summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/mkl-dnn/mkl-dnn_0.17.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-core/mkl-dnn/mkl-dnn_0.17.4.bb b/recipes-core/mkl-dnn/mkl-dnn_0.17.4.bb
new file mode 100644
index 00000000..f2b3ae7d
--- /dev/null
+++ b/recipes-core/mkl-dnn/mkl-dnn_0.17.4.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Intel Math Kernel Library for Deep Neural Networks"
2DESCRIPTION = "This software is a user mode library that accelerates\
3deep-learning applications and frameworks on Intel architecture."
4LICENSE = "Apache-2.0 & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e \
6 file://tests/gtests/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
7 file://src/cpu/xbyak/COPYRIGHT;md5=03532861dad9003cc2c17f14fc7a4efa"
8SECTION = "lib"
9
10inherit pkgconfig cmake
11
12S = "${WORKDIR}/git"
13SRCREV = "722901c9aaefa579698df778d061d4848ab8c3e3"
14SRC_URI = "git://github.com/intel/mkl-dnn.git;branch=rls-v0.17"
15
16COMPATIBLE_HOST = '(x86_64).*-linux'
17COMPATIBLE_HOST_libc-musl = 'null'
18
19EXTRA_OECMAKE += "-DMKLDNN_LIBRARY_TYPE=SHARED"
20EXTRA_OECMAKE += "-DMKLDNN_THREADING=OMP"
21EXTRA_OECMAKE += "-DWITH_EXAMPLE=ON"
22EXTRA_OECMAKE += "-DWITH_TEST=ON"