summaryrefslogtreecommitdiffstats
path: root/recipes-core/mkl-dnn/mkl-dnn_0.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/mkl-dnn/mkl-dnn_0.19.bb')
-rw-r--r--recipes-core/mkl-dnn/mkl-dnn_0.19.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-core/mkl-dnn/mkl-dnn_0.19.bb b/recipes-core/mkl-dnn/mkl-dnn_0.19.bb
new file mode 100644
index 00000000..79c95de7
--- /dev/null
+++ b/recipes-core/mkl-dnn/mkl-dnn_0.19.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Intel Math Kernel Library for Deep Neural Networks"
2DESCRIPTION = "This software is a user mode library that accelerates\
3deep-learning applications and frameworks on Intel architecture."
4LICENSE = "Apache-2.0 & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=afa44a3d001cc203032135324f9636b7 \
6 file://tests/gtests/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
7 file://src/cpu/xbyak/COPYRIGHT;md5=03532861dad9003cc2c17f14fc7a4efa"
8SECTION = "lib"
9
10inherit pkgconfig cmake
11
12S = "${WORKDIR}/git"
13SRCREV = "41bee20d7eb4a67feeeeb8d597b3598994eb1959"
14SRC_URI = "git://github.com/intel/mkl-dnn.git;branch=rls-v0.19"
15
16UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"
17
18COMPATIBLE_HOST = '(x86_64).*-linux'
19COMPATIBLE_HOST_libc-musl = 'null'
20
21EXTRA_OECMAKE += "-DMKLDNN_LIBRARY_TYPE=SHARED"
22EXTRA_OECMAKE += "-DMKLDNN_THREADING=OMP"
23EXTRA_OECMAKE += "-DWITH_EXAMPLE=ON"
24EXTRA_OECMAKE += "-DWITH_TEST=ON"