summaryrefslogtreecommitdiffstats
path: root/recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch')
-rw-r--r--recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch b/recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch
deleted file mode 100644
index 67db3e4c..00000000
--- a/recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 8f8a1d131a05aa1494825f0fae32580cbed680e5 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 25 Jun 2020 14:22:59 +0800
4Subject: [PATCH] test-soft-image.cpp: fix header path
5
6throw compilation error:
7 | ../../git/tests/test-soft-image.cpp:31:10: fatal error: xcore/fisheye_dewarp.h: No such file or directory
8| 31 | #include <xcore/fisheye_dewarp.h>
9| | ^~~~~~~~~~~~~~~~~~~~~~~~
10| compilation terminated.
11
12TEST_BASE_CXXFLAGS already includes -I$(top_srcdir)/xcore
13
14Ref: https://github.com/intel/libxcam/blob/1.4.0/tests/Makefile.am#L48
15
16Upstream-Status: Submitted [https://github.com/intel/libxcam/pull/734]
17Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
18---
19 tests/test-soft-image.cpp | 2 +-
20 1 file changed, 1 insertion(+), 1 deletion(-)
21
22diff --git a/tests/test-soft-image.cpp b/tests/test-soft-image.cpp
23index a9e02d8..1c687e5 100644
24--- a/tests/test-soft-image.cpp
25+++ b/tests/test-soft-image.cpp
26@@ -28,7 +28,7 @@
27 #include <interface/blender.h>
28 #include <interface/geo_mapper.h>
29 #include <interface/stitcher.h>
30-#include <xcore/fisheye_dewarp.h>
31+#include <fisheye_dewarp.h>
32
33 #define MAP_WIDTH 3
34 #define MAP_HEIGHT 4
35--
362.17.1
37