summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ace/ace_6.5.8.bb39
-rw-r--r--recipes-bsp/ace/files/ace_config.patch12
-rw-r--r--recipes-bsp/formfactor/formfactor_0.0.bbappend2
-rw-r--r--recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb29
-rw-r--r--recipes-bsp/metee/metee_3.2.4.bb (renamed from recipes-bsp/metee/metee_2.2.0.bb)5
-rw-r--r--recipes-bsp/systemd-boot/systemd-boot_%.bbappend9
-rw-r--r--recipes-bsp/thermald/thermald/0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch51
-rw-r--r--recipes-bsp/thermald/thermald_1.9.1.bb35
8 files changed, 33 insertions, 149 deletions
diff --git a/recipes-bsp/ace/ace_6.5.8.bb b/recipes-bsp/ace/ace_6.5.8.bb
deleted file mode 100644
index 87197aef..00000000
--- a/recipes-bsp/ace/ace_6.5.8.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1SUMMARY = "C++ framework for implementing distributed and networked applications"
2DESCRIPTION = "C++ network programming framework that implements many core \
3patterns for concurrent communication software"
4LICENSE = "ACE-TAO-CIAO"
5HOMEPAGE = "http://www.dre.vanderbilt.edu/~schmidt/ACE.html"
6LIC_FILES_CHKSUM = "file://COPYING;md5=96ef88a5529594698e8ceabdd47df92c"
7
8DEPENDS += "openssl gperf-native"
9
10SRC_URI = "https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-6_5_8/ACE-${PV}.tar.bz2 \
11 file://ace_config.patch \
12 "
13
14SRC_URI[md5sum] = "a6ba6a944612fe0696c90cbb5c3078ee"
15SRC_URI[sha256sum] = "cda2a960dbb9970a907663627711b2e2b14b3484a2859ae936370bcad0b16923"
16
17COMPATIBLE_HOST_libc-musl = "null"
18
19S = "${WORKDIR}/ACE_wrappers"
20B = "${WORKDIR}/ACE_wrappers/ace"
21export ACE_ROOT="${WORKDIR}/ACE_wrappers"
22
23inherit pkgconfig
24
25CXXFLAGS_append = " -fpermissive -Wnodeprecated-declarations"
26
27do_install() {
28 export D="${D}"
29 oe_runmake install
30
31 for i in $(find ${D} -name "*.pc") ; do
32 sed -i -e s:${D}::g \
33 -e s:/${TARGET_SYS}::g \
34 $i
35 done
36
37 rm -r ${D}/usr/share
38}
39
diff --git a/recipes-bsp/ace/files/ace_config.patch b/recipes-bsp/ace/files/ace_config.patch
deleted file mode 100644
index 207b85ab..00000000
--- a/recipes-bsp/ace/files/ace_config.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1diff -ruN ACE_wrappers1/ace/config.h ACE_wrappers/ace/config.h
2--- ACE_wrappers1/ace/config.h 1970-01-01 02:00:00.000000000 +0200
3+++ ACE_wrappers/ace/config.h 2019-01-10 13:36:52.698012477 +0200
4@@ -0,0 +1,1 @@
5+#include "ace/config-linux.h"
6diff -ruN ACE_wrappers1/include/makeinclude/platform_macros.GNU ACE_wrappers/include/makeinclude/platform_macros.GNU
7--- ACE_wrappers1/include/makeinclude/platform_macros.GNU 1970-01-01 02:00:00.000000000 +0200
8+++ ACE_wrappers/include/makeinclude/platform_macros.GNU 2018-10-31 15:11:18.265392460 +0200
9@@ -0,0 +1,3 @@
10+INSTALL_PREFIX = $(D)$(exec_prefix)
11+INSTALL_LIB = $(base_libdir)
12+include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU
diff --git a/recipes-bsp/formfactor/formfactor_0.0.bbappend b/recipes-bsp/formfactor/formfactor_0.0.bbappend
index 6dd422ae..d21c3bee 100644
--- a/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ b/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -1 +1 @@
FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" FILESEXTRAPATHS:prepend:intel-x86-common := "${THISDIR}/${PN}:"
diff --git a/recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb b/recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb
new file mode 100644
index 00000000..60d0dfd2
--- /dev/null
+++ b/recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "intel-cmt-cat"
2DESCRIPTION = "Software package which provides basic support for Intel(R) \
3Resource Director Technology (Intel(R) RDT)"
4HOMEPAGE = "https://github.com/intel/intel-cmt-cat"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=4b63c65942e1c16fd897f8cd20abebf8"
8
9SRC_URI = "git://github.com/intel/intel-cmt-cat;protocol=https;branch=master"
10SRCREV = "b26b31b0ae6980c5939a421cefe0316cae884626"
11
12S = "${WORKDIR}/git"
13
14COMPATIBLE_HOST = '(x86_64).*-linux'
15COMPATIBLE_HOST:libc-musl = "null"
16
17do_install() {
18 oe_runmake install PREFIX=${D}${prefix} NOLDCONFIG=y
19}
20
21FILES:${PN} += "${nonarch_libdir}/libpqos*"
22FILES:${PN}-doc = "/usr/man*"
23
24INSANE_SKIP:${PN} += "ldflags"
25INSANE_SKIP:${PN} += "dev-so"
26INSANE_SKIP:${PN} += "libdir"
27INSANE_SKIP:${PN} += "already-stripped"
28
29INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
diff --git a/recipes-bsp/metee/metee_2.2.0.bb b/recipes-bsp/metee/metee_3.2.4.bb
index d0a4556d..da8220b9 100644
--- a/recipes-bsp/metee/metee_2.2.0.bb
+++ b/recipes-bsp/metee/metee_3.2.4.bb
@@ -10,8 +10,9 @@ COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10 10
11inherit cmake 11inherit cmake
12 12
13SRC_URI = "git://github.com/intel/metee.git" 13SRC_URI = "git://github.com/intel/metee.git;branch=master;protocol=https \
14SRCREV = "2d6989803c4785b7c3e0ca38030b73e46ae07232" 14"
15SRCREV = "db45e37e146fd9c06907a15ade55eba06ad1f951"
15 16
16S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
17 18
diff --git a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
deleted file mode 100644
index d2e1c16b..00000000
--- a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
1PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
2
3do_compile_append_intel-x86-common() {
4 ninja src/boot/efi/linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
5}
6
7do_deploy_append_intel-x86-common() {
8 install ${B}/src/boot/efi/linux*.efi.stub ${DEPLOYDIR}
9}
diff --git a/recipes-bsp/thermald/thermald/0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch b/recipes-bsp/thermald/thermald/0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch
deleted file mode 100644
index ee3c5e5e..00000000
--- a/recipes-bsp/thermald/thermald/0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From 2145c92fb2ee6d1b03b9ea92e0f910e60b925d70 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 5 Mar 2020 13:45:57 +0800
4Subject: [PATCH] thd_trip_point: fix 32-bit build error with musl v1.2.0
5
6Error log:
7 ../git/src/thd_trip_point.cpp: In member function 'bool cthd_trip_point::thd_trip_point_check(int, unsigned int, int, bool*)':
8| ../git/src/thd_trip_point.cpp:250:19: error: format '%ld' expects argument of type 'long int', but argument 6 has type 'time_t' {aka 'long long int'} [-Werror=format=]
9| 250 | thd_log_info("Too early to act zone:%d index %d tm %ld\n",
10
11musl 1.2.0 have new feature:
12time_t is now 64-bit on all archs (not just 64-bit archs)
13
14Commit id:
15https://git.musl-libc.org/cgit/musl/commit/?id=38143339646a4ccce8afe298c34467767c899f51
16
17Release note link for musl 1.2.0:
18https://git.musl-libc.org/cgit/musl/diff/
19
20Upstream-Status: Submitted [https://github.com/intel/thermal_daemon/pull/217]
21
22Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
23---
24 src/thd_trip_point.cpp | 10 ++--------
25 1 file changed, 2 insertions(+), 8 deletions(-)
26
27diff --git a/src/thd_trip_point.cpp b/src/thd_trip_point.cpp
28index 043be0c..2186ac2 100644
29--- a/src/thd_trip_point.cpp
30+++ b/src/thd_trip_point.cpp
31@@ -242,15 +242,9 @@ bool cthd_trip_point::thd_trip_point_check(int id, unsigned int read_temp,
32 time_t tm;
33 time(&tm);
34 if ((tm - cdevs[i].last_op_time) < cdevs[i].sampling_priod) {
35-#if defined __x86_64__ && defined __ILP32__
36- thd_log_info("Too early to act zone:%d index %d tm %lld\n",
37+ thd_log_info("Too early to act zone:%d index %d tm %jd\n",
38 zone_id, cdev->thd_cdev_get_index(),
39- tm - cdevs[i].last_op_time);
40-#else
41- thd_log_info("Too early to act zone:%d index %d tm %ld\n",
42- zone_id, cdev->thd_cdev_get_index(),
43- tm - cdevs[i].last_op_time);
44-#endif
45+ (intmax_t)tm - cdevs[i].last_op_time);
46 break;
47 }
48 cdevs[i].last_op_time = tm;
49--
502.17.1
51
diff --git a/recipes-bsp/thermald/thermald_1.9.1.bb b/recipes-bsp/thermald/thermald_1.9.1.bb
deleted file mode 100644
index be68aa48..00000000
--- a/recipes-bsp/thermald/thermald_1.9.1.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11DEPENDS_append_libc-musl = " argp-standalone"
12DEPENDS_append_toolchain-clang = " openmp"
13LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15
16SRC_URI = "git://github.com/intel/thermal_daemon/ \
17 file://0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch \
18 "
19SRCREV = "7e23f7cc4611fd7289014c9805749ec75d59bae0"
20S = "${WORKDIR}/git"
21
22inherit pkgconfig autotools systemd
23
24FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
25
26SYSTEMD_SERVICE_${PN} = "thermald.service"
27
28COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
29
30CONFFILES_${PN} = " \
31 ${sysconfdir}/thermald/thermal-conf.xml \
32 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
33 "
34
35UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"