diff options
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc | 1 | ||||
-rw-r--r-- | recipes-bsp/systemd-boot/systemd-boot/systemd-boot.inc | 6 | ||||
-rw-r--r-- | recipes-bsp/systemd-boot/systemd-boot_%.bbappend | 7 |
3 files changed, 6 insertions, 8 deletions
diff --git a/recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc b/recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc index aea22499..11fddaf9 100644 --- a/recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc +++ b/recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc | |||
@@ -17,6 +17,5 @@ SRC_URI_append_intel-x86-common = " \ | |||
17 | file://0002-sd-boot-Load-board-specific-boot-entries-from-RMC-da.patch \ | 17 | file://0002-sd-boot-Load-board-specific-boot-entries-from-RMC-da.patch \ |
18 | file://0003-sd-boot-Support-global-kernel-command-line-fragment.patch \ | 18 | file://0003-sd-boot-Support-global-kernel-command-line-fragment.patch \ |
19 | file://0004-sd-boot-Support-global-kernel-command-line-fragment-in-EFI-stub.patch \ | 19 | file://0004-sd-boot-Support-global-kernel-command-line-fragment-in-EFI-stub.patch \ |
20 | file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \ | ||
21 | file://0001-sd-boot-stub-check-LoadOptions-contains-data.patch \ | 20 | file://0001-sd-boot-stub-check-LoadOptions-contains-data.patch \ |
22 | " | 21 | " |
diff --git a/recipes-bsp/systemd-boot/systemd-boot/systemd-boot.inc b/recipes-bsp/systemd-boot/systemd-boot/systemd-boot.inc deleted file mode 100644 index 788e57af..00000000 --- a/recipes-bsp/systemd-boot/systemd-boot/systemd-boot.inc +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | EXTRA_OEMAKE_append_intel-x86-common = ' EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" ' | ||
2 | |||
3 | SRC_URI_append_intel-x86-common = " \ | ||
4 | file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \ | ||
5 | " | ||
6 | |||
diff --git a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend index 48968116..9e6cc161 100644 --- a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend +++ b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend | |||
@@ -1,6 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/systemd-boot:" | 1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/systemd-boot:" |
2 | 2 | ||
3 | include systemd-boot/${EFI_PROVIDER}.inc | 3 | SRC_URI_append_intel-x86-common = " \ |
4 | file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \ | ||
5 | " | ||
4 | 6 | ||
5 | PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}" | 7 | PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}" |
6 | 8 | ||
@@ -11,3 +13,6 @@ do_compile_append_intel-x86-common() { | |||
11 | do_deploy_append_intel-x86-common() { | 13 | do_deploy_append_intel-x86-common() { |
12 | install ${B}/linux*.efi.stub ${DEPLOYDIR} | 14 | install ${B}/linux*.efi.stub ${DEPLOYDIR} |
13 | } | 15 | } |
16 | |||
17 | # includes rmc-boot.inc if rmc-boot is the EFI_PROVIDER | ||
18 | include systemd-boot/${EFI_PROVIDER}.inc | ||