summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/thermald/thermald_1.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/thermald/thermald_1.7.1.bb')
-rw-r--r--recipes-bsp/thermald/thermald_1.7.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/thermald/thermald_1.7.1.bb b/recipes-bsp/thermald/thermald_1.7.1.bb
new file mode 100644
index 00000000..c3a43f46
--- /dev/null
+++ b/recipes-bsp/thermald/thermald_1.7.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11DEPENDS_append_libc-musl = " argp-standalone"
12DEPENDS_append_toolchain-clang = " openmp"
13LICENSE = "GPL-2.0"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15
16SRC_URI = "git://github.com/intel/thermal_daemon/ \
17 file://0001-Include-poll.h-instead-of-sys-poll.h.patch \
18 file://0002-Use-correct-format-specifier-for-X32.patch \
19 "
20SRCREV = "c0d224b7b5cf62d384f5ad0a29bfaaba4bdc4ac1"
21S = "${WORKDIR}/git"
22
23inherit pkgconfig autotools systemd
24
25FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
26
27SYSTEMD_SERVICE_${PN} = "thermald.service"
28
29COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
30
31CONFFILES_${PN} = " \
32 ${sysconfdir}/thermald/thermal-conf.xml \
33 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
34 "
35
36UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"