summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/efilinux/efilinux/0001-Disable-address-of-packed-member-warning.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/efilinux/efilinux/0001-Disable-address-of-packed-member-warning.patch')
-rw-r--r--recipes-bsp/efilinux/efilinux/0001-Disable-address-of-packed-member-warning.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/efilinux/efilinux/0001-Disable-address-of-packed-member-warning.patch b/recipes-bsp/efilinux/efilinux/0001-Disable-address-of-packed-member-warning.patch
new file mode 100644
index 00000000..afb99514
--- /dev/null
+++ b/recipes-bsp/efilinux/efilinux/0001-Disable-address-of-packed-member-warning.patch
@@ -0,0 +1,33 @@
1From 7c171c1813651a3a02ad2cda361b42ebc7ce324d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 12 Aug 2017 10:34:19 -0700
4Subject: [PATCH 1/2] Disable address-of-packed-member warning
5
6Clang complains so make it happy
7
8loaders/bzimage/bzimage.c:346:55: error: taking address of packed member 'base' of class or structure 'dt_addr_t' may result in an unaligned pointer value [-Werror,-Waddress-of-packed-member]
9 err = emalloc(gdt.limit, 8, (EFI_PHYSICAL_ADDRESS *)&gdt.base);
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13Upstream-Status: Pending
14
15 Makefile | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/Makefile b/Makefile
19index a955e34..ff1b79b 100644
20--- a/Makefile
21+++ b/Makefile
22@@ -61,7 +61,7 @@ ifeq ($(ARCH),ia32)
23 endif
24 endif
25 ifeq ($(ARCH),x86_64)
26- CFLAGS += -mno-red-zone
27+ CFLAGS += -mno-red-zone -Wno-address-of-packed-member
28 endif
29
30 LDFLAGS=-T $(LDSCRIPT) -Bsymbolic -shared -nostdlib -znocombreloc \
31--
322.14.1
33