summaryrefslogtreecommitdiffstats
path: root/meta-romley
diff options
context:
space:
mode:
Diffstat (limited to 'meta-romley')
-rw-r--r--meta-romley/README22
-rw-r--r--meta-romley/conf/machine/romley-ivb.conf20
-rw-r--r--meta-romley/recipes-bsp/formfactor/formfactor/romley-ivb/machconfig3
-rw-r--r--meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley-ivb/xorg.conf26
-rw-r--r--meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend7
5 files changed, 73 insertions, 5 deletions
diff --git a/meta-romley/README b/meta-romley/README
index f1a9bb0a..ffad2971 100644
--- a/meta-romley/README
+++ b/meta-romley/README
@@ -2,10 +2,18 @@ This README file contains information on building the meta-romley
2BSP layer, and booting the images contained in the /binary directory. 2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details. 3Please see the corresponding sections below for details.
4 4
5The 'romley' platform consists of the Intel Xeon E5-2600 and E5-2400 5The romley platform consists of two versions:
6Series Processors, plus the Intel C604/C602-J Chipset 61. romley - Sandy Bridge
72. romley - Ivy Bridge
8
9The romley - Sandy Bridge platform consists of the Intel Xeon E5-2600
10and E5-2400 Series processors, plus the Intel C604/C602-J chipset
7(Sandy Bridge-EP/EN + Patsburg). 11(Sandy Bridge-EP/EN + Patsburg).
8 12
13The romley - Ivy Bridge platform consists of the Intel Xeon E5-2600
14and E5-2400 v2 Series processors with the Intel C604/C602-J chipset
15(Ivy Bridge-EP/EN + Patsburg).
16
9This BSP assumes Matrox graphics is being used. 17This BSP assumes Matrox graphics is being used.
10 18
11Further information about the platforms supported by this BSP can be 19Further information about the platforms supported by this BSP can be
@@ -25,6 +33,7 @@ listed here:
25 33
26 https://www.yoctoproject.org/webform/yocto-project-compatible-registration 34 https://www.yoctoproject.org/webform/yocto-project-compatible-registration
27 35
36
28Dependencies 37Dependencies
29============ 38============
30 39
@@ -76,10 +85,14 @@ common metadata shared between BSPs) e.g.:
76 yocto/meta-intel \ 85 yocto/meta-intel \
77 yocto/meta-intel/meta-romley \ 86 yocto/meta-intel/meta-romley \
78 87
79To enable the romley layer, add the romley MACHINE to local.conf: 88To enable the romley Sandy Bridge layer, add the romley MACHINE to local.conf:
80 89
81 MACHINE ?= "romley" 90 MACHINE ?= "romley"
82 91
92To enable the romley Ivy Bridge layer, add the romley-ivb MACHINE to local.conf:
93
94 MACHINE ?= "romley-ivb"
95
83You should then be able to build a romley image as such: 96You should then be able to build a romley image as such:
84 97
85 $ source oe-init-build-env 98 $ source oe-init-build-env
@@ -127,6 +140,7 @@ ifconfig the IP address and use that to ssh in. The root password is
127empty, so to log in type 'root' for the user name and hit 'Enter' at 140empty, so to log in type 'root' for the user name and hit 'Enter' at
128the Password prompt: and you should be in. 141the Password prompt: and you should be in.
129 142
143
130III. Enabling Intel DPDK Technology 144III. Enabling Intel DPDK Technology
131=================================== 145===================================
132 146
@@ -142,5 +156,3 @@ the syslinux boot: prompt, or the boot: prompt contains strange
142characters), try doing this first: 156characters), try doing this first:
143 157
144# dd if=/dev/zero of=/dev/sdf bs=1M count=512 158# dd if=/dev/zero of=/dev/sdf bs=1M count=512
145
146
diff --git a/meta-romley/conf/machine/romley-ivb.conf b/meta-romley/conf/machine/romley-ivb.conf
new file mode 100644
index 00000000..bf9dd9f0
--- /dev/null
+++ b/meta-romley/conf/machine/romley-ivb.conf
@@ -0,0 +1,20 @@
1#@TYPE: Machine
2#@NAME: romley-ivb
3
4#@WEBTITLE: Intel Xeon E5-2600 and E5-2400 v2 Series (Formerly Ivy Bridge-EP/EN)
5#Processors with Intel C604/C602-J Chipset (Romley-EP/EN Platform)
6
7#@DESCRIPTION: Machine configuration for Romley systems
8# i.e. Xeon E5-2600 and E5-2400 + Intel CC604/C602-J
9
10
11PREFERRED_VERSION_linux-yocto ?= "3.4%"
12
13require conf/machine/include/tune-x86_64.inc
14require conf/machine/include/ia32-base.inc
15require conf/machine/include/meta-intel.inc
16
17XSERVER ?= "${XSERVER_IA32_BASE} \
18 ${XSERVER_IA32_EXT} \
19 ${XSERVER_IA32_MATROX_MGA} \
20 "
diff --git a/meta-romley/recipes-bsp/formfactor/formfactor/romley-ivb/machconfig b/meta-romley/recipes-bsp/formfactor/formfactor/romley-ivb/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-romley/recipes-bsp/formfactor/formfactor/romley-ivb/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley-ivb/xorg.conf b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley-ivb/xorg.conf
new file mode 100644
index 00000000..28ad0bf7
--- /dev/null
+++ b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley-ivb/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Matrox MGA"
3 Driver "mga"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Matrox MGA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 44a485b2..fc2c3037 100644
--- a/meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -8,6 +8,13 @@ KBRANCH_romley = "standard/common-pc-64/romley"
8SRCREV_machine_pn-linux-yocto_romley ?= "13809f2cfd9be0ce86bd486e1643f9b90bed6f4f" 8SRCREV_machine_pn-linux-yocto_romley ?= "13809f2cfd9be0ce86bd486e1643f9b90bed6f4f"
9SRCREV_meta_pn-linux-yocto_romley ?= "f697e099bc76d5df3a307a5bc0cc25021dd6dfe0" 9SRCREV_meta_pn-linux-yocto_romley ?= "f697e099bc76d5df3a307a5bc0cc25021dd6dfe0"
10 10
11COMPATIBLE_MACHINE_romley-ivb = "romley-ivb"
12KMACHINE_romley-ivb = "romley"
13KBRANCH_romley-ivb = "standard/common-pc-64/romley"
14
15SRCREV_machine_pn-linux-yocto_romley-ivb ?= "13809f2cfd9be0ce86bd486e1643f9b90bed6f4f"
16SRCREV_meta_pn-linux-yocto_romley-ivb ?= "f697e099bc76d5df3a307a5bc0cc25021dd6dfe0"
17
11module_autoload_uio = "uio" 18module_autoload_uio = "uio"
12 19
13LINUX_VERSION = "3.4.28" 20LINUX_VERSION = "3.4.28"