summaryrefslogtreecommitdiffstats
path: root/meta-nuc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-nuc')
-rw-r--r--meta-nuc/COPYING.MIT17
-rw-r--r--meta-nuc/README156
-rw-r--r--meta-nuc/README.sources17
-rw-r--r--meta-nuc/conf/layer.conf10
-rw-r--r--meta-nuc/conf/machine/nuc.conf27
-rw-r--r--meta-nuc/recipes-bsp/alsa-state/alsa-state.bbappend1
-rw-r--r--meta-nuc/recipes-bsp/alsa-state/alsa-state/nuc/asound.conf24
-rw-r--r--meta-nuc/recipes-bsp/formfactor/formfactor/nuc/machconfig3
-rw-r--r--meta-nuc/recipes-bsp/formfactor/formfactor_0.0.bbappend1
-rw-r--r--meta-nuc/recipes-core/initscripts/initscripts/hdmi_port_audio.sh28
-rw-r--r--meta-nuc/recipes-core/initscripts/initscripts_1.0.bbappend10
11 files changed, 0 insertions, 294 deletions
diff --git a/meta-nuc/COPYING.MIT b/meta-nuc/COPYING.MIT
deleted file mode 100644
index 89de3547..00000000
--- a/meta-nuc/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-nuc/README b/meta-nuc/README
deleted file mode 100644
index 7753755e..00000000
--- a/meta-nuc/README
+++ /dev/null
@@ -1,156 +0,0 @@
1This README file contains information on building the meta-nuc
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5This BSP is made specifically for "Next Unit of Computing Kit DC3217IYE"
6with Intel Centrino Advanced-N 6235 Wireless mini PCI Express card.
7
8Further information on this NUC platform can be found here:
9
10 http://www.intel.com/content/www/us/en/motherboards/desktop-motherboards/desktop-boards-d33217gke-dc3217iye.html
11
12Information on all IntelĀ® embedded platforms can be found here:
13
14 http://www.intel.com/p/en_US/embedded/hwsw/hardware
15
16
17Yocto Project Compatible
18========================
19
20This BSP is compatible with the Yocto Project as per the requirements
21listed here:
22
23 https://www.yoctoproject.org/webform/yocto-project-compatible-registration
24
25
26Dependencies
27============
28
29This layer depends on:
30
31 URI: git://git.openembedded.org/bitbake
32 branch: master
33
34 URI: git://git.openembedded.org/openembedded-core
35 layers: meta
36 branch: master
37
38 URI: git://git.yoctoproject.org/meta-intel
39 layers: intel
40 branch: master
41
42
43Patches
44=======
45
46Please submit any patches against this BSP to the meta-intel mailing list
47(meta-intel@yoctoproject.org) and cc: the maintainer:
48
49Maintainer: Saul Wold <sgw@linux.intel.com>
50
51Please see the meta-intel/MAINTAINERS file for more details.
52
53
54Table of Contents
55=================
56
57 I. Building the meta-nuc BSP layer
58 II. Booting the images in /binary
59
60
61I. Building the meta-nuc BSP layer
62=========================================
63
64In order to build an image with BSP support for a given release, you
65need to download the corresponding BSP tarball from the 'Board Support
66Package (BSP) Downloads' page of the Yocto Project website.
67
68Having done that, and assuming you extracted the BSP tarball contents
69at the top-level of your yocto build tree, you can build a nuc
70image by adding the location of the meta-nuc layer to
71bblayers.conf, along with the meta-intel layer itself (to access
72common metadata shared between BSPs) e.g.:
73
74 yocto/meta-intel \
75 yocto/meta-intel/meta-nuc \
76
77To enable the nuc layer, add the nuc MACHINE to local.conf:
78
79 MACHINE ?= "nuc"
80
81You should then be able to build a nuc image as such:
82
83 $ source oe-init-build-env
84 $ bitbake core-image-sato
85
86At the end of a successful build, you should have a live image that
87you can boot from a USB flash drive (see instructions on how to do
88that below, in the section 'Booting the images from /binary').
89
90NOTE: The 'nuc' machine will include support for hardware video
91acceleration via gstreamer if and only if the "commercial" string is
92added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
93
94For example:
95
96 LICENSE_FLAGS_WHITELIST = "commercial"
97
98The reason this is needed is to prevent the image from including
99anything that might violate the license terms of the packages used to
100implement the the video acceleration feature, such as gst-ffmpeg and
101ffmpeg. As always, please consult the licenses included in the
102specific packages for details if you use packages that require
103particular LICENSE_FLAGS.
104
105The xf86-video-intel recipe depends on Xorg's dri and glx modules,
106which are built only when 'opengl' is listed in DISTRO_FEATURES. So
107if the distro doesn't list 'opengl' in the DISTRO_FEATURES, then you
108would need this additional line in your local.conf:
109
110 DISTRO_FEATURES_append = " opengl"
111
112As an alternative to downloading the BSP tarball, you can also work
113directly from the meta-intel git repository. For each BSP in the
114'meta-intel' repository, there are multiple branches, one
115corresponding to each major release starting with 'laverne' (0.90), in
116addition to the latest code which tracks the current master (note that
117not all BSPs are present in every release). Instead of extracting a
118BSP tarball at the top level of your yocto build tree, you can
119equivalently check out the appropriate branch from the meta-intel
120repository at the same location.
121
122
123II. Booting the images in /binary
124=================================
125
126This BSP contains bootable live images, which can be used to directly
127boot Yocto off of a USB flash drive.
128
129Under Linux, insert a USB flash drive. Assuming the USB flash drive
130takes device /dev/sdf, use dd to copy the live image to it. For
131example:
132
133# dd if=core-image-sato-nuc.hddimg of=/dev/sdf
134# sync
135# eject /dev/sdf
136
137This should give you a bootable USB flash device. Insert the device
138into a bootable USB socket on the target, and power on. This should
139result in a system booted to the Sato graphical desktop.
140
141If you want a terminal, use the arrows at the top of the UI to move to
142different pages of available applications, one of which is named
143'Terminal'. Clicking that should give you a root terminal.
144
145If you want to ssh into the system, you can use the root terminal to
146ifconfig the IP address and use that to ssh in. The root password is
147empty, so to log in type 'root' for the user name and hit 'Enter' at
148the Password prompt: and you should be in.
149
150----
151
152If you find you're getting corrupt images on the USB (it doesn't show
153the syslinux boot: prompt, or the boot: prompt contains strange
154characters), try doing this first:
155
156# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-nuc/README.sources b/meta-nuc/README.sources
deleted file mode 100644
index 0d4d849a..00000000
--- a/meta-nuc/README.sources
+++ /dev/null
@@ -1,17 +0,0 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://downloads.yoctoproject.org/releases/yocto/yocto-1.3/poky-danny-8.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-nuc/conf/layer.conf b/meta-nuc/conf/layer.conf
deleted file mode 100644
index 174411ff..00000000
--- a/meta-nuc/conf/layer.conf
+++ /dev/null
@@ -1,10 +0,0 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "nuc"
9BBFILE_PATTERN_nuc := "^${LAYERDIR}/"
10BBFILE_PRIORITY_nuc = "6"
diff --git a/meta-nuc/conf/machine/nuc.conf b/meta-nuc/conf/machine/nuc.conf
deleted file mode 100644
index bdc4bca1..00000000
--- a/meta-nuc/conf/machine/nuc.conf
+++ /dev/null
@@ -1,27 +0,0 @@
1#@TYPE: Machine
2#@NAME: chiefriver
3
4#@WEBTITLE: Intel Next Unit of Computing (NUC) Model: DC3217IYE
5
6#@DESCRIPTION: Machine configuration for Intel NUC model DC3217IYE
7# i.e. Ivy Bridge + Panther Point
8
9PREFERRED_VERSION_linux-yocto ?= "3.19%"
10MACHINE_FEATURES += "va-impl-intel wifi efi"
11MACHINE_FEATURES += "intel-ucode"
12
13require conf/machine/include/meta-intel.inc
14require conf/machine/include/intel-corei7-64-common.inc
15require conf/machine/include/intel-common-pkgarch.inc
16
17MACHINE_HWCODECS ?= "va-intel gstreamer-vaapi-1.0"
18
19XSERVER ?= "${XSERVER_X86_BASE} \
20 ${XSERVER_X86_EXT} \
21 ${XSERVER_X86_I965} \
22 "
23
24MACHINE_EXTRA_RRECOMMENDS += "linux-firmware-iwlwifi-6000g2b-6 lms8"
25
26# disable the serial port configuration
27SERIAL_CONSOLE = ""
diff --git a/meta-nuc/recipes-bsp/alsa-state/alsa-state.bbappend b/meta-nuc/recipes-bsp/alsa-state/alsa-state.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-nuc/recipes-bsp/alsa-state/alsa-state.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-nuc/recipes-bsp/alsa-state/alsa-state/nuc/asound.conf b/meta-nuc/recipes-bsp/alsa-state/alsa-state/nuc/asound.conf
deleted file mode 100644
index 1defe77d..00000000
--- a/meta-nuc/recipes-bsp/alsa-state/alsa-state/nuc/asound.conf
+++ /dev/null
@@ -1,24 +0,0 @@
1pcm.!default {
2 type plug
3 slave.pcm "dmixer"
4}
5
6pcm.dmixer {
7 type dmix
8 ipc_key 1024
9 ipc_key_add_uid 0
10 ipc_perm 0666
11 slave {
12 pcm "hw:0,3" # HDMI CARD AND DEVICE
13 period_time 0
14 period_size 1024
15 buffer_size 8192
16 rate 48000 #or 44100
17 }
18}
19
20ctl.dmixer {
21 type hw
22 card 0
23}
24
diff --git a/meta-nuc/recipes-bsp/formfactor/formfactor/nuc/machconfig b/meta-nuc/recipes-bsp/formfactor/formfactor/nuc/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-nuc/recipes-bsp/formfactor/formfactor/nuc/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-nuc/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-nuc/recipes-bsp/formfactor/formfactor_0.0.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-nuc/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-nuc/recipes-core/initscripts/initscripts/hdmi_port_audio.sh b/meta-nuc/recipes-core/initscripts/initscripts/hdmi_port_audio.sh
deleted file mode 100644
index 69d8a53f..00000000
--- a/meta-nuc/recipes-core/initscripts/initscripts/hdmi_port_audio.sh
+++ /dev/null
@@ -1,28 +0,0 @@
1#!/bin/sh
2### BEGIN INIT INFO
3# Provides:
4# Required-Start:
5# Required-Stop:
6# Default-Start: S
7# Default-Stop:
8# Short-Description: Configure ALSA audio output to the connected HDMI port
9### END INIT INFO
10
11#
12# If both HDMI ports are connected then use HDMI0 for default ALSA audio out..
13
14ALSA_CONF_FILE="/etc/asound.conf"
15
16HDMI0_STATUS_FILE="/sys/class/drm/card0-HDMI-A-1/status"
17HDMI1_STATUS_FILE="/sys/class/drm/card0-HDMI-A-2/status"
18
19HDMI0_ALSA_CONF="hw:0,3"
20HDMI1_ALSA_CONF="hw:0,7"
21
22if [ -f "${HDMI0_STATUS_FILE}" ] && [ "`cat ${HDMI0_STATUS_FILE}`" == "connected" ]
23then
24 sed -i "s/pcm *\"hw:[0-9]*,[0-9]*\"/pcm \"${HDMI0_ALSA_CONF}\"/" ${ALSA_CONF_FILE}
25elif [ -f "${HDMI1_STATUS_FILE}" ] && [ "`cat ${HDMI1_STATUS_FILE}`" == "connected" ]
26then
27 sed -i "s/pcm \"hw:[0-9]*,[0-9]*\"/pcm \"${HDMI1_ALSA_CONF}\"/" ${ALSA_CONF_FILE}
28fi
diff --git a/meta-nuc/recipes-core/initscripts/initscripts_1.0.bbappend b/meta-nuc/recipes-core/initscripts/initscripts_1.0.bbappend
deleted file mode 100644
index abc5fe01..00000000
--- a/meta-nuc/recipes-core/initscripts/initscripts_1.0.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://hdmi_port_audio.sh"
4
5PR .= ".1"
6
7do_install_append() {
8 install -m 0755 ${WORKDIR}/hdmi_port_audio.sh ${D}${sysconfdir}/init.d
9 ln -sf ../init.d/hdmi_port_audio.sh ${D}${sysconfdir}/rcS.d/S66hdmi_port_audio.sh
10}