summaryrefslogtreecommitdiffstats
path: root/meta-nuc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-nuc')
-rw-r--r--meta-nuc/COPYING.MIT17
-rw-r--r--meta-nuc/README149
-rw-r--r--meta-nuc/README.sources17
-rw-r--r--meta-nuc/conf/layer.conf10
4 files changed, 193 insertions, 0 deletions
diff --git a/meta-nuc/COPYING.MIT b/meta-nuc/COPYING.MIT
new file mode 100644
index 00000000..89de3547
--- /dev/null
+++ b/meta-nuc/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-nuc/README b/meta-nuc/README
new file mode 100644
index 00000000..3b68609f
--- /dev/null
+++ b/meta-nuc/README
@@ -0,0 +1,149 @@
1This README file contains information on building the meta-nuc
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5This BSP is made specifically for "Next Unit of Computing Kit DC3217IYE"
6with Intel Centrino Advanced-N 6235 Wireless mini PCI Express card.
7
8Further information on this NUC platform can be found here:
9
10 http://www.intel.com/content/www/us/en/motherboards/desktop-motherboards/desktop-boards-d33217gke-dc3217iye.html
11
12Information on all IntelĀ® embedded platforms can be found here:
13
14 http://www.intel.com/p/en_US/embedded/hwsw/hardware
15
16
17Compliance
18==========
19
20This BSP is compliant with the Yocto Project as per the requirements
21listed here:
22
23 http://www.yoctoproject.org/yocto-project-compatible-registration
24
25
26Dependencies
27============
28
29This layer depends on:
30
31 URI: git://git.openembedded.org/bitbake
32 branch: master
33
34 URI: git://git.openembedded.org/openembedded-core
35 layers: meta
36 branch: master
37
38 URI: git://git.yoctoproject.org/meta-intel
39 layers: intel
40 branch: master
41
42
43Patches
44=======
45
46Please submit any patches against this BSP to the Yocto mailing list
47(yocto@yoctoproject.org) and cc: the maintainer:
48
49Maintainer: Nitin A Kamble <nitin.a.kamble@intel.com>
50
51Please see the meta-intel/MAINTAINERS file for more details.
52
53
54Table of Contents
55=================
56
57 I. Building the meta-nuc BSP layer
58 II. Booting the images in /binary
59
60
61I. Building the meta-nuc BSP layer
62=========================================
63
64In order to build an image with BSP support for a given release, you
65need to download the corresponding BSP tarball from the 'Board Support
66Package (BSP) Downloads' page of the Yocto Project website.
67
68Having done that, and assuming you extracted the BSP tarball contents
69at the top-level of your yocto build tree, you can build a nuc
70image by adding the location of the meta-nuc layer to
71bblayers.conf, along with the meta-intel layer itself (to access
72common metadata shared between BSPs) e.g.:
73
74 yocto/meta-intel \
75 yocto/meta-intel/meta-nuc \
76
77To enable the nuc layer, add the nuc MACHINE to local.conf:
78
79 MACHINE ?= "nuc"
80
81You should then be able to build a nuc image as such:
82
83 $ source oe-init-build-env
84 $ bitbake core-image-sato
85
86At the end of a successful build, you should have a live image that
87you can boot from a USB flash drive (see instructions on how to do
88that below, in the section 'Booting the images from /binary').
89
90NOTE: The 'nuc' machine will include support for hardware video
91acceleration via gstreamer if and only if the "commercial" string is
92added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
93
94For example:
95
96 LICENSE_FLAGS_WHITELIST = "commercial"
97
98The reason this is needed is to prevent the image from including
99anything that might violate the license terms of the packages used to
100implement the the video acceleration feature, such as gst-ffmpeg and
101ffmpeg. As always, please consult the licenses included in the
102specific packages for details if you use packages that require
103particular LICENSE_FLAGS.
104
105As an alternative to downloading the BSP tarball, you can also work
106directly from the meta-intel git repository. For each BSP in the
107'meta-intel' repository, there are multiple branches, one
108corresponding to each major release starting with 'laverne' (0.90), in
109addition to the latest code which tracks the current master (note that
110not all BSPs are present in every release). Instead of extracting a
111BSP tarball at the top level of your yocto build tree, you can
112equivalently check out the appropriate branch from the meta-intel
113repository at the same location.
114
115
116II. Booting the images in /binary
117=================================
118
119This BSP contains bootable live images, which can be used to directly
120boot Yocto off of a USB flash drive.
121
122Under Linux, insert a USB flash drive. Assuming the USB flash drive
123takes device /dev/sdf, use dd to copy the live image to it. For
124example:
125
126# dd if=core-image-sato-nuc-20101207053738.hddimg of=/dev/sdf
127# sync
128# eject /dev/sdf
129
130This should give you a bootable USB flash device. Insert the device
131into a bootable USB socket on the target, and power on. This should
132result in a system booted to the Sato graphical desktop.
133
134If you want a terminal, use the arrows at the top of the UI to move to
135different pages of available applications, one of which is named
136'Terminal'. Clicking that should give you a root terminal.
137
138If you want to ssh into the system, you can use the root terminal to
139ifconfig the IP address and use that to ssh in. The root password is
140empty, so to log in type 'root' for the user name and hit 'Enter' at
141the Password prompt: and you should be in.
142
143----
144
145If you find you're getting corrupt images on the USB (it doesn't show
146the syslinux boot: prompt, or the boot: prompt contains strange
147characters), try doing this first:
148
149# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-nuc/README.sources b/meta-nuc/README.sources
new file mode 100644
index 00000000..0d4d849a
--- /dev/null
+++ b/meta-nuc/README.sources
@@ -0,0 +1,17 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://downloads.yoctoproject.org/releases/yocto/yocto-1.3/poky-danny-8.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-nuc/conf/layer.conf b/meta-nuc/conf/layer.conf
new file mode 100644
index 00000000..fb5b58a0
--- /dev/null
+++ b/meta-nuc/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "nuc"
9BBFILE_PATTERN_nuc := "^${LAYERDIR}/"
10BBFILE_PRIORITY_nuc = "6"