summaryrefslogtreecommitdiffstats
path: root/meta-n450
diff options
context:
space:
mode:
Diffstat (limited to 'meta-n450')
-rw-r--r--meta-n450/conf/machine/n450.conf32
-rw-r--r--meta-n450/recipes-kernel/linux/linux-yocto_3.0.bbappend9
2 files changed, 37 insertions, 4 deletions
diff --git a/meta-n450/conf/machine/n450.conf b/meta-n450/conf/machine/n450.conf
index f9cf4f2a..888c5d2e 100644
--- a/meta-n450/conf/machine/n450.conf
+++ b/meta-n450/conf/machine/n450.conf
@@ -3,13 +3,37 @@
3 3
4#@DESCRIPTION: Machine configuration for Intel 1-N450 based systems 4#@DESCRIPTION: Machine configuration for Intel 1-N450 based systems
5 5
6require conf/machine/atom-pc.conf 6include conf/machine/include/tune-atom.inc
7
8MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
9 acpi serial"
10
11KERNEL_IMAGETYPE = "bzImage"
12
13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
14PREFERRED_VERSION_linux-yocto = "3.0+git%"
15PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
16PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
17PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
18PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
19PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
20XSERVER ?= "xserver-xf86-dri-lite \
21 xf86-input-mouse \
22 xf86-input-keyboard \
23 xf86-input-evdev \
24 xf86-input-synaptics \
25 xf86-video-intel \
26 mesa-dri-driver-i915"
7 27
8SYSLINUX_OPTS = "serial 0 115200" 28SYSLINUX_OPTS = "serial 0 115200"
9SERIAL_CONSOLE = "115200 ttyS0" 29SERIAL_CONSOLE = "115200 ttyS0"
10APPEND += "console=ttyS0,115200 console=tty0" 30APPEND += "console=ttyS0,115200 console=tty0"
11 31
12PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 32MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts n450-audio"
33
34IMAGE_FSTYPES ?= "ext3 cpio.gz live"
35
36GLIBC_ADDONS = "nptl"
37GLIBC_EXTRA_OECONF = "--with-tls"
13 38
14# Ensure the bsp packages are installed 39ROOTLESS_X = "1"
15MACHINE_EXTRA_RRECOMMENDS += " n450-audio "
diff --git a/meta-n450/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-n450/recipes-kernel/linux/linux-yocto_3.0.bbappend
new file mode 100644
index 00000000..c1b69aab
--- /dev/null
+++ b/meta-n450/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_n450 = "n450"
3KMACHINE_n450 = "yocto/standard/common-pc/atom-pc"
4
5# The n450 is a single core hypterthreaded CPU
6KERNEL_FEATURES_append_n450 += " cfg/smp.scc"
7
8SRCREV_machine_pn-linux-yocto_n450 = "c54453332efbd86c2ea3caa64e908b39cfac1e76"
9#SRCREV_meta_pn-linux-yocto_n450 ?= XXXX