diff options
Diffstat (limited to 'meta-n450/recipes-bsp')
-rw-r--r-- | meta-n450/recipes-bsp/alsa-state/alsa-state.bbappend | 1 | ||||
-rw-r--r-- | meta-n450/recipes-bsp/alsa-state/alsa-state/n450/asound.state | 450 |
2 files changed, 451 insertions, 0 deletions
diff --git a/meta-n450/recipes-bsp/alsa-state/alsa-state.bbappend b/meta-n450/recipes-bsp/alsa-state/alsa-state.bbappend new file mode 100644 index 00000000..72d991c7 --- /dev/null +++ b/meta-n450/recipes-bsp/alsa-state/alsa-state.bbappend | |||
@@ -0,0 +1 @@ | |||
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
diff --git a/meta-n450/recipes-bsp/alsa-state/alsa-state/n450/asound.state b/meta-n450/recipes-bsp/alsa-state/alsa-state/n450/asound.state new file mode 100644 index 00000000..03a0bee7 --- /dev/null +++ b/meta-n450/recipes-bsp/alsa-state/alsa-state/n450/asound.state | |||
@@ -0,0 +1,450 @@ | |||
1 | state.Intel { | ||
2 | control.1 { | ||
3 | iface MIXER | ||
4 | name 'Front Playback Volume' | ||
5 | value.0 36 | ||
6 | value.1 36 | ||
7 | comment { | ||
8 | access 'read write' | ||
9 | type INTEGER | ||
10 | count 2 | ||
11 | range '0 - 39' | ||
12 | dbmin -5850 | ||
13 | dbmax 0 | ||
14 | dbvalue.0 -450 | ||
15 | dbvalue.1 -450 | ||
16 | } | ||
17 | } | ||
18 | control.2 { | ||
19 | iface MIXER | ||
20 | name 'Front Playback Switch' | ||
21 | value.0 true | ||
22 | value.1 true | ||
23 | comment { | ||
24 | access 'read write' | ||
25 | type BOOLEAN | ||
26 | count 2 | ||
27 | } | ||
28 | } | ||
29 | control.3 { | ||
30 | iface MIXER | ||
31 | name 'Surround Playback Volume' | ||
32 | value.0 36 | ||
33 | value.1 36 | ||
34 | comment { | ||
35 | access 'read write' | ||
36 | type INTEGER | ||
37 | count 2 | ||
38 | range '0 - 39' | ||
39 | dbmin -5850 | ||
40 | dbmax 0 | ||
41 | dbvalue.0 -450 | ||
42 | dbvalue.1 -450 | ||
43 | } | ||
44 | } | ||
45 | control.4 { | ||
46 | iface MIXER | ||
47 | name 'Surround Playback Switch' | ||
48 | value.0 false | ||
49 | value.1 false | ||
50 | comment { | ||
51 | access 'read write' | ||
52 | type BOOLEAN | ||
53 | count 2 | ||
54 | } | ||
55 | } | ||
56 | control.5 { | ||
57 | iface MIXER | ||
58 | name 'Center Playback Volume' | ||
59 | value 36 | ||
60 | comment { | ||
61 | access 'read write' | ||
62 | type INTEGER | ||
63 | count 1 | ||
64 | range '0 - 39' | ||
65 | dbmin -5850 | ||
66 | dbmax 0 | ||
67 | dbvalue.0 -450 | ||
68 | } | ||
69 | } | ||
70 | control.6 { | ||
71 | iface MIXER | ||
72 | name 'LFE Playback Volume' | ||
73 | value 36 | ||
74 | comment { | ||
75 | access 'read write' | ||
76 | type INTEGER | ||
77 | count 1 | ||
78 | range '0 - 39' | ||
79 | dbmin -5850 | ||
80 | dbmax 0 | ||
81 | dbvalue.0 -450 | ||
82 | } | ||
83 | } | ||
84 | control.7 { | ||
85 | iface MIXER | ||
86 | name 'Center Playback Switch' | ||
87 | value false | ||
88 | comment { | ||
89 | access 'read write' | ||
90 | type BOOLEAN | ||
91 | count 1 | ||
92 | } | ||
93 | } | ||
94 | control.8 { | ||
95 | iface MIXER | ||
96 | name 'LFE Playback Switch' | ||
97 | value false | ||
98 | comment { | ||
99 | access 'read write' | ||
100 | type BOOLEAN | ||
101 | count 1 | ||
102 | } | ||
103 | } | ||
104 | control.9 { | ||
105 | iface MIXER | ||
106 | name 'Side Playback Volume' | ||
107 | value.0 36 | ||
108 | value.1 36 | ||
109 | comment { | ||
110 | access 'read write' | ||
111 | type INTEGER | ||
112 | count 2 | ||
113 | range '0 - 39' | ||
114 | dbmin -5850 | ||
115 | dbmax 0 | ||
116 | dbvalue.0 -450 | ||
117 | dbvalue.1 -450 | ||
118 | } | ||
119 | } | ||
120 | control.10 { | ||
121 | iface MIXER | ||
122 | name 'Side Playback Switch' | ||
123 | value.0 false | ||
124 | value.1 false | ||
125 | comment { | ||
126 | access 'read write' | ||
127 | type BOOLEAN | ||
128 | count 2 | ||
129 | } | ||
130 | } | ||
131 | control.11 { | ||
132 | iface MIXER | ||
133 | name 'Mic Playback Volume' | ||
134 | value.0 28 | ||
135 | value.1 28 | ||
136 | comment { | ||
137 | access 'read write' | ||
138 | type INTEGER | ||
139 | count 2 | ||
140 | range '0 - 31' | ||
141 | dbmin -3450 | ||
142 | dbmax 1200 | ||
143 | dbvalue.0 750 | ||
144 | dbvalue.1 750 | ||
145 | } | ||
146 | } | ||
147 | control.12 { | ||
148 | iface MIXER | ||
149 | name 'Mic Playback Switch' | ||
150 | value.0 false | ||
151 | value.1 false | ||
152 | comment { | ||
153 | access 'read write' | ||
154 | type BOOLEAN | ||
155 | count 2 | ||
156 | } | ||
157 | } | ||
158 | control.13 { | ||
159 | iface MIXER | ||
160 | name 'Mic Boost Volume' | ||
161 | value.0 2 | ||
162 | value.1 2 | ||
163 | comment { | ||
164 | access 'read write' | ||
165 | type INTEGER | ||
166 | count 2 | ||
167 | range '0 - 3' | ||
168 | dbmin 0 | ||
169 | dbmax 3000 | ||
170 | dbvalue.0 2000 | ||
171 | dbvalue.1 2000 | ||
172 | } | ||
173 | } | ||
174 | control.14 { | ||
175 | iface MIXER | ||
176 | name 'Analog Mix Playback Volume' | ||
177 | value.0 28 | ||
178 | value.1 28 | ||
179 | comment { | ||
180 | access 'read write' | ||
181 | type INTEGER | ||
182 | count 2 | ||
183 | range '0 - 31' | ||
184 | dbmin -4650 | ||
185 | dbmax 0 | ||
186 | dbvalue.0 -450 | ||
187 | dbvalue.1 -450 | ||
188 | } | ||
189 | } | ||
190 | control.15 { | ||
191 | iface MIXER | ||
192 | name 'Analog Mix Playback Switch' | ||
193 | value.0 true | ||
194 | value.1 true | ||
195 | comment { | ||
196 | access 'read write' | ||
197 | type BOOLEAN | ||
198 | count 2 | ||
199 | } | ||
200 | } | ||
201 | control.16 { | ||
202 | iface MIXER | ||
203 | name 'Capture Volume' | ||
204 | value.0 48 | ||
205 | value.1 48 | ||
206 | comment { | ||
207 | access 'read write' | ||
208 | type INTEGER | ||
209 | count 2 | ||
210 | range '0 - 54' | ||
211 | dbmin -5850 | ||
212 | dbmax 2250 | ||
213 | dbvalue.0 1350 | ||
214 | dbvalue.1 1350 | ||
215 | } | ||
216 | } | ||
217 | control.17 { | ||
218 | iface MIXER | ||
219 | name 'Capture Switch' | ||
220 | value.0 false | ||
221 | value.1 false | ||
222 | comment { | ||
223 | access 'read write' | ||
224 | type BOOLEAN | ||
225 | count 2 | ||
226 | } | ||
227 | } | ||
228 | control.18 { | ||
229 | iface MIXER | ||
230 | name 'Capture Volume' | ||
231 | index 1 | ||
232 | value.0 48 | ||
233 | value.1 48 | ||
234 | comment { | ||
235 | access 'read write' | ||
236 | type INTEGER | ||
237 | count 2 | ||
238 | range '0 - 54' | ||
239 | dbmin -5850 | ||
240 | dbmax 2250 | ||
241 | dbvalue.0 1350 | ||
242 | dbvalue.1 1350 | ||
243 | } | ||
244 | } | ||
245 | control.19 { | ||
246 | iface MIXER | ||
247 | name 'Capture Switch' | ||
248 | index 1 | ||
249 | value.0 false | ||
250 | value.1 false | ||
251 | comment { | ||
252 | access 'read write' | ||
253 | type BOOLEAN | ||
254 | count 2 | ||
255 | } | ||
256 | } | ||
257 | control.20 { | ||
258 | iface MIXER | ||
259 | name 'Capture Volume' | ||
260 | index 2 | ||
261 | value.0 48 | ||
262 | value.1 48 | ||
263 | comment { | ||
264 | access 'read write' | ||
265 | type INTEGER | ||
266 | count 2 | ||
267 | range '0 - 54' | ||
268 | dbmin -5850 | ||
269 | dbmax 2250 | ||
270 | dbvalue.0 1350 | ||
271 | dbvalue.1 1350 | ||
272 | } | ||
273 | } | ||
274 | control.21 { | ||
275 | iface MIXER | ||
276 | name 'Capture Switch' | ||
277 | index 2 | ||
278 | value.0 false | ||
279 | value.1 false | ||
280 | comment { | ||
281 | access 'read write' | ||
282 | type BOOLEAN | ||
283 | count 2 | ||
284 | } | ||
285 | } | ||
286 | control.22 { | ||
287 | iface MIXER | ||
288 | name 'Input Source' | ||
289 | value Mic | ||
290 | comment { | ||
291 | access 'read write' | ||
292 | type ENUMERATED | ||
293 | count 1 | ||
294 | item.0 Mic | ||
295 | item.1 Mix | ||
296 | } | ||
297 | } | ||
298 | control.23 { | ||
299 | iface MIXER | ||
300 | name 'Input Source' | ||
301 | index 1 | ||
302 | value Mic | ||
303 | comment { | ||
304 | access 'read write' | ||
305 | type ENUMERATED | ||
306 | count 1 | ||
307 | item.0 Mic | ||
308 | item.1 Mix | ||
309 | } | ||
310 | } | ||
311 | control.24 { | ||
312 | iface MIXER | ||
313 | name 'Input Source' | ||
314 | index 2 | ||
315 | value Mic | ||
316 | comment { | ||
317 | access 'read write' | ||
318 | type ENUMERATED | ||
319 | count 1 | ||
320 | item.0 Mic | ||
321 | item.1 Mix | ||
322 | } | ||
323 | } | ||
324 | control.25 { | ||
325 | iface MIXER | ||
326 | name 'IEC958 Playback Volume' | ||
327 | value.0 36 | ||
328 | value.1 36 | ||
329 | comment { | ||
330 | access 'read write' | ||
331 | type INTEGER | ||
332 | count 2 | ||
333 | range '0 - 39' | ||
334 | dbmin -5850 | ||
335 | dbmax 0 | ||
336 | dbvalue.0 -450 | ||
337 | dbvalue.1 -450 | ||
338 | } | ||
339 | } | ||
340 | control.26 { | ||
341 | iface MIXER | ||
342 | name 'HDMI Playback Volume' | ||
343 | value.0 36 | ||
344 | value.1 36 | ||
345 | comment { | ||
346 | access 'read write' | ||
347 | type INTEGER | ||
348 | count 2 | ||
349 | range '0 - 39' | ||
350 | dbmin -5850 | ||
351 | dbmax 0 | ||
352 | dbvalue.0 -450 | ||
353 | dbvalue.1 -450 | ||
354 | } | ||
355 | } | ||
356 | control.27 { | ||
357 | iface MIXER | ||
358 | name 'IEC958 Playback Con Mask' | ||
359 | value '0fff000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000' | ||
360 | comment { | ||
361 | access read | ||
362 | type IEC958 | ||
363 | count 1 | ||
364 | } | ||
365 | } | ||
366 | control.28 { | ||
367 | iface MIXER | ||
368 | name 'IEC958 Playback Pro Mask' | ||
369 | value '0f00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000' | ||
370 | comment { | ||
371 | access read | ||
372 | type IEC958 | ||
373 | count 1 | ||
374 | } | ||
375 | } | ||
376 | control.29 { | ||
377 | iface MIXER | ||
378 | name 'IEC958 Playback Default' | ||
379 | value '0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000' | ||
380 | comment { | ||
381 | access 'read write' | ||
382 | type IEC958 | ||
383 | count 1 | ||
384 | } | ||
385 | } | ||
386 | control.30 { | ||
387 | iface MIXER | ||
388 | name 'IEC958 Playback Switch' | ||
389 | value false | ||
390 | comment { | ||
391 | access 'read write' | ||
392 | type BOOLEAN | ||
393 | count 1 | ||
394 | } | ||
395 | } | ||
396 | control.31 { | ||
397 | iface MIXER | ||
398 | name 'IEC958 Default PCM Playback Switch' | ||
399 | value true | ||
400 | comment { | ||
401 | access 'read write' | ||
402 | type BOOLEAN | ||
403 | count 1 | ||
404 | } | ||
405 | } | ||
406 | control.32 { | ||
407 | iface MIXER | ||
408 | name 'IEC958 Capture Switch' | ||
409 | value false | ||
410 | comment { | ||
411 | access 'read write' | ||
412 | type BOOLEAN | ||
413 | count 1 | ||
414 | } | ||
415 | } | ||
416 | control.33 { | ||
417 | iface MIXER | ||
418 | name 'IEC958 Capture Default' | ||
419 | value '0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000' | ||
420 | comment { | ||
421 | access read | ||
422 | type IEC958 | ||
423 | count 1 | ||
424 | } | ||
425 | } | ||
426 | control.34 { | ||
427 | iface MIXER | ||
428 | name 'Master Playback Volume' | ||
429 | value 36 | ||
430 | comment { | ||
431 | access 'read write' | ||
432 | type INTEGER | ||
433 | count 1 | ||
434 | range '0 - 39' | ||
435 | dbmin -5850 | ||
436 | dbmax 0 | ||
437 | dbvalue.0 -450 | ||
438 | } | ||
439 | } | ||
440 | control.35 { | ||
441 | iface MIXER | ||
442 | name 'Master Playback Switch' | ||
443 | value true | ||
444 | comment { | ||
445 | access 'read write' | ||
446 | type BOOLEAN | ||
447 | count 1 | ||
448 | } | ||
449 | } | ||
450 | } | ||