diff options
Diffstat (limited to 'meta-jasperforest')
12 files changed, 221 insertions, 0 deletions
diff --git a/meta-jasperforest/COPYING.MIT b/meta-jasperforest/COPYING.MIT new file mode 100644 index 00000000..fb950dc6 --- /dev/null +++ b/meta-jasperforest/COPYING.MIT | |||
@@ -0,0 +1,17 @@ | |||
1 | Permission is hereby granted, free of charge, to any person obtaining a copy | ||
2 | of this software and associated documentation files (the "Software"), to deal | ||
3 | in the Software without restriction, including without limitation the rights | ||
4 | to use, copy, modify, merge, publish, distribute, sublicense, and/or sell | ||
5 | copies of the Software, and to permit persons to whom the Software is | ||
6 | furnished to do so, subject to the following conditions: | ||
7 | |||
8 | The above copyright notice and this permission notice shall be included in | ||
9 | all copies or substantial portions of the Software. | ||
10 | |||
11 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
12 | IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
13 | FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
14 | AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
15 | LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
16 | OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN | ||
17 | THE SOFTWARE. | ||
diff --git a/meta-jasperforest/README b/meta-jasperforest/README new file mode 100644 index 00000000..ab7246d9 --- /dev/null +++ b/meta-jasperforest/README | |||
@@ -0,0 +1,85 @@ | |||
1 | This README file contains information on building the | ||
2 | meta-jasperforest BSP layer, and booting the images contained in the | ||
3 | /binary directory. Please see the corresponding sections below for | ||
4 | details. | ||
5 | |||
6 | 'Jasper Forest' refers to the Intel Xeon C5500/C3500 processors, which | ||
7 | combined with the Intel 3420 PCH chipset (Ibex Peak) make up the | ||
8 | 'Picket Post' CRB this BSP was developed on. | ||
9 | |||
10 | |||
11 | Table of Contents | ||
12 | ================= | ||
13 | |||
14 | I. Building the meta-jasperforest BSP layer | ||
15 | II. Booting the images in /binary | ||
16 | |||
17 | |||
18 | I. Building the meta-jasperforest BSP layer | ||
19 | ======================================= | ||
20 | |||
21 | For each BSP in the 'meta-intel' repository, there are multiple | ||
22 | branches, one corresponding to each major release starting with | ||
23 | 'laverne' (0.90), in addition to the latest code which tracks the | ||
24 | current master. | ||
25 | |||
26 | In order to build an image with BSP support for a given release, you | ||
27 | need to check out the 'meta-intel' branch corresponding to the release | ||
28 | you're building against e.g. to build for laverne (0.90), check out | ||
29 | the 'laverne' branch of both poky and 'meta-intel'. | ||
30 | |||
31 | Having done that, and assuming you cloned the 'meta-intel' repository | ||
32 | at the top-level of your yocto build tree, you can build a jasperforest | ||
33 | image by adding the location of the meta-jasperforest layer to | ||
34 | bblayers.conf e.g.: | ||
35 | |||
36 | yocto/meta-intel/meta-jasperforest \ | ||
37 | |||
38 | To enable the jasperforest layer, add the jasperforest MACHINE to local.conf: | ||
39 | |||
40 | MACHINE ?= "jasperforest" | ||
41 | |||
42 | You should then be able to build a jasperforest image as such: | ||
43 | |||
44 | $ source poky-init-build-env | ||
45 | $ bitbake poky-image-sato-live | ||
46 | |||
47 | At the end of a successful build, you should have a live image that | ||
48 | you can boot from a USB flash drive (see instructions on how to do | ||
49 | that below, in the section 'Booting the images from /binary'). | ||
50 | |||
51 | |||
52 | II. Booting the images in /binary | ||
53 | ================================= | ||
54 | |||
55 | This BSP contains bootable live images, which can be used to directly | ||
56 | boot Yocto off of a USB flash drive. | ||
57 | |||
58 | Under Linux, insert a USB flash drive. Assuming the USB flash drive | ||
59 | takes device /dev/sdf, use dd to copy the live image to it. For | ||
60 | example: | ||
61 | |||
62 | # dd if=poky-image-sato-live-jasperforest-20101207053738.hddimg of=/dev/sdf | ||
63 | # sync | ||
64 | # eject /dev/sdf | ||
65 | |||
66 | This should give you a bootable USB flash device. Insert the device | ||
67 | into a bootable USB socket on the target, and power on. This should | ||
68 | result in a system booted to the Sato graphical desktop. | ||
69 | |||
70 | If you want a terminal, use the arrows at the top of the UI to move to | ||
71 | different pages of available applications, one of which is named | ||
72 | 'Terminal'. Clicking that should give you a root terminal. | ||
73 | |||
74 | If you want to ssh into the system, you can use the root terminal to | ||
75 | ifconfig the IP address and use that to ssh in. The root password is | ||
76 | empty, so to log in type 'root' for the user name and hit 'Enter' at | ||
77 | the Password prompt: and you should be in. | ||
78 | |||
79 | ---- | ||
80 | |||
81 | If you find you're getting corrupt images on the USB (it doesn't show | ||
82 | the syslinux boot: prompt, or the boot: prompt contains strange | ||
83 | characters), try doing this first: | ||
84 | |||
85 | # dd if=/dev/zero of=/dev/sdf bs=1M count=512 | ||
diff --git a/meta-jasperforest/binary/.gitignore b/meta-jasperforest/binary/.gitignore new file mode 100644 index 00000000..e69de29b --- /dev/null +++ b/meta-jasperforest/binary/.gitignore | |||
diff --git a/meta-jasperforest/conf/layer.conf b/meta-jasperforest/conf/layer.conf new file mode 100644 index 00000000..564bb1d8 --- /dev/null +++ b/meta-jasperforest/conf/layer.conf | |||
@@ -0,0 +1,12 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH := "${BBPATH}:${LAYERDIR}" | ||
3 | |||
4 | # We have a recipes directory, add to BBFILES | ||
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes-*/*/*.bbappend \ | ||
7 | ${LAYERDIR}/../common/recipes-*/*/*.bb \ | ||
8 | ${LAYERDIR}/../common/recipes-*/*/*.bbappend" | ||
9 | |||
10 | BBFILE_COLLECTIONS_jasperforest += "jasperforest" | ||
11 | BBFILE_PATTERN_jasperforest := "^${LAYERDIR}/" | ||
12 | BBFILE_PRIORITY_jasperforest = "6" | ||
diff --git a/meta-jasperforest/conf/machine/jasperforest.conf b/meta-jasperforest/conf/machine/jasperforest.conf new file mode 100644 index 00000000..5c2e9bc4 --- /dev/null +++ b/meta-jasperforest/conf/machine/jasperforest.conf | |||
@@ -0,0 +1,54 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: jasperforest | ||
3 | |||
4 | #@DESCRIPTION: Machine configuration for Jasper Forest Picket Post | ||
5 | # systems i.e. Xeon C5500/C3500 + Intel 3420 chipset (Ibex Peak) | ||
6 | |||
7 | TARGET_ARCH = "x86_64" | ||
8 | PACKAGE_EXTRA_ARCHS = "x86 xeon" | ||
9 | |||
10 | BASE_PACKAGE_ARCH="xeon" | ||
11 | |||
12 | MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \ | ||
13 | acpi serial usbgadget" | ||
14 | |||
15 | KERNEL_IMAGETYPE = "bzImage" | ||
16 | |||
17 | PREFERRED_PROVIDER_virtual/kernel = "linux-yocto" | ||
18 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto" | ||
19 | |||
20 | PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim" | ||
21 | PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri" | ||
22 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite" | ||
23 | PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite" | ||
24 | XSERVER ?= "xserver-xf86-dri-lite \ | ||
25 | xf86-input-mouse \ | ||
26 | xf86-input-keyboard \ | ||
27 | xf86-input-evdev \ | ||
28 | xf86-input-synaptics \ | ||
29 | xf86-video-vesa" | ||
30 | |||
31 | SERIAL_CONSOLE = "115200 ttyS0" | ||
32 | |||
33 | MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts" | ||
34 | |||
35 | GUI_MACHINE_CLASS = "bigscreen" | ||
36 | |||
37 | IMAGE_ROOTFS_SIZE_ext3 = "2000000" | ||
38 | |||
39 | IMAGE_FSTYPES ?= "ext3 cpio.gz" | ||
40 | |||
41 | GLIBC_ADDONS = "nptl" | ||
42 | GLIBC_EXTRA_OECONF = "--with-tls" | ||
43 | |||
44 | MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "grub" | ||
45 | PREFERRED_VERSION_grub ?= "1.98" | ||
46 | |||
47 | TARGET_CC_ARCH = "-m64" | ||
48 | |||
49 | SRCREV_machine_pn-linux-yocto_jasperforest ?= "a6dd773a94336c7bbdfd02f8a6a647d034f84821" | ||
50 | SRCREV_meta_pn-linux-yocto_jasperforest ?= "5806e601595ff3db7655f14b3d720433072eb656" | ||
51 | |||
52 | SRCREV_machine_pn-linux-yocto-stable_jasperforest ?= "aae69fdf104b0a9d7b3710f808aac6ab303490f7" | ||
53 | SRCREV_meta_pn-linux-yocto-stable_jasperforest ?= "50ccd2b3213b6a1bacb3f898c035119802dac420" | ||
54 | |||
diff --git a/meta-jasperforest/recipes-bsp/formfactor/formfactor/jasperforest/machconfig b/meta-jasperforest/recipes-bsp/formfactor/formfactor/jasperforest/machconfig new file mode 100644 index 00000000..ffce0122 --- /dev/null +++ b/meta-jasperforest/recipes-bsp/formfactor/formfactor/jasperforest/machconfig | |||
@@ -0,0 +1,3 @@ | |||
1 | # Assume a USB mouse and keyboard are connected | ||
2 | HAVE_TOUCHSCREEN=0 | ||
3 | HAVE_KEYBOARD=1 | ||
diff --git a/meta-jasperforest/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-jasperforest/recipes-bsp/formfactor/formfactor_0.0.bbappend new file mode 100644 index 00000000..4a41d487 --- /dev/null +++ b/meta-jasperforest/recipes-bsp/formfactor/formfactor_0.0.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS := "${THISDIR}/${PN}" | ||
2 | |||
3 | PRINC = "1" | ||
diff --git a/meta-jasperforest/recipes-graphics/xorg-xserver/xserver-xf86-config/jasperforest/xorg.conf b/meta-jasperforest/recipes-graphics/xorg-xserver/xserver-xf86-config/jasperforest/xorg.conf new file mode 100644 index 00000000..ca14a0c4 --- /dev/null +++ b/meta-jasperforest/recipes-graphics/xorg-xserver/xserver-xf86-config/jasperforest/xorg.conf | |||
@@ -0,0 +1,32 @@ | |||
1 | #Section "Device" | ||
2 | # Identifier "Volari Z11" | ||
3 | # Driver "xgi" | ||
4 | #EndSection | ||
5 | |||
6 | Section "Device" | ||
7 | Identifier "Generic VESA" | ||
8 | Driver "vesa" | ||
9 | EndSection | ||
10 | |||
11 | Section "Monitor" | ||
12 | Identifier "Generic Monitor" | ||
13 | Option "DPMS" | ||
14 | EndSection | ||
15 | |||
16 | Section "Screen" | ||
17 | Identifier "Default Screen" | ||
18 | # Device "Volari Z11" | ||
19 | Device "Generic VESA" | ||
20 | Monitor "Generic Monitor" | ||
21 | DefaultDepth 24 | ||
22 | EndSection | ||
23 | |||
24 | Section "ServerLayout" | ||
25 | Identifier "Default Layout" | ||
26 | Screen "Default Screen" | ||
27 | EndSection | ||
28 | |||
29 | Section "ServerFlags" | ||
30 | Option "DontZap" "0" | ||
31 | Option "AutoAddDevices" "False" | ||
32 | EndSection | ||
diff --git a/meta-jasperforest/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-jasperforest/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend new file mode 100644 index 00000000..4b8d0e65 --- /dev/null +++ b/meta-jasperforest/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}" | ||
2 | FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:" | ||
3 | |||
diff --git a/meta-jasperforest/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bbappend b/meta-jasperforest/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bbappend new file mode 100644 index 00000000..b2808ef2 --- /dev/null +++ b/meta-jasperforest/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bbappend | |||
@@ -0,0 +1 @@ | |||
EXTRA_OECONF += "--enable-dga" | |||
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-stable_git.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-stable_git.bbappend new file mode 100644 index 00000000..066776b3 --- /dev/null +++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto-stable_git.bbappend | |||
@@ -0,0 +1,5 @@ | |||
1 | FILESEXTRAPATHS := "${THISDIR}/${PN}" | ||
2 | |||
3 | COMPATIBLE_MACHINE_jasperforest = "jasperforest" | ||
4 | KMACHINE_jasperforest = "jasperforest" | ||
5 | |||
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto_git.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto_git.bbappend new file mode 100644 index 00000000..988c9694 --- /dev/null +++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto_git.bbappend | |||
@@ -0,0 +1,6 @@ | |||
1 | FILESEXTRAPATHS := "${THISDIR}/${PN}" | ||
2 | |||
3 | COMPATIBLE_MACHINE_jasperforest = "jasperforest" | ||
4 | |||
5 | KMACHINE_jasperforest = "yocto/standard/common-pc-64/jasperforest" | ||
6 | |||