summaryrefslogtreecommitdiffstats
path: root/meta-isg
diff options
context:
space:
mode:
Diffstat (limited to 'meta-isg')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch43
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-examples-add-config-variable-to-enable-disable-dpdk_.patch44
2 files changed, 87 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch
new file mode 100644
index 00000000..e8ded8d0
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch
@@ -0,0 +1,43 @@
1From c1a59d62f2aa7656060d8ebcc8e45e852d931ff1 Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Tue, 17 Feb 2015 00:23:12 +0800
4Subject: [PATCH] dpdk: enable VHOST build config in common_linuxapp config
5
6Introduce CONFIG_VHOST_ENABLED for package config selection purpose in
7building vhost feature.
8
9Upstream-Status: Inappropriate [configuration]
10
11Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
12---
13 config/common_linuxapp | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/config/common_linuxapp b/config/common_linuxapp
17index 2f9643b..67f5edb 100644
18--- a/config/common_linuxapp
19+++ b/config/common_linuxapp
20@@ -361,9 +361,9 @@ CONFIG_RTE_LIBRTE_PIPELINE=y
21 #
22 CONFIG_RTE_LIBRTE_KNI=y
23 CONFIG_RTE_KNI_KO_DEBUG=n
24-CONFIG_RTE_KNI_VHOST=n
25+CONFIG_RTE_KNI_VHOST=$(CONFIG_VHOST_ENABLED)
26 CONFIG_RTE_KNI_VHOST_MAX_CACHE_SIZE=1024
27-CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=n
28+CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=$(CONFIG_VHOST_ENABLED)
29 CONFIG_RTE_KNI_VHOST_DEBUG_RX=n
30 CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
31
32@@ -372,7 +372,7 @@ CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
33 # fuse-devel is needed to run vhost.
34 # fuse-devel enables user space char driver development
35 #
36-CONFIG_RTE_LIBRTE_VHOST=n
37+CONFIG_RTE_LIBRTE_VHOST=$(CONFIG_VHOST_ENABLED)
38 CONFIG_RTE_LIBRTE_VHOST_DEBUG=n
39
40 #
41--
421.7.9.5
43
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-examples-add-config-variable-to-enable-disable-dpdk_.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-examples-add-config-variable-to-enable-disable-dpdk_.patch
new file mode 100644
index 00000000..c86c1a1d
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-examples-add-config-variable-to-enable-disable-dpdk_.patch
@@ -0,0 +1,44 @@
1From 54c95ca8f76f412c94a9f61e3756420ac554310b Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Thu, 12 Feb 2015 16:33:49 +0800
4Subject: [PATCH] examples: add config variable to enable/disable dpdk_qat
5
6Upstream-Status: Inappropriate [configuration]
7
8This patch adss following example build configs:
9
101) CONFIG_EXAMPLE_DPDK_QAT is used to control dpdk_qat example
11 by PACKAGECONFIG.
12
132) CONFIG_EXAMPLE_VM_POWER_MANAGER is used to control vm_power_manager
14 example by PACKAGECONFIG.
15
16Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
17---
18 examples/Makefile | 4 ++--
19 1 file changed, 2 insertions(+), 2 deletions(-)
20
21diff --git a/examples/Makefile b/examples/Makefile
22index 81f1d2f..7e9c7bd 100644
23--- a/examples/Makefile
24+++ b/examples/Makefile
25@@ -40,7 +40,7 @@ include $(RTE_SDK)/mk/rte.vars.mk
26 DIRS-y += cmdline
27 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
28 ifneq ($(ICP_ROOT),)
29-DIRS-y += dpdk_qat
30+DIRS-$(CONFIG_EXAMPLE_DPDK_QAT) += dpdk_qat
31 endif
32 DIRS-y += exception_path
33 DIRS-y += helloworld
34@@ -68,6 +68,6 @@ DIRS-$(CONFIG_RTE_LIBRTE_VHOST) += vhost
35 DIRS-$(CONFIG_RTE_LIBRTE_XEN_DOM0) += vhost_xen
36 DIRS-y += vmdq
37 DIRS-y += vmdq_dcb
38-DIRS-y += vm_power_manager
39+DIRS-$(CONFIG_EXAMPLE_VM_POWER_MANAGER) += vm_power_manager
40
41 include $(RTE_SDK)/mk/rte.extsubdir.mk
42--
431.7.9.5
44