summaryrefslogtreecommitdiffstats
path: root/meta-isg/meta-valleyisland
diff options
context:
space:
mode:
Diffstat (limited to 'meta-isg/meta-valleyisland')
-rw-r--r--meta-isg/meta-valleyisland/COPYING.MIT17
-rw-r--r--meta-isg/meta-valleyisland/README218
-rw-r--r--meta-isg/meta-valleyisland/README.sources18
-rw-r--r--meta-isg/meta-valleyisland/conf/layer.conf14
4 files changed, 267 insertions, 0 deletions
diff --git a/meta-isg/meta-valleyisland/COPYING.MIT b/meta-isg/meta-valleyisland/COPYING.MIT
new file mode 100644
index 00000000..89de3547
--- /dev/null
+++ b/meta-isg/meta-valleyisland/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-isg/meta-valleyisland/README b/meta-isg/meta-valleyisland/README
new file mode 100644
index 00000000..99cba0d1
--- /dev/null
+++ b/meta-isg/meta-valleyisland/README
@@ -0,0 +1,218 @@
1This README file contains information on building the meta-valleyisland
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The Valley Island BSP consists of two versions:
61. 32-bit Valley Island
72. 64-bit Valley Island
8
9The BSP is made specifically for Intel Atom E38XX Processor E38XX
10Development Kit (formerly known as Valley Island). This BSP integrates
11Intel Graphics for Linux driver as the integrated graphics.
12
13Valley Island BSP is meant to support Valley Island Development
14Kit, "Bayley Bay" CRB and "Bakersport" CRB.
15
16Further information on the platforms supported by this BSP can be
17found here:
18
19 http://www.intel.com/content/www/us/en/intelligent-systems/bay-trail/atom-processor-e3800-family-overview.html
20
21Information on all IntelĀ® embedded platforms can be found here:
22
23 http://www.intel.com/p/en_US/embedded/hwsw/hardware
24
25Yocto Project Compatible
26========================
27
28This BSP is compatible with the Yocto Project as per the requirements
29listed here:
30
31 https://www.yoctoproject.org/webform/yocto-project-compatible-registration
32
33Dependencies
34============
35
36This layer depends on:
37
38 URI: git://git.openembedded.org/bitbake
39 branch: master
40
41 URI: git://git.openembedded.org/openembedded-core
42 layers: meta
43 branch: master
44
45 URI: git://git.yoctoproject.org/meta-intel
46 layers: intel
47 branch: master
48
49Patches
50=======
51
52Please submit any patches against this BSP to the Meta-Intel Yocto mailing list
53(meta-intel@yoctoproject.org) and cc: the maintainer:
54
55Maintainer: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com>
56
57Please see the meta-isg/MAINTAINERS file for more details.
58
59Table of Contents
60=================
61
62 I. Building the meta-valleyisland BSP layer
63 II. Booting the images in /binary
64III. Device Notes
65 a. Boot Loader
66 b. I/O drivers
67 c. LPIO ACPI enumeration support
68 IV. Known Issues
69 a. I/O drivers
70
71
72I. Building the meta-valleyisland BSP layer
73===========================================
74
75In order to build an image with BSP support for a given release, you
76need to download the corresponding BSP tarball from the 'Board Support
77Package (BSP) Downloads' page of the Yocto Project website.
78
79Having that done, and assuming you have extracted the BSP tarball contents
80at the top-level of your Yocto build tree, you can build a valleyisland
81image by adding the location of the meta-valleyisland layer to
82bblayers.conf, along with the meta-intel layer itself (to access
83common metadata shared between BSPs) e.g.:
84
85 yocto/meta-intel \
86 yocto/meta-intel/meta-isg/meta-valleyisland \
87
88To enable the 32-bit Valley Island layer, add the valleyisland-32 MACHINE to local.conf:
89
90 MACHINE ?= "valleyisland-32"
91
92To enable the 64-bit Valley Island layer, add the valleyisland-64 MACHINE to local.conf:
93
94 MACHINE ?= "valleyisland-64"
95
96The meta-valleyisland contains support for Intel HD Audio. However, HD Audio
97driver is dependent on gstreamer plugins and ffmpeg plugins to work properly.
98These gstreamer plugins require license flags in order to be included in the build.
99
100Add "commercial" in the LICENSE_FLAGS_WHITELIST in local.conf. For example:
101
102 LICENSE_FLAGS_WHITELIST = "commercial"
103
104You should then be able to build a valleyisland image as such:
105
106 $ source oe-init-build-env
107 $ bitbake core-image-sato
108
109At the end of a successful build, you should have a live image that
110you can boot from a USB flash drive (see instructions on how to do
111that below, in the section 'Booting the images from /binary').
112
113As an alternative to downloading the BSP tarball, you can also work
114directly from the meta-intel git repository. For each BSP in the
115'meta-intel' repository, there are multiple branches, one
116corresponding to each major release starting with 'laverne' (0.90), in
117addition to the latest code which tracks the current master (note that
118not all BSPs are present in every release). Instead of extracting a
119BSP tarball at the top level of your yocto build tree, you can
120equivalently check out the appropriate branch from the meta-intel
121repository at the same location.
122
123II. Booting the images in /binary
124=================================
125
126This BSP contains (or builds) live images which must be converted to a
127partitioned image format in order to boot them on the Valley Island
128Development Kit, Bayley Bay CRB and Bakersport CRB.
129
130You can deploy the hddimg image to a USB or SATA device. You will
131need to know the device name on your host as well as the device name on
132the target. Be careful with this step as using the wrong host device can
133result in overwriting data on your host machine.
134
135Under Linux, USB and SATA devices typically appears as /dev/sdb,
136/dev/sdc, etc. Watching your system messages as you connect the device
137will tell you exactly which device name is assigned to the device.
138On the Valley Island platform, assuming only one storage device is
139attached at boot, a USB or SATA device will be /dev/sda.
140
141After inserting the boot media into your host machine and determining
142your host and target device, create the image using the mkefidisk.sh
143script, provided by poky under scripts/contrib/. Note that root
144privileges are required. For example, using an USB device which appears
145as /dev/sdc on the host:
146
147$ sudo ./mkefidisk.sh /dev/sdc core-image-sato-valleyisland-32.hddimg /dev/sda
148
149Follow the prompts on the screen to confirm the action.
150
151Insert the device into the Valley Island platform and power on. This
152should result in a system booted to the Sato graphical desktop.
153
154The root password is empty on the Poky reference distribution images.
155
156
157III. Device Notes
158=================
159a. Boot Loader
160--------------
161BIOS : Bayley Bay 072_011
162EC : KSC v3.10 for Bayley Bay/Bakersport CRB Fab3
163
164Required settings in BIOS
165
166 Turn off Secure-boot:
167 Device Manager -> System Setup -> Boot -> Security Boot -> Disable
168
169 Turn off LPE Audio Support:
170 Device Manager -> System Setup -> South Cluster Configuration ->
171 Audio Configuration -> LPE Audio Support -> Disable
172
173Please use EFI mode for all boot medium types, i.e. USB disk and Hard Disk.
174Setting in BIOS:
175
176 Choose boot medium:
177 Boot Manager -> EFI (Hard Drive/USB Device)
178
179 Save settings:
180 Boot Maintenance Manager -> Boot Options -> Change Boot Order ->
181 Change the order -> Commmit Changes and Exit
182
183
184b. I/O drivers
185--------------
186The I2C controller driver supports fast mode by default.
187To enable standard mode, appends the arguments to kernel command line.
188
189 "i2c-designware-pci.force_std_mode=1" (PCI mode)
190 "i2c-designware-platform.force_std_mode=1" (ACPI mode)
191
192
193c. LPIO ACPI enumeration support
194--------------------------------
195Required settings in BIOS
196
197 Turn on ACPI mode
198 Device Manager -> System Setup -> South Cluster Configuration ->
199 LPSS & SCC Configuration -> LPSS & SCC Device Mode -> ACPI mode
200
201Some LPSS devices are hidden in ACPI mode to support Windows. To enable
202these devices, toggle the following in the BIOS Menu.
203
204 Device Manager -> System Setup -> South Cluster Configuration -> Miscellaneous
205 Configuration -> Unsupported LPSS Device and select "Unhide"
206
207
208IV. Known Limitations
209=====================
210a. I/O drivers
211--------------
212HSUART:
213
214When runninig PCI mode HSUART at baud rate 2M and above, you may observe
215kernel message "serial8250: too much work for irq...". Most of the time it
216won't disrupt the transfer and able to complete without data corruption.
217However, occasionally your transfer may halt when that kernel message appear.
218In this case, you would need to re-open the HSUART port.
diff --git a/meta-isg/meta-valleyisland/README.sources b/meta-isg/meta-valleyisland/README.sources
new file mode 100644
index 00000000..eef58fec
--- /dev/null
+++ b/meta-isg/meta-valleyisland/README.sources
@@ -0,0 +1,18 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://downloads.yoctoproject.org/releases/yocto/yocto-1.5/poky-dora-10.0.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17
18git://git.yoctoproject.org/meta-intel
diff --git a/meta-isg/meta-valleyisland/conf/layer.conf b/meta-isg/meta-valleyisland/conf/layer.conf
new file mode 100644
index 00000000..00eea9cd
--- /dev/null
+++ b/meta-isg/meta-valleyisland/conf/layer.conf
@@ -0,0 +1,14 @@
1#We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "valleyisland"
9BBFILE_PATTERN_valleyisland := "^${LAYERDIR}/"
10BBFILE_PRIORITY_valleyisland = "6"
11
12LAYERDEPENDS_valleyisland = "intel"
13
14LICENSE_PATH += "${LAYERDIR}/custom-licenses"