diff options
Diffstat (limited to 'meta-isg/meta-mohonpeak')
-rw-r--r-- | meta-isg/meta-mohonpeak/COPYING.MIT | 17 | ||||
-rw-r--r-- | meta-isg/meta-mohonpeak/README | 146 | ||||
-rw-r--r-- | meta-isg/meta-mohonpeak/README.sources | 18 | ||||
-rw-r--r-- | meta-isg/meta-mohonpeak/conf/layer.conf | 12 |
4 files changed, 193 insertions, 0 deletions
diff --git a/meta-isg/meta-mohonpeak/COPYING.MIT b/meta-isg/meta-mohonpeak/COPYING.MIT new file mode 100644 index 00000000..89de3547 --- /dev/null +++ b/meta-isg/meta-mohonpeak/COPYING.MIT | |||
@@ -0,0 +1,17 @@ | |||
1 | Permission is hereby granted, free of charge, to any person obtaining a copy | ||
2 | of this software and associated documentation files (the "Software"), to deal | ||
3 | in the Software without restriction, including without limitation the rights | ||
4 | to use, copy, modify, merge, publish, distribute, sublicense, and/or sell | ||
5 | copies of the Software, and to permit persons to whom the Software is | ||
6 | furnished to do so, subject to the following conditions: | ||
7 | |||
8 | The above copyright notice and this permission notice shall be included in | ||
9 | all copies or substantial portions of the Software. | ||
10 | |||
11 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
12 | IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
13 | FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
14 | AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
15 | LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
16 | OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN | ||
17 | THE SOFTWARE. | ||
diff --git a/meta-isg/meta-mohonpeak/README b/meta-isg/meta-mohonpeak/README new file mode 100644 index 00000000..a30e4550 --- /dev/null +++ b/meta-isg/meta-mohonpeak/README | |||
@@ -0,0 +1,146 @@ | |||
1 | This README file contains information on building the meta-mohonpeak | ||
2 | BSP layer, and booting the images contained in the /binary directory. | ||
3 | Please see the corresponding sections below for details. | ||
4 | |||
5 | The mohonpeak platform consists of two versions: | ||
6 | 1. 32-bit Mohon Peak | ||
7 | 2. 64-bit Mohon Peak | ||
8 | |||
9 | The Mohon Peak platform consists of the Intel Atom Processor C2000 | ||
10 | Product Family (Formerly Rangeley) | ||
11 | |||
12 | This BSP assumes ASPEED Technology graphics card is being used. | ||
13 | |||
14 | Further information about the platforms supported by this BSP can be | ||
15 | found here: | ||
16 | |||
17 | http://www.intel.com/content/www/us/en/intelligent-systems/rangeley/ | ||
18 | atom-c2000-product-family-based-platforms-overview.html | ||
19 | |||
20 | Information on all IntelĀ® embedded platforms can be found here: | ||
21 | |||
22 | http://www.intel.com/p/en_US/embedded/hwsw/hardware | ||
23 | |||
24 | |||
25 | Yocto Project Compatible | ||
26 | ======================== | ||
27 | |||
28 | This BSP is compatible with the Yocto Project as per the requirements | ||
29 | listed here: | ||
30 | |||
31 | https://www.yoctoproject.org/webform/yocto-project-compatible-registration | ||
32 | |||
33 | |||
34 | Dependencies | ||
35 | ============ | ||
36 | |||
37 | This layer depends on: | ||
38 | |||
39 | URI: git://git.openembedded.org/bitbake | ||
40 | branch: master | ||
41 | |||
42 | URI: git://git.openembedded.org/openembedded-core | ||
43 | layers: meta | ||
44 | branch: master | ||
45 | |||
46 | URI: git://git.yoctoproject.org/meta-intel | ||
47 | layers: intel | ||
48 | branch: master | ||
49 | |||
50 | |||
51 | Patches | ||
52 | ======= | ||
53 | |||
54 | Please submit any patches against this BSP to the Yocto mailing list | ||
55 | (meta-intel@yoctoproject.org) and cc: the maintainer: | ||
56 | |||
57 | Maintainer: Ong Boon Leong <boon.leong.ong@intel.com> | ||
58 | |||
59 | Please see the meta-intel/MAINTAINERS file for more details. | ||
60 | |||
61 | |||
62 | Table of Contents | ||
63 | ================= | ||
64 | |||
65 | I. Building the meta-mohonpeak BSP layer | ||
66 | II. Booting the images in /binary | ||
67 | |||
68 | I. Building the meta-mohonpeak BSP layer | ||
69 | ======================================= | ||
70 | |||
71 | In order to build an image with BSP support for a given release, you | ||
72 | need to download the corresponding BSP tarball from the 'Board Support | ||
73 | Package (BSP) Downloads' page of the Yocto Project website. | ||
74 | |||
75 | Having done that, and assuming you extracted the BSP tarball contents | ||
76 | at the top-level of your yocto build tree, you can build a mohonpeak | ||
77 | image by adding the location of the meta-mohonpeak layer to | ||
78 | bblayers.conf, along with the meta-intel layer itself (to access | ||
79 | common metadata shared between BSPs) e.g.: | ||
80 | |||
81 | yocto/meta-intel \ | ||
82 | yocto/meta-intel/meta-isg \ | ||
83 | yocto/meta-intel/meta-isg/meta-mohonpeak \ | ||
84 | |||
85 | To enable the 32-bit Mohon Peak layer, add the mohonpeak-32 MACHINE to local.conf: | ||
86 | |||
87 | MACHINE ?= "mohonpeak-32" | ||
88 | |||
89 | To enable the 64-bit Mohon Peak layer, add the mohonpeak-64 MACHINE to local.conf: | ||
90 | |||
91 | MACHINE ?= "mohonpeak-64" | ||
92 | |||
93 | You should then be able to build a mohonpeak image as such: | ||
94 | |||
95 | $ source oe-init-build-env | ||
96 | $ bitbake core-image-sato | ||
97 | |||
98 | At the end of a successful build, you should have a live image that | ||
99 | you can boot from a USB flash drive (see instructions on how to do | ||
100 | that below, in the section 'Booting the images from /binary'). | ||
101 | |||
102 | As an alternative to downloading the BSP tarball, you can also work | ||
103 | directly from the meta-intel git repository. For each BSP in the | ||
104 | 'meta-intel' repository, there are multiple branches, one | ||
105 | corresponding to each major release starting with 'laverne' (0.90), in | ||
106 | addition to the latest code which tracks the current master (note that | ||
107 | not all BSPs are present in every release). Instead of extracting a | ||
108 | BSP tarball at the top level of your yocto build tree, you can | ||
109 | equivalently check out the appropriate branch from the meta-intel | ||
110 | repository at the same location. | ||
111 | |||
112 | |||
113 | II. Booting the images in /binary | ||
114 | ================================= | ||
115 | |||
116 | This BSP contains bootable live images, which can be used to directly | ||
117 | boot Yocto off of a USB flash drive. | ||
118 | |||
119 | Under Linux, insert a USB flash drive. Assuming the USB flash drive | ||
120 | takes device /dev/sdf, use dd to copy the live image to it. For | ||
121 | example: | ||
122 | |||
123 | # dd if=core-image-sato-mohonpeak-64.hddimg of=/dev/sdf | ||
124 | # sync | ||
125 | # eject /dev/sdf | ||
126 | |||
127 | This should give you a bootable USB flash device. Insert the device | ||
128 | into a bootable USB socket on the target, and power on. This should | ||
129 | result in a system booted to the Sato graphical desktop. | ||
130 | |||
131 | If you want a terminal, use the arrows at the top of the UI to move to | ||
132 | different pages of available applications, one of which is named | ||
133 | 'Terminal'. Clicking that should give you a root terminal. | ||
134 | |||
135 | If you want to ssh into the system, you can use the root terminal to | ||
136 | ifconfig the IP address and use that to ssh in. The root password is | ||
137 | empty, so to log in type 'root' for the user name and hit 'Enter' at | ||
138 | the Password prompt: and you should be in. | ||
139 | |||
140 | ---- | ||
141 | |||
142 | If you find you're getting corrupt images on the USB (it doesn't show | ||
143 | the syslinux boot: prompt, or the boot: prompt contains strange | ||
144 | characters), try doing this first: | ||
145 | |||
146 | # dd if=/dev/zero of=/dev/sdf bs=1M count=512 | ||
diff --git a/meta-isg/meta-mohonpeak/README.sources b/meta-isg/meta-mohonpeak/README.sources new file mode 100644 index 00000000..b6f7c9f8 --- /dev/null +++ b/meta-isg/meta-mohonpeak/README.sources | |||
@@ -0,0 +1,18 @@ | |||
1 | The sources for the packages comprising the images shipped with this | ||
2 | BSP can be found at the following location: | ||
3 | |||
4 | http://downloads.yoctoproject.org/mirror/sources/ | ||
5 | |||
6 | The metadata used to generate the images shipped with this BSP, in | ||
7 | addition to the code contained in this BSP, can be found at the | ||
8 | following location: | ||
9 | |||
10 | http://www.yoctoproject.org/downloads/yocto-1.5.0/poky-dora-10.0.0.tar.bz2 | ||
11 | |||
12 | The metadata used to generate the images shipped with this BSP, in | ||
13 | addition to the code contained in this BSP, can also be found at the | ||
14 | following locations: | ||
15 | |||
16 | git://git.yoctoproject.org/poky.git | ||
17 | |||
18 | git://git.yoctoproject.org/meta-intel.git | ||
diff --git a/meta-isg/meta-mohonpeak/conf/layer.conf b/meta-isg/meta-mohonpeak/conf/layer.conf new file mode 100644 index 00000000..93ec112d --- /dev/null +++ b/meta-isg/meta-mohonpeak/conf/layer.conf | |||
@@ -0,0 +1,12 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH := "${BBPATH}:${LAYERDIR}" | ||
3 | |||
4 | # We have a recipes directory, add to BBFILES | ||
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes-*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "mohonpeak" | ||
9 | BBFILE_PATTERN_mohonpeak := "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_mohonpeak = "6" | ||
11 | |||
12 | LAYERDEPENDS_mohonpeak = "intel" | ||