summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb')
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb118
1 files changed, 4 insertions, 114 deletions
diff --git a/meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb b/meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb
index 83ccbfb1..d6e9af40 100644
--- a/meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb
+++ b/meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb
@@ -1,118 +1,8 @@
1DESCRIPTION = "Intel(r) QuickAssist Technology API" 1include qat16.inc
2HOMEPAGE = "https://01.org/packet-processing/intel%C2%AE-quickassist-technology-drivers-and-patches"
3 2
4#Dual BSD and GPLv2 License 3SRC_URI += "file://qat16_2.3.0-34-qat-add-install-target-to-makefiles.patch \
5LICENSE = "BSD & GPLv2" 4 file://qat16_2.3.0-34-qat-replace-strict_strtoull-with-kstrtoull.patch \
6LIC_FILES_CHKSUM = "\ 5 "
7 file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
8 file://${COMMON_LICENSE_DIR}/BSD;md5=3775480a712fc46a69647678acb234cb \
9 "
10PV = "2.3.0-34"
11DEPENDS += "zlib openssl"
12PROVIDES += "virtual/qat"
13
14SRC_URI="https://01.org/sites/default/files/page/qatmux.l.${PV}.tgz;name=qat \
15 file://qat16_2.3.0-34-qat-add-install-target-to-makefiles.patch \
16 file://qat16_2.3.0-34-qat-fix-for-cross-compilation-issue.patch \
17 file://qat16_2.3.0-34-qat-remove-local-path-from-makefile.patch \
18 "
19 6
20SRC_URI[qat.md5sum] = "9614bf598bc8e7eedc8adb6d29109033" 7SRC_URI[qat.md5sum] = "9614bf598bc8e7eedc8adb6d29109033"
21SRC_URI[qat.sha256sum] = "1f9708de3c132258eaa488c82760f374b6b6838c85cafef2e8c61034fe0f7031" 8SRC_URI[qat.sha256sum] = "1f9708de3c132258eaa488c82760f374b6b6838c85cafef2e8c61034fe0f7031"
22
23COMPATIBLE_MACHINE = "crystalforest"
24
25S = "${WORKDIR}/${ICP_DRIVER_TYPE}"
26ICP_TOOLS = "accelcomp"
27SAMPLE_CODE_DIR = "${S}/quickassist/lookaside/access_layer/src/sample_code"
28
29export ICP_DRIVER_TYPE = "QAT1.6"
30export ICP_FIRMWARE_DIR="dh895xcc"
31export ICP_ROOT = "${S}"
32export ICP_ENV_DIR = "${S}/quickassist/build_system/build_files/env_files"
33export ICP_BUILDSYSTEM_PATH = "${S}/quickassist/build_system"
34export ICP_TOOLS_TARGET = "${ICP_TOOLS}"
35export FUNC_PATH = "${ICP_ROOT}/quickassist/lookaside/access_layer/src/sample_code/functional"
36export KERNEL_SOURCE_ROOT = "${STAGING_KERNEL_DIR}"
37export ICP_BUILD_OUTPUT = "${D}"
38export DEST_LIBDIR = "${libdir}"
39export DEST_BINDIR = "${bindir}"
40export QAT_KERNEL_VER = "${KERNEL_VERSION}"
41export SAMPLE_BUILD_OUTPUT = "${D}"
42export MODULE_DIR = "${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"
43
44inherit module
45inherit update-rc.d
46INITSCRIPT_NAME = "qat_service"
47
48PARALLEL_MAKE = ""
49
50#To get around the double slashes in paths in QAT makefiles
51PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
52
53do_unpack2() {
54 cd ${S}/
55 tar xzvf ${ICP_DRIVER_TYPE}.L.${PV}.tar.gz
56}
57
58addtask unpack2 after do_unpack before do_patch
59
60do_compile () {
61 export LD="${LD} --hash-style=gnu"
62 export MACHINE="${TARGET_ARCH}"
63 cd ${S}/quickassist
64 oe_runmake EXTRA_OEMAKE="'CFLAGS=${CFLAGS} -fPIC'"
65
66 cd ${SAMPLE_CODE_DIR}
67 touch ${SAMPLE_CODE_DIR}/performance/compression/calgary
68 touch ${SAMPLE_CODE_DIR}/performance/compression/canterbury
69
70 #build the whole sample code: fips, functional, performance
71 oe_runmake 'all'
72 oe_runmake 'fips_user_code'
73}
74
75do_install() {
76 cd ${S}/quickassist
77 oe_runmake install
78
79 cd ${SAMPLE_CODE_DIR}
80 oe_runmake install
81
82 install -d ${D}/etc/udev/rules.d \
83 ${D}${includedir} \
84 ${D}${includedir}/dc \
85 ${D}${includedir}/lac \
86 ${D}${sysconfdir}/dh895xcc \
87 ${D}${base_libdir}/firmware
88
89 echo 'KERNEL=="icp_adf_ctl" MODE="0600"' > ${D}/etc/udev/rules.d/00-dh895xcc_qa.rules
90 echo 'KERNEL=="icp_dev[0-9]*" MODE="0600"' >> ${D}/etc/udev/rules.d/00-dh895xcc_qa.rules
91 echo 'KERNEL=="icp_dev_mem?" MODE="0600"' >> ${D}/etc/udev/rules.d/00-dh895xcc_qa.rules
92
93 install -m 640 ${S}/quickassist/include/*.h ${D}${includedir}
94 install -m 640 ${S}/quickassist/include/dc/*.h ${D}${includedir}/dc/
95 install -m 640 ${S}/quickassist/include/lac/*.h ${D}${includedir}/lac/
96 install -m 640 ${S}/quickassist/lookaside/access_layer/include/*.h ${D}${includedir}
97
98 install -m 0755 ${SAMPLE_CODE_DIR}/performance/compression/calgary ${D}${base_libdir}/firmware
99 install -m 0755 ${SAMPLE_CODE_DIR}/performance/compression/canterbury ${D}${base_libdir}/firmware
100
101 install -m 660 ${S}/quickassist/config/dh* ${D}${sysconfdir}/dh895xcc
102}
103
104PACKAGES += "${PN}-app"
105
106FILES_${PN}-dev = "${includedir}"
107
108FILES_${PN} += "\
109 ${base_libdir}/firmware/ \
110 ${sysconfdir}/ \
111 ${sysconfdir}/udev/rules.d/ \
112 ${sysconfdir}/init.d/ \
113 ${libdir}/ \
114 "
115
116FILES_${PN}-dbg += "${sysconfdir}/init.d/.debug"
117
118FILES_${PN}-app += "${bindir}/*"