summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch
new file mode 100644
index 00000000..db762e9e
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch
@@ -0,0 +1,33 @@
1From 893d208cc66fbe533ab4e3e66907c5f63266579b Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Thu, 2 Jul 2015 23:51:01 +0800
4Subject: [PATCH] dpdk: add --sysroot option within app makefile
5
6Upstream-Status: Inappropriate [configuration]
7
8rte.app.mk has been changed to add -Wl, to all items listed
9under EXTRA_LDFLAGS. It causes --sysroot=<path> to not setup
10correctly when we depends on gcc to setup for GNU ld.
11
12Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
13Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
14---
15 mk/rte.app.mk | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/mk/rte.app.mk b/mk/rte.app.mk
19index 8ecab41..35fcd8d 100644
20--- a/mk/rte.app.mk
21+++ b/mk/rte.app.mk
22@@ -186,7 +186,7 @@ ifeq ($(LINK_USING_CC),1)
23 override EXTRA_LDFLAGS := $(call linkerprefix,$(EXTRA_LDFLAGS))
24 O_TO_EXE = $(CC) $(CFLAGS) $(LDFLAGS_$(@)) \
25 -Wl,-Map=$(@).map,--cref -o $@ $(OBJS-y) $(call linkerprefix,$(LDFLAGS)) \
26- $(EXTRA_LDFLAGS) $(call linkerprefix,$(LDLIBS))
27+ $(EXTRA_LDFLAGS) $(SYSROOTPATH) $(call linkerprefix,$(LDLIBS))
28 else
29 O_TO_EXE = $(LD) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
30 -Map=$(@).map --cref -o $@ $(OBJS-y) $(LDLIBS)
31--
321.9.1
33