summaryrefslogtreecommitdiffstats
path: root/meta-fri2
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fri2')
-rw-r--r--meta-fri2/COPYING.MIT17
-rw-r--r--meta-fri2/README339
-rw-r--r--meta-fri2/README.sources17
-rw-r--r--meta-fri2/binary/.gitignore0
-rw-r--r--meta-fri2/conf/layer.conf12
-rw-r--r--meta-fri2/conf/machine/fri2-noemgd.conf36
-rw-r--r--meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend1
-rw-r--r--meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state411
-rw-r--r--meta-fri2/recipes-bsp/formfactor/formfactor/fri2-noemgd/machconfig3
-rw-r--r--meta-fri2/recipes-bsp/formfactor/formfactor_0.0.bbappend1
-rw-r--r--meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend13
-rw-r--r--meta-fri2/recipes-core/init-ifupdown/files/fri2-noemgd/interfaces9
-rw-r--r--meta-fri2/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend1
-rw-r--r--meta-fri2/recipes-kernel/kmod/kmod_git.bbappend3
14 files changed, 0 insertions, 863 deletions
diff --git a/meta-fri2/COPYING.MIT b/meta-fri2/COPYING.MIT
deleted file mode 100644
index fb950dc6..00000000
--- a/meta-fri2/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-fri2/README b/meta-fri2/README
deleted file mode 100644
index 6e90c335..00000000
--- a/meta-fri2/README
+++ /dev/null
@@ -1,339 +0,0 @@
1This README file contains information on building the meta-fri2 BSP
2layer and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The Fish River Island II BSP supports the Kontron M2M Smart Services
6Developer Kit, as described here:
7
8http://us.kontron.com/products/systems+and+platforms/m2m/m2m+smart+services+developer+kit.html
9
10The 'Queens Bay' platform consists of the Intel Atom E640T processor plus the
11Intel EG20T Platform Controller Hub (Tunnel Creek + Topcliff). The Fish River
12Island II includes a variety of communications options and other
13machine-to-machine (m2m) capabilities.
14
15Information on all Intel embedded platforms can be found here:
16
17 http://www.intel.com/p/en_US/embedded/hwsw/hardware
18
19
20Yocto Project Compatible
21========================
22
23This BSP is compatible with the Yocto Project as per the requirements
24listed here:
25
26 https://www.yoctoproject.org/webform/yocto-project-compatible-registration
27
28
29Dependencies
30============
31
32This layer depends on:
33
34 URI: git://git.openembedded.org/bitbake
35 branch: master
36
37 URI: git://git.openembedded.org/openembedded-core
38 layers: meta
39 branch: master
40
41 URI: git://git.yoctoproject.org/meta-intel
42 layers: intel
43 branch: master
44
45
46Patches
47=======
48
49Please submit any patches against this BSP to the meta-intel mailing list
50(meta-intel@yoctoproject.org) and cc: the maintainer:
51
52Maintainer: Darren Hart <dvhart@linux.intel.com>
53
54Please see the meta-intel/MAINTAINERS file for more details.
55
56
57Table of Contents
58=================
59
60 I. Building the meta-fri2 BSP layer
61 II. Booting the images in /binary
62III. Device Notes
63 a. BIOS and Firmware
64 b. Serial Port
65 c. HDMI
66 d. Power Reset
67 e. Accelerometer
68 f. GPIO
69 g. MMC
70 h. 802.11
71 i. 802.15.4
72 j. Audio
73 k. Optional Devices
74 IV. Known Issues
75 a. EFI boot fails
76 b. Client USB is disabled
77 c. Audio over secondary HDMI port only
78 V. Additional Resources
79
80
81I. Building the meta-fri2 BSP layer
82===================================
83
84In order to build an image with BSP support for a given release, you
85need to download the corresponding BSP tarball from the 'Board Support
86Package (BSP) Downloads' page of the Yocto Project website.
87
88Having done that, and assuming you extracted the BSP tarball contents
89at the top-level of your yocto build tree, you can build an fri2 image
90by adding the location of the meta-intel and meta-fri2 layers to
91bblayers.conf, e.g.:
92
93 yocto/meta-intel \
94 yocto/meta-intel/meta-fri2 \
95
96The meta-fri2 layer contains support for fri2-noemgd machine configuration.
97The previously supported fri2 machine with the proprietary EMGD graphics
98driver has been retired. The 'fri2-noemgd' machine configuration uses
99the open source 'vesa' kernel driver.
100
101To enable the layer add the following to the local.conf file:
102
103 MACHINE ?= "fri2-noemgd"
104
105You should then be able to build an fri2 image as such:
106
107 $ source oe-init-build-env
108 $ bitbake core-image-sato
109
110At the end of a successful build, you should have a live image that
111you can boot from a USB flash drive (see instructions on how to do
112that below, in the section 'Booting the images from /binary').
113
114As an alternative to downloading the BSP tarball, you can also work
115directly from the meta-intel git repository. For each BSP in the
116'meta-intel' repository, there are multiple branches, one
117corresponding to each major release starting with 'laverne' (0.90), in
118addition to the latest code which tracks the current master (note that
119not all BSPs are present in every release). Instead of extracting a
120BSP tarball at the top level of your yocto build tree, you can
121equivalently check out the appropriate branch from the meta-intel
122repository at the same location.
123
124
125II. Booting the images in /binary
126=================================
127
128This BSP contains bootable live images, which can be used to directly
129boot Yocto off of a USB flash drive.
130
131Under Linux, insert a USB flash drive. Assuming the USB flash drive
132takes device /dev/sdf, use dd to copy the live image to it. For
133example:
134
135# dd if=core-image-sato-fri2-noemgd.hddimg of=/dev/sdf
136# sync
137# eject /dev/sdf
138
139This should give you a bootable USB flash device. Insert the device
140into one of the USB host ports on the target, and power on. This
141should result in a system booted to the Sato graphical desktop.
142
143If you want a terminal, use the arrows at the top of the UI to move to
144different pages of available applications, one of which is named
145'Terminal'. Clicking that should give you a root terminal.
146
147If you want to ssh into the system, you can use the root terminal to
148ifconfig the IP address and use that to ssh in. The root password is
149empty, so to log in type 'root' for the user name and hit 'Enter' at
150the Password prompt: and you should be in.
151
152If instead of a live image, you would like to prepare an EFI bootable
153partitioned image, use the mkefidisk.sh script provided in the scripts
154directory of this BSP. Future versions of the images have an EFI
155installer integrated into the live image.
156
157----
158
159If you find you're getting corrupt images on the USB (it doesn't show
160the syslinux boot: prompt, or the boot: prompt contains strange
161characters), try doing this first:
162
163# dd if=/dev/zero of=/dev/sdf bs=1M count=512
164
165
166III. Device Notes
167================================
168a. BIOS and Firmware
169
170Units provided from the Yocto Project Fish River Island 2 Giveaway
171Program are preconfigured with the Intel provided Fast Boot EFI
172firmware. This firmware will search the available devices (USB, SD,
173and mSATA) for a valid EFI payload at "EFI\BOOT\BOOTIA32.EFI". If it
174fails to find one, it will launch the EFI shell and optionally execute
175a "startup.nsh" script if it finds the script on the available storage
176devices. It searches the devices in the following order: USB, SD,
177mSATA.
178
179Units acquired via other channels may have the Kontron supplied APTIO
180(AMI) BIOS. This is a PCBIOS and EFI firmware with a traditional BIOS
181configuration menu which can be used to define a variety of boot
182configurations.
183
184b. Serial Port
185--------------
186The FRI2 has an optional serial daughter card providing a serial
187console via the micro-USB port on the top of the device adjacent the
188SIM card slot.
189
190The UART from the EG20T is connected to a TI UART-to-USB device
191(TUSB3410) which appears as a serial port on the host computer. From a
192Linux host, load the driver with the following options:
193
194# modprobe ti_usb_3410_5052 vendor_3410=0x0451 product_3410=0x5053
195
196In future versions of the Linux kernel (3.4 and later), the
197vendor and product codes are detected automatically.
198
199When you power on your FRI2, your host will discover a serial device
200and name it /dev/ttyUSB0 (or similar). You can communicate with this
201device at 115200 8N1 using your preferred terminal emulator.
202
203If using the Intel provided Fast Boot EFI firmware, no additional
204configuration is required. If using the APTIO (AMI) BIOS, use the
205following settings to configure console redirection in the BIOS menu:
206
207 Advanced
208 Serial Port Console Redirection
209 COM2
210 Console Redirection [Enabled]
211 Console Redirection Settings
212 Terminal Type [ANSI]
213 Bits per second [115200]
214 Data Bits [8]
215 Parity [None]
216 Stop Bits [1]
217 Flow Control [None]
218 Recorder Mode [Disabled]
219 Resolution 100x31 [Disabled]
220 Legacy OS Redirection [80x24]
221
222c. HDMI
223-------
224The FRI2 has two micro HDMI ports. For the Intel provided Fast Boot
225EFI firmware, the one closest to the bottom of the device is the
226primary display. For the APTIO (AMI) BIOS, the jack nearest the 1/8"
227audio jacks is the primary display.
228
229d. Power Reset
230--------------
231The recessed button adjacent the LEDs on the top of the device is a
232power reset button.
233
234e. Accelerometer
235----------------
236The LIS331DLH accelerometer is connected to the I2C bus on the CPLD on
237the compute module. The driver for this chip is under active
238development and will be included in the BSP once completed.
239
240f. GPIO
241-------
242The FRI2 has two I2C PCA555x GPIO devices used for internal control
243signals. These have not been exposed in the current release of the
244BSP, but may be in the future. Regardless, these would not provide
245general purpose IO with which to read or drive additional signals.
246
247g. MMC
248------
249The FRI2 provides two microSD card MMC devices. One is located
250adjacent the 1/8" audio jacks, another is located on the board inside
251the chassis. These devices can be used to boot the device, or as
252secondary storage.
253
254h. 802.11
255---------
256The Intel Corporation Centrino Advanced-N 6205 that ships with the
257FRI2 is supported. You can use connman-gnome to configures the
258interface.
259
260i. 802.15.4
261-----------
262The TI CC2531 802.15.4 radio is a USB ACM modem. The MAC is enabled by
263issuing the following command:
264
265# echo J > /dev/ttyACM0
266
267The bank of 3 LEDs nearest the power reset button will change if this
268command is executed successfully. If you have a 3G modem installed,
269the 802.15.4 device may appear as /dev/ttyACM3 instead.
270
271No further testing or integration has been done.
272
273j. Audio
274--------------------
275The FRI2 has an 1/8" analog output (nearest the antennae), a line-in
276input below that, as well as SPDIF over HDMI. These can be tested
277using the alsa-utils package. The aplay -l command will list both
278playback devices:
279
280# aplay -l
281**** List of PLAYBACK Hardware Devices ****
282card 0: MID [HDA Intel MID], device 0: ALC262 Analog [ALC262 Analog]
283 Subdevices: 1/1
284 Subdevice #0: subdevice #0
285card 0: MID [HDA Intel MID], device 3: ALC262 Digital [ALC262 Digital]
286 Subdevices: 1/1
287 Subdevice #0: subdevice #0
288
289Using a sample WAV file, you can use aplay to play to either device:
290
291Over analog:
292# aplay -D plughw:0,0 sample.wav
293
294Over HDMI:
295# aplay -D plughw:0,3 sample.wav
296
297
298k. Optional Devices
299-------------------
300The FRI2 has two mini-PCIe slots internally. The device ships with a
301half-length wireless card installed. This can be replaced with a
302wireless + bluetooth card. The other slot is available for use with
303cellular cards or mSATA SSDs.
304
305The Ericsson F5521gw 3G modem has been verifed with the FRI2 images.
306Note that the connman-gnome UI does not allow for configuring the
307cellular interface. The ofono-tests package can be used to configure
308the modem and bring up an interface.
309
310
311IV. Known Issues
312----------------
313a. EFI
314------
315The APTIO (AMI) BIOS does not yet boot the EFI payload provided on the
316FRI2 live image. This is a known issue under investigation. If using
317this firmware, boot using PCBIOS mode, rather than EFI. The Intel
318provided Fast Boot EFI firmware will boot the EFI payload.
319
320b. Client USB is disabled
321-------------------------
322The micro-USB port adjacent the primary HDMI port is intended for Client
323USB functionality, but is not supported on current revisions of the
324device.
325
326c. Audio over secondary HDMI port only
327--------------------------------------
328While audio over HDMI has been shown to work, it seems to only work over
329the secondary (bottom-most) HDMI port. There does not appear to be a
330deterministic way of getting the device to output the signal (video and
331audio) over the secondary port.
332
333
334V. Additional Resources
335-----------------------
336In addition to this README, please see the following wiki page for tips
337on using the FRI2 with the Yocto Project:
338
339https://wiki.yoctoproject.org/wiki/BSPs/FRI2
diff --git a/meta-fri2/README.sources b/meta-fri2/README.sources
deleted file mode 100644
index 0d4d849a..00000000
--- a/meta-fri2/README.sources
+++ /dev/null
@@ -1,17 +0,0 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://downloads.yoctoproject.org/releases/yocto/yocto-1.3/poky-danny-8.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-fri2/binary/.gitignore b/meta-fri2/binary/.gitignore
deleted file mode 100644
index e69de29b..00000000
--- a/meta-fri2/binary/.gitignore
+++ /dev/null
diff --git a/meta-fri2/conf/layer.conf b/meta-fri2/conf/layer.conf
deleted file mode 100644
index 0bb29a13..00000000
--- a/meta-fri2/conf/layer.conf
+++ /dev/null
@@ -1,12 +0,0 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "fri2"
9BBFILE_PATTERN_fri2 := "^${LAYERDIR}/"
10BBFILE_PRIORITY_fri2 = "6"
11
12LAYERDEPENDS_fri2 = "intel"
diff --git a/meta-fri2/conf/machine/fri2-noemgd.conf b/meta-fri2/conf/machine/fri2-noemgd.conf
deleted file mode 100644
index bdf4b0dd..00000000
--- a/meta-fri2/conf/machine/fri2-noemgd.conf
+++ /dev/null
@@ -1,36 +0,0 @@
1#@TYPE: Machine
2#@NAME: fri2
3
4#@WEBTITLE: Intel Atom E640T Processor with Intel EG20T Controller Hub Development Kit (Queens Bay) with Open Source VESA Graphics for Fish River Island II systems
5
6#@DESCRIPTION: Machine configuration for Fish River Island II systems, without Intel-proprietary graphics bits
7
8require conf/machine/include/intel-core2-32-common.inc
9require conf/machine/include/intel-common-pkgarch.inc
10require conf/machine/include/meta-intel.inc
11
12MACHINE_FEATURES += "wifi 3g pcbios efi"
13MACHINE_FEATURES += "intel-ucode"
14
15MACHINE_EXTRA_RRECOMMENDS += "linux-firmware-iwlwifi-6000g2a-5"
16
17PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
18PREFERRED_VERSION_linux-yocto ?= "3.19%"
19
20XSERVER ?= "${XSERVER_X86_BASE} \
21 ${XSERVER_X86_EXT} \
22 ${XSERVER_X86_FBDEV} \
23 "
24
25# Syslinux does not know about the 64MHz uart clock and it does not detect the
26# serial device by number. Use the IO port directly and divide the baud down to
27# trick syslinux into configuring a 115200 baud.
28SYSLINUX_OPTS = "serial 0xb060 3318"
29SERIAL_CONSOLE = "115200 ttyPCH1"
30APPEND += "console=ttyPCH1,115200 console=tty0"
31
32# EFI boot will ignore this and use the EFI framebuffer at 800x600
33APPEND += "video=vesafb vga=0x318"
34
35# MSI interrupts fail for the HDA device when using the EFI firmware
36APPEND += "snd_hda_intel.enable_msi=0"
diff --git a/meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend b/meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state
deleted file mode 100644
index 8a89f0bc..00000000
--- a/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state
+++ /dev/null
@@ -1,411 +0,0 @@
1state.MID {
2 control.1 {
3 iface MIXER
4 name 'PCM Playback Volume'
5 value.0 24
6 value.1 24
7 comment {
8 access 'read write'
9 type INTEGER
10 count 2
11 range '0 - 30'
12 dbmin -4500
13 dbmax 0
14 dbvalue.0 -900
15 dbvalue.1 -900
16 }
17 }
18 control.2 {
19 iface MIXER
20 name 'PCM Playback Switch'
21 value.0 true
22 value.1 true
23 comment {
24 access 'read write'
25 type BOOLEAN
26 count 2
27 }
28 }
29 control.3 {
30 iface MIXER
31 name 'Headphone Playback Volume'
32 value.0 0
33 value.1 0
34 comment {
35 access 'read write'
36 type INTEGER
37 count 2
38 range '0 - 30'
39 dbmin -4500
40 dbmax 0
41 dbvalue.0 -4500
42 dbvalue.1 -4500
43 }
44 }
45 control.4 {
46 iface MIXER
47 name 'Headphone Playback Switch'
48 value.0 false
49 value.1 false
50 comment {
51 access 'read write'
52 type BOOLEAN
53 count 2
54 }
55 }
56 control.5 {
57 iface MIXER
58 name 'Rear Mic Playback Volume'
59 value.0 0
60 value.1 0
61 comment {
62 access 'read write'
63 type INTEGER
64 count 2
65 range '0 - 31'
66 dbmin -3450
67 dbmax 1200
68 dbvalue.0 -3450
69 dbvalue.1 -3450
70 }
71 }
72 control.6 {
73 iface MIXER
74 name 'Rear Mic Playback Switch'
75 value.0 false
76 value.1 false
77 comment {
78 access 'read write'
79 type BOOLEAN
80 count 2
81 }
82 }
83 control.7 {
84 iface MIXER
85 name 'Front Mic Playback Volume'
86 value.0 0
87 value.1 0
88 comment {
89 access 'read write'
90 type INTEGER
91 count 2
92 range '0 - 31'
93 dbmin -3450
94 dbmax 1200
95 dbvalue.0 -3450
96 dbvalue.1 -3450
97 }
98 }
99 control.8 {
100 iface MIXER
101 name 'Front Mic Playback Switch'
102 value.0 false
103 value.1 false
104 comment {
105 access 'read write'
106 type BOOLEAN
107 count 2
108 }
109 }
110 control.9 {
111 iface MIXER
112 name 'Line Playback Volume'
113 value.0 0
114 value.1 0
115 comment {
116 access 'read write'
117 type INTEGER
118 count 2
119 range '0 - 31'
120 dbmin -3450
121 dbmax 1200
122 dbvalue.0 -3450
123 dbvalue.1 -3450
124 }
125 }
126 control.10 {
127 iface MIXER
128 name 'Line Playback Switch'
129 value.0 false
130 value.1 false
131 comment {
132 access 'read write'
133 type BOOLEAN
134 count 2
135 }
136 }
137 control.11 {
138 iface MIXER
139 name 'CD Playback Volume'
140 value.0 0
141 value.1 0
142 comment {
143 access 'read write'
144 type INTEGER
145 count 2
146 range '0 - 31'
147 dbmin -3450
148 dbmax 1200
149 dbvalue.0 -3450
150 dbvalue.1 -3450
151 }
152 }
153 control.12 {
154 iface MIXER
155 name 'CD Playback Switch'
156 value.0 false
157 value.1 false
158 comment {
159 access 'read write'
160 type BOOLEAN
161 count 2
162 }
163 }
164 control.13 {
165 iface MIXER
166 name 'Auto-Mute Mode'
167 value Disabled
168 comment {
169 access 'read write'
170 type ENUMERATED
171 count 1
172 item.0 Disabled
173 item.1 Enabled
174 }
175 }
176 control.14 {
177 iface MIXER
178 name 'Rear Mic Boost Volume'
179 value.0 0
180 value.1 0
181 comment {
182 access 'read write'
183 type INTEGER
184 count 2
185 range '0 - 3'
186 dbmin 0
187 dbmax 3000
188 dbvalue.0 0
189 dbvalue.1 0
190 }
191 }
192 control.15 {
193 iface MIXER
194 name 'Front Mic Boost Volume'
195 value.0 0
196 value.1 0
197 comment {
198 access 'read write'
199 type INTEGER
200 count 2
201 range '0 - 3'
202 dbmin 0
203 dbmax 3000
204 dbvalue.0 0
205 dbvalue.1 0
206 }
207 }
208 control.16 {
209 iface MIXER
210 name 'Capture Switch'
211 value.0 true
212 value.1 true
213 comment {
214 access 'read write'
215 type BOOLEAN
216 count 2
217 }
218 }
219 control.17 {
220 iface MIXER
221 name 'Capture Switch'
222 index 1
223 value.0 false
224 value.1 false
225 comment {
226 access 'read write'
227 type BOOLEAN
228 count 2
229 }
230 }
231 control.18 {
232 iface MIXER
233 name 'Capture Switch'
234 index 2
235 value.0 false
236 value.1 false
237 comment {
238 access 'read write'
239 type BOOLEAN
240 count 2
241 }
242 }
243 control.19 {
244 iface MIXER
245 name 'Capture Volume'
246 value.0 25
247 value.1 25
248 comment {
249 access 'read write'
250 type INTEGER
251 count 2
252 range '0 - 31'
253 dbmin -1200
254 dbmax 3450
255 dbvalue.0 2550
256 dbvalue.1 2550
257 }
258 }
259 control.20 {
260 iface MIXER
261 name 'Capture Volume'
262 index 1
263 value.0 0
264 value.1 0
265 comment {
266 access 'read write'
267 type INTEGER
268 count 2
269 range '0 - 31'
270 dbmin -1200
271 dbmax 3450
272 dbvalue.0 -1200
273 dbvalue.1 -1200
274 }
275 }
276 control.21 {
277 iface MIXER
278 name 'Capture Volume'
279 index 2
280 value.0 0
281 value.1 0
282 comment {
283 access 'read write'
284 type INTEGER
285 count 2
286 range '0 - 31'
287 dbmin -1200
288 dbmax 3450
289 dbvalue.0 -1200
290 dbvalue.1 -1200
291 }
292 }
293 control.22 {
294 iface MIXER
295 name 'Input Source'
296 value Line
297 comment {
298 access 'read write'
299 type ENUMERATED
300 count 1
301 item.0 'Rear Mic'
302 item.1 'Front Mic'
303 item.2 Line
304 item.3 CD
305 }
306 }
307 control.23 {
308 iface MIXER
309 name 'Input Source'
310 index 1
311 value 'Rear Mic'
312 comment {
313 access 'read write'
314 type ENUMERATED
315 count 1
316 item.0 'Rear Mic'
317 item.1 'Front Mic'
318 item.2 Line
319 item.3 CD
320 }
321 }
322 control.24 {
323 iface MIXER
324 name 'Input Source'
325 index 2
326 value 'Rear Mic'
327 comment {
328 access 'read write'
329 type ENUMERATED
330 count 1
331 item.0 'Rear Mic'
332 item.1 'Front Mic'
333 item.2 Line
334 item.3 CD
335 }
336 }
337 control.25 {
338 iface MIXER
339 name 'IEC958 Playback Con Mask'
340 value '0fff000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
341 comment {
342 access read
343 type IEC958
344 count 1
345 }
346 }
347 control.26 {
348 iface MIXER
349 name 'IEC958 Playback Pro Mask'
350 value '0f00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
351 comment {
352 access read
353 type IEC958
354 count 1
355 }
356 }
357 control.27 {
358 iface MIXER
359 name 'IEC958 Playback Default'
360 value '0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
361 comment {
362 access 'read write'
363 type IEC958
364 count 1
365 }
366 }
367 control.28 {
368 iface MIXER
369 name 'IEC958 Playback Switch'
370 value true
371 comment {
372 access 'read write'
373 type BOOLEAN
374 count 1
375 }
376 }
377 control.29 {
378 iface MIXER
379 name 'IEC958 Default PCM Playback Switch'
380 value true
381 comment {
382 access 'read write'
383 type BOOLEAN
384 count 1
385 }
386 }
387 control.30 {
388 iface MIXER
389 name 'Master Playback Volume'
390 value 24
391 comment {
392 access 'read write'
393 type INTEGER
394 count 1
395 range '0 - 30'
396 dbmin -4500
397 dbmax 0
398 dbvalue.0 -900
399 }
400 }
401 control.31 {
402 iface MIXER
403 name 'Master Playback Switch'
404 value true
405 comment {
406 access 'read write'
407 type BOOLEAN
408 count 1
409 }
410 }
411}
diff --git a/meta-fri2/recipes-bsp/formfactor/formfactor/fri2-noemgd/machconfig b/meta-fri2/recipes-bsp/formfactor/formfactor/fri2-noemgd/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-fri2/recipes-bsp/formfactor/formfactor/fri2-noemgd/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-fri2/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-fri2/recipes-bsp/formfactor/formfactor_0.0.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-fri2/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend b/meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend
deleted file mode 100644
index f6105711..00000000
--- a/meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
1# The Intel provided Fast Boot Firmware may not initialize the USB keyboard
2# before launching the grub.efi payload. Ensure GRUB has keyboard control by
3# building in the usb, usb_keyboard, and ohci modules.
4
5do_deploy() {
6 # Search for the grub.cfg on the local boot media by using the
7 # built in cfg file provided via this recipe
8 grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
9 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
10 boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search \
11 usb usb_keyboard ohci
12 install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
13}
diff --git a/meta-fri2/recipes-core/init-ifupdown/files/fri2-noemgd/interfaces b/meta-fri2/recipes-core/init-ifupdown/files/fri2-noemgd/interfaces
deleted file mode 100644
index f5bb9468..00000000
--- a/meta-fri2/recipes-core/init-ifupdown/files/fri2-noemgd/interfaces
+++ /dev/null
@@ -1,9 +0,0 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wired or wireless interfaces
8auto eth0
9iface eth0 inet dhcp
diff --git a/meta-fri2/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend b/meta-fri2/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend
deleted file mode 100644
index 81fe7b79..00000000
--- a/meta-fri2/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
diff --git a/meta-fri2/recipes-kernel/kmod/kmod_git.bbappend b/meta-fri2/recipes-kernel/kmod/kmod_git.bbappend
deleted file mode 100644
index 56d8fcb0..00000000
--- a/meta-fri2/recipes-kernel/kmod/kmod_git.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
1do_install_append () {
2 echo "blacklist gma500_gfx" > ${D}${sysconfdir}/modprobe.d/prohibit_gma500_gfx.conf
3}