summaryrefslogtreecommitdiffstats
path: root/meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend')
-rw-r--r--meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend b/meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend
new file mode 100644
index 00000000..c6904ef0
--- /dev/null
+++ b/meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend
@@ -0,0 +1,11 @@
1# The Intel provided Fast Boot Firmware may not initialize the USB keyboard
2# before launching the grub.efi payload. Ensure GRUB has keyboard control by
3# building in the usb, usb_keyboard, and ohci modules.
4
5do_mkimage() {
6 ./grub-mkimage -p /EFI/BOOT -d ./grub-core/ \
7 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
8 boot linux ext2 fat serial part_msdos part_gpt normal efi_gop \
9 usb usb_keyboard ohci
10}
11