summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb')
-rw-r--r--meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb57
1 files changed, 0 insertions, 57 deletions
diff --git a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
deleted file mode 100644
index 03c0258a..00000000
--- a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
+++ /dev/null
@@ -1,57 +0,0 @@
1DESCRIPTION = "X11 drivers for Poulsbo (psb) 3D acceleration"
2
3# There's a mesa implementation in this package, which is presumably
4# not Intel proprietary, but it has no obvious license attached to it.
5LICENSE = "Intel-binary-only"
6LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=02c597a2f082b4581596065bb5a521a8"
7PR = "r10"
8
9inherit autotools
10
11PROVIDES = "virtual/libgl mesa-dri"
12
13SRC_URI="https://launchpad.net/~gma500/+archive/ppa/+files/xpsb-glx_0.18-0ubuntu1netbook2~1004um1ubuntu1.tar.gz \
14 file://cross-compile.patch \
15 file://libdrmname.patch \
16 file://native-matypes.patch"
17
18SRC_URI[md5sum] = "50423a9e861ccff5814eb95a32494952"
19SRC_URI[sha256sum] = "03c958defef56ae0ec051c6f67620fa90733649925386824b7bf029f40bd7905"
20
21do_configure () {
22 chmod +x autogen.sh && ./autogen.sh ${CONFIGUREOPTS} && make realclean
23 cd ${S}/src/mesa/x86/
24 ${BUILD_CC} -I../../../include/GL -I../../../include -I.. -I../main -I../math -I../glapi -I../tnl -Wall -Wmissing-prototypes -std=c99 -ffast-math -fPIC -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DHAVE_POSIX_MEMALIGN -DUSE_X86_ASM -DUSE_MMX_ASM -DUSE_3DNOW_ASM -DUSE_SSE_ASM -fno-strict-aliasing gen_matypes.c -o gen_matypes
25}
26
27do_install() {
28 make DESTDIR=${D} install
29 install -d -m 0755 ${D}/${libdir}/xorg/modules/dri \
30 ${D}/${libdir}/xorg/modules/drivers
31 install -m 0644 ${WORKDIR}/${PN}-${PV}/dri/* \
32 ${D}/${libdir}/xorg/modules/dri
33 install -m 0644 ${WORKDIR}/${PN}-${PV}/drivers/* \
34 ${D}/${libdir}/xorg/modules/drivers
35 ln -s ${libdir}/xorg/modules/dri ${D}${libdir}/dri
36}
37
38S = "${WORKDIR}/${PN}-${PV}/mesa"
39
40EXTRA_OEMAKE = "linux-dri-x86"
41
42DEPENDS += "libxfixes libxdamage libdrm-poulsbo libxxf86vm dri2proto libxmu libxi glproto makedepend-native"
43
44FILES_${PN}-dev += "${libdir}/pkgconfig"
45FILES_${PN} += "${libdir}/xorg/modules/dri/* \
46 ${libdir}/xorg/modules/drivers/* \
47 ${libdir}/dri"
48
49PACKAGES =+ "libglu libglu-dev"
50
51FILES_libglu = "${libdir}/libGLU.so.*"
52FILES_libglu-dev = "${libdir}/libGLU.* ${includedir}/GL/glu*.h"
53
54# Multiple virtual/gl providers being built breaks staging
55EXCLUDE_FROM_WORLD = "1"
56
57COMPATIBLE_MACHINE = "emenlow"