summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-graphics/libva/libva_0.31.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-emenlow/recipes-graphics/libva/libva_0.31.0.bb')
-rw-r--r--meta-emenlow/recipes-graphics/libva/libva_0.31.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-graphics/libva/libva_0.31.0.bb b/meta-emenlow/recipes-graphics/libva/libva_0.31.0.bb
new file mode 100644
index 00000000..a3164098
--- /dev/null
+++ b/meta-emenlow/recipes-graphics/libva/libva_0.31.0.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Video Acceleration (VA) API for Linux"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://COPYING;md5=efc13a0998e678466e556756613c582e"
4PR = "r1"
5DEPENDS = "libxext"
6
7inherit autotools
8
9SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libva_0.31.0-1+sds9.1ubuntu1.tar.gz \
10 file://033_g45_add_rgba_subpic.patch \
11 file://034_g45_fix_return_for_unimpl.patch \
12 file://035_g45_add_yv12_image_format.patch \
13 file://036_g45_add_vaGetImage.patch \
14 file://037_g45_add_vaPutImage.patch \
15 file://038_g45_vaPutSurface_cliprects.patch \
16 file://102_attribute_visibility.patch \
17 file://103_fix_vainfo_deps.patch \
18 file://104_fix_libva_pkgconfig_deps.patch \
19 file://105_dont_search_LIBGL_DRIVERS_PATH.patch \
20 file://108_drivers_path.patch \
21 file://203_fix_fglrx_detection.patch \
22 file://204_check_ATIFGLEXTENSION.patch \
23 file://300_sds_version.patch \
24 file://301_vdpau_mpeg4.patch \
25 file://320_move_vaPutSurface_flags_def.patch \
26 file://321_libva_glx.base.patch \
27 file://322_libva_glx.patch \
28 file://390_compat.base.patch \
29 file://391_compat.patch \
30 file://392_compat.dso.patch \
31 file://libdrm-poulsbo.patch"
32
33export LDFLAGS="-Wl,-z,defs"
34
35EXTRA_OECONF = "--disable-i965-driver"
36
37FILES_${PN} += "${libdir}/va/drivers/*"
38
39COMPATIBLE_MACHINE = "emenlow"
40PACKAGE_ARCH = "${MACHINE_ARCH}"