summaryrefslogtreecommitdiffstats
path: root/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/zlib-qat-qat_mem-use-the-right-compiler.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/zlib-qat-qat_mem-use-the-right-compiler.patch')
-rw-r--r--meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/zlib-qat-qat_mem-use-the-right-compiler.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/zlib-qat-qat_mem-use-the-right-compiler.patch b/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/zlib-qat-qat_mem-use-the-right-compiler.patch
new file mode 100644
index 00000000..7b9af291
--- /dev/null
+++ b/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/zlib-qat-qat_mem-use-the-right-compiler.patch
@@ -0,0 +1,31 @@
1From 22a4ef23792251c284d9766ab5ee87cbeeef2ec4 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Thu, 16 Jul 2015 11:05:38 +0800
4Subject: [PATCH] qat_mem: use the right compiler
5
6Upstream-Status: Inappropriate [Configuration]
7
8Use $(CC) instead of gcc directly. Makes sure that the
9right options are being passed for cross-compile.
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 contrib/qat/qat_mem/Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/contrib/qat/qat_mem/Makefile b/contrib/qat/qat_mem/Makefile
17index 0a521f2..2c7c8dc 100644
18--- a/contrib/qat/qat_mem/Makefile
19+++ b/contrib/qat/qat_mem/Makefile
20@@ -64,7 +64,7 @@ MODULENAME := qat_mem
21 KDIR := $(KERNEL_SOURCE_ROOT)
22 PWD := $(shell pwd)
23
24-CC := gcc -Wall -imacros $(KERNEL_SOURCE_ROOT)/include/generated/autoconf.h
25+CC := $(CC) -Wall -imacros $(KERNEL_SOURCE_ROOT)/include/generated/autoconf.h
26
27 ifeq ($(KERNELRELEASE),)
28 all: $(MODULENAME)_test
29--
301.7.9.5
31