summaryrefslogtreecommitdiffstats
path: root/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/0001-Fix-for-Zlib-qat-Compilation-issue.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/0001-Fix-for-Zlib-qat-Compilation-issue.patch')
-rw-r--r--meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/0001-Fix-for-Zlib-qat-Compilation-issue.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/0001-Fix-for-Zlib-qat-Compilation-issue.patch b/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/0001-Fix-for-Zlib-qat-Compilation-issue.patch
new file mode 100644
index 00000000..5d7ca95c
--- /dev/null
+++ b/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat/0001-Fix-for-Zlib-qat-Compilation-issue.patch
@@ -0,0 +1,54 @@
1From 9ba7bca8e30f76cdc9d667dd7b6d203314301edc Mon Sep 17 00:00:00 2001
2From: venkatasubramanian pattu <venkatasubramanianx.pattu@intel.com>
3Date: Thu, 11 Jun 2015 11:45:33 +0800
4Subject: [PATCH] Fix for Zlib-qat Compilation issue
5
6This patch is used to fix the compliation issue when QAT is enabled with
7Zlib.
8
9When compiling the Zlib-qat by default it takes the kernel source from the host machine .
10Since we are working on the yocto recipe implementation we need to change the path
11of the kernel source by exporting the variable (KERNEL_SOURCE_ROOT) in the main recipe.
12
13Upstream-Status: Inappropriate
14
15Signed-off-by: venkatasubramanian pattu <venkatasubramanianx.pattu@intel.com>
16---
17 contrib/qat/qat_mem/Makefile | 12 ++++--------
18 1 file changed, 4 insertions(+), 8 deletions(-)
19
20diff --git a/contrib/qat/qat_mem/Makefile b/contrib/qat/qat_mem/Makefile
21index ddf5b59..0a521f2 100644
22--- a/contrib/qat/qat_mem/Makefile
23+++ b/contrib/qat/qat_mem/Makefile
24@@ -61,16 +61,10 @@
25 #########################################################################
26
27 MODULENAME := qat_mem
28-KDIR := /lib/modules/$(shell uname -r)/build
29+KDIR := $(KERNEL_SOURCE_ROOT)
30 PWD := $(shell pwd)
31
32-ifeq ($(shell uname -r|grep -c grsec-WR), 1)
33-AUTO_CONF=/lib/modules/$(shell uname -r)/build/include/generated/autoconf.h
34-else
35-AUTO_CONF=/usr/src/kernels/$(shell uname -r)/include/linux/autoconf.h
36-endif
37-
38-CC := gcc -Wall -imacros $(AUTO_CONF)
39+CC := gcc -Wall -imacros $(KERNEL_SOURCE_ROOT)/include/generated/autoconf.h
40
41 ifeq ($(KERNELRELEASE),)
42 all: $(MODULENAME)_test
43@@ -80,6 +74,8 @@ else
44 obj-m := $(MODULENAME).o
45 endif
46
47+modules_install:
48+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
49 $(MODULENAME)_test: $(MODULENAME)_test.c
50 $(CC) -g -o $(MODULENAME)_test $(MODULENAME)_test.c
51
52--
531.9.1
54