summaryrefslogtreecommitdiffstats
path: root/meta-crystalforest/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-crystalforest/conf')
-rw-r--r--meta-crystalforest/conf/layer.conf12
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-shumway.conf26
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-stargo.conf27
3 files changed, 65 insertions, 0 deletions
diff --git a/meta-crystalforest/conf/layer.conf b/meta-crystalforest/conf/layer.conf
new file mode 100644
index 00000000..6b802d63
--- /dev/null
+++ b/meta-crystalforest/conf/layer.conf
@@ -0,0 +1,12 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "crystalforest"
9BBFILE_PATTERN_crystalforest := "^${LAYERDIR}/"
10BBFILE_PRIORITY_crystalforest = "6"
11
12LAYERDEPENDS_crystalforest = "intel"
diff --git a/meta-crystalforest/conf/machine/crystalforest-shumway.conf b/meta-crystalforest/conf/machine/crystalforest-shumway.conf
new file mode 100644
index 00000000..0a2141c8
--- /dev/null
+++ b/meta-crystalforest/conf/machine/crystalforest-shumway.conf
@@ -0,0 +1,26 @@
1#@TYPE: Machine
2#@NAME: crystalforest-shumway
3
4#@DESCRIPTION: Machine configuration for Crystal Forest Server (SHUMWAY) systems
5# i.e. Two Sandy Bridge Jaketown processors (SNB-EP ES2 Grade and SNB-EN ES2 Grade) + Two Cave Creek Chipsets.
6
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
8PREFERRED_VERSION_linux-yocto ?= "3.4%"
9
10require conf/machine/include/tune-x86_64.inc
11require conf/machine/include/ia32-base.inc
12require conf/machine/include/meta-intel.inc
13
14XSERVER ?= "${XSERVER_IA32_BASE} \
15 ${XSERVER_IA32_EXT} \
16 ${XSERVER_IA32_MATROX_MGA} \
17 "
18#This Kernel Option is required for Intel Quick Assist Technology Software.
19APPEND += "acpi_enforce_resources=lax"
20
21#Uncomment the below Kernel Option if Virtualization is not needed.
22#APPEND += "intel_iommu=off"
23
24SYSLINUX_OPTS = "serial 0 115200"
25SERIAL_CONSOLE = "115200 ttyS0"
26APPEND += "console=ttyS0,115200 console=tty0"
diff --git a/meta-crystalforest/conf/machine/crystalforest-stargo.conf b/meta-crystalforest/conf/machine/crystalforest-stargo.conf
new file mode 100644
index 00000000..575a504d
--- /dev/null
+++ b/meta-crystalforest/conf/machine/crystalforest-stargo.conf
@@ -0,0 +1,27 @@
1#@TYPE: Machine
2#@NAME: crystalforest-stargo
3
4#@DESCRIPTION: Machine configuration for Crystal Forest (STARGO) systems
5# i.e. One Sandy Bridge based Gladden Processor + One Cave Creek Chipset
6
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
8PREFERRED_VERSION_linux-yocto ?= "3.4%"
9
10require conf/machine/include/tune-x86_64.inc
11require conf/machine/include/ia32-base.inc
12require conf/machine/include/meta-intel.inc
13
14XSERVER ?= "${XSERVER_IA32_BASE} \
15 ${XSERVER_IA32_EXT} \
16 ${XSERVER_IA32_MATROX_MGA} \
17 "
18
19#This Kernel Option is required for Intel Quick Assist Technology Software.
20APPEND += "acpi_enforce_resources=lax"
21
22#Uncomment the below Kernel Option if Virtualization is not needed.
23#APPEND += "intel_iommu=off"
24
25SYSLINUX_OPTS = "serial 0 115200"
26SERIAL_CONSOLE = "115200 ttyS0"
27APPEND += "console=ttyS0,115200 console=tty0"