summaryrefslogtreecommitdiffstats
path: root/meta-crownbay
diff options
context:
space:
mode:
Diffstat (limited to 'meta-crownbay')
-rw-r--r--meta-crownbay/COPYING.MIT17
-rw-r--r--meta-crownbay/README140
-rw-r--r--meta-crownbay/README.sources17
-rw-r--r--meta-crownbay/binary/.gitignore0
-rw-r--r--meta-crownbay/conf/layer.conf12
-rw-r--r--meta-crownbay/conf/machine/crownbay-noemgd.conf22
-rw-r--r--meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig3
-rw-r--r--meta-crownbay/recipes-bsp/formfactor/formfactor_0.0.bbappend1
-rw-r--r--meta-crownbay/recipes-kernel/kmod/kmod_git.bbappend3
9 files changed, 0 insertions, 215 deletions
diff --git a/meta-crownbay/COPYING.MIT b/meta-crownbay/COPYING.MIT
deleted file mode 100644
index fb950dc6..00000000
--- a/meta-crownbay/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-crownbay/README b/meta-crownbay/README
deleted file mode 100644
index 03dafb40..00000000
--- a/meta-crownbay/README
+++ /dev/null
@@ -1,140 +0,0 @@
1This README file contains information on building the meta-crownbay
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The Crown Bay platform consists of the Intel Atom E6xx processor,
6plus the Intel EG20T Platform Controller Hub (Tunnel Creek + Topcliff).
7
8Further information on the platforms supported by this BSP can be
9found here:
10
11 http://www.intel.com/p/en_US/embedded/hwsw/hardware/atom-e6xx/overview
12
13And information on all IntelĀ® embedded platforms can be found here:
14
15 http://www.intel.com/p/en_US/embedded/hwsw/hardware
16
17
18Yocto Project Compatible
19========================
20
21This BSP is compatible with the Yocto Project as per the requirements
22listed here:
23
24 https://www.yoctoproject.org/webform/yocto-project-compatible-registration
25
26
27Dependencies
28============
29
30This layer depends on:
31
32 URI: git://git.openembedded.org/bitbake
33 branch: master
34
35 URI: git://git.openembedded.org/openembedded-core
36 layers: meta
37 branch: master
38
39 URI: git://git.yoctoproject.org/meta-intel
40 layers: intel
41 branch: master
42
43
44Patches
45=======
46
47Please submit any patches against this BSP to the meta-intel mailing list
48(meta-intel@yoctoproject.org) and cc: the maintainer:
49
50Maintainer: Saul Wold <sgw@linux.intel.com>
51
52Please see the meta-intel/MAINTAINERS file for more details.
53
54
55Table of Contents
56=================
57
58 I. Building the meta-crownbay BSP layer
59 II. Booting the images in /binary
60
61
62I. Building the meta-crownbay BSP layer
63=======================================
64
65In order to build an image with BSP support for a given release, you
66need to download the corresponding BSP tarball from the 'Board Support
67Package (BSP) Downloads' page of the Yocto Project website.
68
69Having done that, and assuming you extracted the BSP tarball contents
70at the top-level of your yocto build tree, you can build a crownbay
71image by adding the location of the meta-crownbay layer to
72bblayers.conf, along with the meta-intel layer itself (to access
73common metadata shared between BSPs) e.g.:
74
75 yocto/meta-intel \
76 yocto/meta-intel/meta-crownbay \
77
78The meta-crownbay layer contains support for the crownbay-noemgd machine
79configuration. The previously supported crownbay machine with the
80proprietary EMGD graphics driver has been retired. The 'crownbay-noemgd'
81machine configuration uses the open source 'vesa' kernel driver.
82
83To enable the layer add the following to the local.conf file:
84
85 MACHINE ?= "crownbay-noemgd"
86
87You should then be able to build a crownbay image as such:
88
89 $ source oe-init-build-env
90 $ bitbake core-image-sato
91
92At the end of a successful build, you should have a live image that
93you can boot from a USB flash drive (see instructions on how to do
94that below, in the section 'Booting the images from /binary').
95
96As an alternative to downloading the BSP tarball, you can also work
97directly from the meta-intel git repository. For each BSP in the
98'meta-intel' repository, there are multiple branches, one
99corresponding to each major release starting with 'laverne' (0.90), in
100addition to the latest code which tracks the current master (note that
101not all BSPs are present in every release). Instead of extracting
102a BSP tarball at the top level of your yocto build tree, you can
103equivalently check out the appropriate branch from the meta-intel
104repository at the same location.
105
106
107II. Booting the images in /binary
108=================================
109
110This BSP contains bootable live images, which can be used to directly
111boot Yocto off of a USB flash drive.
112
113Under Linux, insert a USB flash drive. Assuming the USB flash drive
114takes device /dev/sdf, use dd to copy the live image to it. For
115example:
116
117# dd if=core-image-sato-crownbay-noemgd.hddimg of=/dev/sdf
118# sync
119# eject /dev/sdf
120
121This should give you a bootable USB flash device. Insert the device
122into a bootable USB socket on the target, and power on. This should
123result in a system booted to the Sato graphical desktop.
124
125If you want a terminal, use the arrows at the top of the UI to move to
126different pages of available applications, one of which is named
127'Terminal'. Clicking that should give you a root terminal.
128
129If you want to ssh into the system, you can use the root terminal to
130ifconfig the IP address and use that to ssh in. The root password is
131empty, so to log in type 'root' for the user name and hit 'Enter' at
132the Password prompt: and you should be in.
133
134----
135
136If you find you're getting corrupt images on the USB (it doesn't show
137the syslinux boot: prompt, or the boot: prompt contains strange
138characters), try doing this first:
139
140# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-crownbay/README.sources b/meta-crownbay/README.sources
deleted file mode 100644
index 0d4d849a..00000000
--- a/meta-crownbay/README.sources
+++ /dev/null
@@ -1,17 +0,0 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://downloads.yoctoproject.org/releases/yocto/yocto-1.3/poky-danny-8.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-crownbay/binary/.gitignore b/meta-crownbay/binary/.gitignore
deleted file mode 100644
index e69de29b..00000000
--- a/meta-crownbay/binary/.gitignore
+++ /dev/null
diff --git a/meta-crownbay/conf/layer.conf b/meta-crownbay/conf/layer.conf
deleted file mode 100644
index e6cc2a02..00000000
--- a/meta-crownbay/conf/layer.conf
+++ /dev/null
@@ -1,12 +0,0 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "crownbay"
9BBFILE_PATTERN_crownbay := "^${LAYERDIR}/"
10BBFILE_PRIORITY_crownbay = "6"
11
12LAYERDEPENDS_crownbay = "intel"
diff --git a/meta-crownbay/conf/machine/crownbay-noemgd.conf b/meta-crownbay/conf/machine/crownbay-noemgd.conf
deleted file mode 100644
index 9f0aa300..00000000
--- a/meta-crownbay/conf/machine/crownbay-noemgd.conf
+++ /dev/null
@@ -1,22 +0,0 @@
1#@TYPE: Machine
2#@NAME: crownbay-noemgd
3
4#@WEBTITLE: Intel Atom E6xx Processor With Intel EG20T Controller Hub Development Kit (Crown Bay) With Open Source VESA Graphics
5
6#@DESCRIPTION: Machine configuration for Crown Bay systems, without Intel-proprietary graphics bits
7# i.e. E660 + EG20T
8
9PREFERRED_VERSION_linux-yocto ?= "3.19%"
10
11require conf/machine/include/meta-intel.inc
12require conf/machine/include/intel-core2-32-common.inc
13require conf/machine/include/intel-common-pkgarch.inc
14
15MACHINE_FEATURES += "intel-ucode"
16
17XSERVER ?= "${XSERVER_X86_BASE} \
18 ${XSERVER_X86_EXT} \
19 ${XSERVER_X86_VESA} \
20 "
21
22APPEND += "video=vesafb vga=0x318"
diff --git a/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig b/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-crownbay/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-crownbay/recipes-bsp/formfactor/formfactor_0.0.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-crownbay/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-crownbay/recipes-kernel/kmod/kmod_git.bbappend b/meta-crownbay/recipes-kernel/kmod/kmod_git.bbappend
deleted file mode 100644
index 56d8fcb0..00000000
--- a/meta-crownbay/recipes-kernel/kmod/kmod_git.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
1do_install_append () {
2 echo "blacklist gma500_gfx" > ${D}${sysconfdir}/modprobe.d/prohibit_gma500_gfx.conf
3}