summaryrefslogtreecommitdiffstats
path: root/meta-crownbay
diff options
context:
space:
mode:
Diffstat (limited to 'meta-crownbay')
-rw-r--r--meta-crownbay/README10
-rw-r--r--meta-crownbay/conf/machine/crownbay.conf2
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend4
3 files changed, 8 insertions, 8 deletions
diff --git a/meta-crownbay/README b/meta-crownbay/README
index f236d8f4..4b539b60 100644
--- a/meta-crownbay/README
+++ b/meta-crownbay/README
@@ -6,7 +6,7 @@ The Crown Bay platform consists of the Intel Atom E6xx processor,
6plus the Intel EG20T Platform Controller Hub (Tunnel Creek + Topcliff). 6plus the Intel EG20T Platform Controller Hub (Tunnel Creek + Topcliff).
7 7
8It also supports the E6xx embedded on-chip graphics via the Intel 8It also supports the E6xx embedded on-chip graphics via the Intel
9Embedded Media and Graphics Driver (EMGD) 1.14 Driver. 9Embedded Media and Graphics Driver (EMGD) 1.16 Driver.
10 10
11Further information on the platforms supported by this BSP can be 11Further information on the platforms supported by this BSP can be
12found here: 12found here:
@@ -81,7 +81,7 @@ common metadata shared between BSPs) e.g.:
81The meta-crownbay layer contains support for two different machine 81The meta-crownbay layer contains support for two different machine
82configurations. These configurations are identical except for the fact 82configurations. These configurations are identical except for the fact
83that the one prefixed with 'crownbay' makes use of the 83that the one prefixed with 'crownbay' makes use of the
84Intel-proprietary EMGD 1.14 graphics driver, while the one prefixed 84Intel-proprietary EMGD 1.16 graphics driver, while the one prefixed
85with 'crownbay-noemgd' does not. 85with 'crownbay-noemgd' does not.
86 86
87If you want to enable the layer that supports EMGD graphics add the 87If you want to enable the layer that supports EMGD graphics add the
@@ -91,10 +91,10 @@ following to the local.conf file:
91 91
92The 'crownbay' machine includes the emgd-driver-bin package, which has 92The 'crownbay' machine includes the emgd-driver-bin package, which has
93a proprietary license that must be whitelisted by adding the string 93a proprietary license that must be whitelisted by adding the string
94"license_emgd-driver-bin_1.14" to the LICENSE_FLAGS_WHITELIST variable 94"license_emgd-driver-bin_1.16" to the LICENSE_FLAGS_WHITELIST variable
95in your local.conf. For example: 95in your local.conf. For example:
96 96
97 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.14" 97 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.16"
98 98
99If you want to enable the layer that does not support EMGD graphics 99If you want to enable the layer that does not support EMGD graphics
100add the following to the local.conf file: 100add the following to the local.conf file:
@@ -116,7 +116,7 @@ added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
116 116
117For example: 117For example:
118 118
119 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.14 commercial" 119 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.16 commercial"
120 120
121The reason this is needed is to prevent the image from including 121The reason this is needed is to prevent the image from including
122anything that might violate the license terms of the packages used to 122anything that might violate the license terms of the packages used to
diff --git a/meta-crownbay/conf/machine/crownbay.conf b/meta-crownbay/conf/machine/crownbay.conf
index 7324c61f..e714a948 100644
--- a/meta-crownbay/conf/machine/crownbay.conf
+++ b/meta-crownbay/conf/machine/crownbay.conf
@@ -22,7 +22,7 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
22PREFERRED_VERSION_xserver-xorg ?= "1.9.3" 22PREFERRED_VERSION_xserver-xorg ?= "1.9.3"
23PREFERRED_VERSION_mesa-dri ?= "8.0.4" 23PREFERRED_VERSION_mesa-dri ?= "8.0.4"
24PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0" 24PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0"
25PREFERRED_VERSION_emgd-driver-bin ?= "1.14" 25PREFERRED_VERSION_emgd-driver-bin ?= "1.16"
26 26
27APPEND += "video=vesafb vga=0x318 vmalloc=256MB" 27APPEND += "video=vesafb vga=0x318 vmalloc=256MB"
28 28
diff --git a/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 01ffb4d3..0f12dea4 100644
--- a/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3COMPATIBLE_MACHINE_crownbay = "crownbay" 3COMPATIBLE_MACHINE_crownbay = "crownbay"
4KMACHINE_crownbay = "crownbay" 4KMACHINE_crownbay = "crownbay"
5KBRANCH_crownbay = "standard/crownbay" 5KBRANCH_crownbay = "standard/crownbay"
6KERNEL_FEATURES_crownbay_append = " features/drm-emgd cfg/vesafb" 6KERNEL_FEATURES_crownbay_append = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb"
7 7
8COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd" 8COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
9KMACHINE_crownbay-noemgd = "crownbay" 9KMACHINE_crownbay-noemgd = "crownbay"
@@ -17,5 +17,5 @@ SRCREV_emgd_pn-linux-yocto_crownbay ?= "${AUTOREV}"
17SRCREV_machine_pn-linux-yocto_crownbay-noemgd ?= "${AUTOREV}" 17SRCREV_machine_pn-linux-yocto_crownbay-noemgd ?= "${AUTOREV}"
18SRCREV_meta_pn-linux-yocto_crownbay-noemgd ?= "${AUTOREV}" 18SRCREV_meta_pn-linux-yocto_crownbay-noemgd ?= "${AUTOREV}"
19 19
20SRC_URI_crownbay = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.14;name=machine,meta,emgd" 20SRC_URI_crownbay = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"
21SRC_URI_crownbay-noemgd = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA};name=machine,meta" 21SRC_URI_crownbay-noemgd = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA};name=machine,meta"