diff options
Diffstat (limited to 'meta-crownbay')
17 files changed, 507 insertions, 0 deletions
diff --git a/meta-crownbay/COPYING.MIT b/meta-crownbay/COPYING.MIT new file mode 100644 index 00000000..fb950dc6 --- /dev/null +++ b/meta-crownbay/COPYING.MIT | |||
@@ -0,0 +1,17 @@ | |||
1 | Permission is hereby granted, free of charge, to any person obtaining a copy | ||
2 | of this software and associated documentation files (the "Software"), to deal | ||
3 | in the Software without restriction, including without limitation the rights | ||
4 | to use, copy, modify, merge, publish, distribute, sublicense, and/or sell | ||
5 | copies of the Software, and to permit persons to whom the Software is | ||
6 | furnished to do so, subject to the following conditions: | ||
7 | |||
8 | The above copyright notice and this permission notice shall be included in | ||
9 | all copies or substantial portions of the Software. | ||
10 | |||
11 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
12 | IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
13 | FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
14 | AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
15 | LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
16 | OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN | ||
17 | THE SOFTWARE. | ||
diff --git a/meta-crownbay/README b/meta-crownbay/README new file mode 100644 index 00000000..f0a710b8 --- /dev/null +++ b/meta-crownbay/README | |||
@@ -0,0 +1,198 @@ | |||
1 | This README file contains information on building the meta-crownbay | ||
2 | BSP layer, and booting the images contained in the /binary directory. | ||
3 | Please see the corresponding sections below for details. | ||
4 | |||
5 | |||
6 | Table of Contents | ||
7 | ================= | ||
8 | |||
9 | I. Building the meta-crownbay BSP layer | ||
10 | II. Special notes for building the meta-crownbay BSP layer | ||
11 | III. Booting the images in /binary | ||
12 | |||
13 | |||
14 | I. Building the meta-crownbay BSP layer | ||
15 | ======================================= | ||
16 | |||
17 | For each BSP in the 'meta-intel' repository, there are multiple | ||
18 | branches, one corresponding to each major release starting with | ||
19 | 'laverne' (0.90), in addition to the latest code which tracks the | ||
20 | current master. | ||
21 | |||
22 | In order to build an image with BSP support for a given release, you | ||
23 | need to check out the 'meta-intel' branch corresponding to the release | ||
24 | you're building against e.g. to build for laverne (0.90), check out | ||
25 | the 'laverne' branch of both poky and 'meta-intel'. | ||
26 | |||
27 | Having done that, and assuming you cloned the 'meta-intel' repository | ||
28 | at the top-level of your yocto build tree, you can build a crownbay | ||
29 | image by adding the location of the meta-crownbay layer to | ||
30 | bblayers.conf e.g.: | ||
31 | |||
32 | yocto/meta-intel/meta-crownbay \ | ||
33 | |||
34 | To enable the crownbay layer, add the crownbay MACHINE to local.conf: | ||
35 | |||
36 | MACHINE ?= "crownbay" | ||
37 | |||
38 | You should then be able to build a crownbay image as such: | ||
39 | |||
40 | $ source poky-init-build-env | ||
41 | $ bitbake poky-image-sato-live | ||
42 | |||
43 | At the end of a successful build, you should have a live image that | ||
44 | you can boot from a USB flash drive (see instructions on how to do | ||
45 | that below, in the section 'Booting the images from /binary'). | ||
46 | |||
47 | |||
48 | II. Special notes for building the meta-crownbay BSP layer | ||
49 | ========================================================== | ||
50 | |||
51 | The meta-crownbay layer makes use of the proprietary Intel EMGD | ||
52 | userspace drivers, which at this point in time require that the user | ||
53 | accept the Intel license by manually extracting the binaries and | ||
54 | copying them to the proper location in the meta-crownbay layer. | ||
55 | |||
56 | There currently isn't an automated way to do this, thus the manual | ||
57 | step. When Yocto supports a click-through installation mechanism, the | ||
58 | binary files will be packaged as part of the recipe, and this step | ||
59 | will be unnecessary. | ||
60 | |||
61 | These steps require that you run a graphical application in Windows. | ||
62 | Windows 7 was used for these instructions, but it shouldn't matter | ||
63 | which version of Windows you use. | ||
64 | |||
65 | The first step of the process is to download the EMGD 1.5 Gold Driver. | ||
66 | Here is the current link to the URL which it can be downloaded from: | ||
67 | |||
68 | http://edc.intel.com/Software/Downloads/EMGD/ | ||
69 | |||
70 | In the Download Now tab, select: | ||
71 | |||
72 | Intel® architecture-based product: Intel Atom Processor E6XX Series | ||
73 | Operating System: MeeGo 1.0 IVI Linux (kernel 2.6.33.3, X.server 1.8.0) | ||
74 | |||
75 | That will give you a large zip file: | ||
76 | |||
77 | IEMGD_1_5_GOLD_ALL_1742.zip | ||
78 | |||
79 | Extract the files in the zip file, which will in turn give you a large | ||
80 | .exe file: | ||
81 | |||
82 | IEMGD_1_5_GOLD_ALL_1742.exe | ||
83 | |||
84 | Run IEMGD_1_5_GOLD_ALL_1742.exe to install, accept licenses, etc. | ||
85 | |||
86 | If it says to install watcom, follow the instructions to do that. | ||
87 | |||
88 | When the installation completes, an application named "emgd-ced" will | ||
89 | be present in the install directory. Double-click to run it. | ||
90 | |||
91 | Select the menu item: New Configuration | ||
92 | |||
93 | In the tabbed page, make the following selections and/or enter the | ||
94 | specified data: | ||
95 | |||
96 | Configuration File Name: myconfig | ||
97 | Platform Chipset: Intel Atom Processor E6xx | ||
98 | Port Devices: LVDS, sDVO | ||
99 | |||
100 | Hit the 'Next' button. | ||
101 | |||
102 | On the next tabbed page, make the following selections and/or enter | ||
103 | the specified data: | ||
104 | |||
105 | Readable Port Name: portname0 | ||
106 | Encoder Configuration: Select sDVO Device: Internal LVDS | ||
107 | |||
108 | Hit the 'Finish' button. | ||
109 | |||
110 | Select the menu item: New Package | ||
111 | |||
112 | In the tabbed page, make the following selections and/or enter the | ||
113 | specified data: | ||
114 | |||
115 | Package File Name: mypackage | ||
116 | Configurations: selec myconfig.cnfg | ||
117 | Target OS: Linux operating System | ||
118 | |||
119 | Hit the 'Finish' button. | ||
120 | |||
121 | Select the menu item: Generate Installation | ||
122 | |||
123 | This will create the EMGD installation package: | ||
124 | |||
125 | Generating EMGD installation... | ||
126 | |||
127 | The installation package should now be under the 'workspace' | ||
128 | subdirectory of the directory you installed to: | ||
129 | |||
130 | workspace/installation/mypackage.pkg_installation/IEMGD_HEAD_Linux/IEMGD_HEAD_Linux.tgz | ||
131 | |||
132 | This is the file you are interested in. Copy it to your Poky build | ||
133 | system, and uncompress/untar it: | ||
134 | |||
135 | $ tar cvfz IEMGD_HEAD_Linux.tgz | ||
136 | |||
137 | Finally, copy Xorg-xserver binaries in the Meego1.0 driver directory | ||
138 | to the xserver-xf86-emgd-bin directory in the meta-crownbay layer: | ||
139 | |||
140 | $ cp IEMGD_HEAD_Linux/MeeGo1.0/driver/Xorg-xserver-1.7.99/* meta-crownbay/recipes/xorg-xserver/xserver-xf86-emgd-bin | ||
141 | |||
142 | You also need to copy the IEMGD License.txt file to the same directory: | ||
143 | |||
144 | $ cp IEMGD_HEAD_Linux/License/License.txt meta-crownbay/recipes/xorg-xserver/xserver-xf86-emgd-bin | ||
145 | |||
146 | At this point, you should be able to build meta-crownbay images as usual. | ||
147 | |||
148 | ---- | ||
149 | |||
150 | For reference, the EMGD Driver documentation is also available at the | ||
151 | above link (it's also part of the installation). | ||
152 | |||
153 | The specific text of the document is: | ||
154 | |||
155 | User Guide: Intel® Embedded Media and Graphics Driver, EFI Video | ||
156 | Driver, EPOG, and Video BIOS v1.5 for Windows* XP and Linux* Provides | ||
157 | installation requirements/procedures & describes the vbios/firmware, | ||
158 | configuration options, & functionality of Intel® EMGD under Windows* & | ||
159 | Linux*. Refer to guide for details. | ||
160 | |||
161 | File Type/Size: PDF 3,340KB | ||
162 | Version: 008 : October 2010 | ||
163 | |||
164 | |||
165 | II. Booting the images in /binary | ||
166 | ================================= | ||
167 | |||
168 | This BSP contains bootable live images, which can be used to directly | ||
169 | boot Yocto off of a USB flash drive. | ||
170 | |||
171 | Under Linux, insert a USB flash drive. Assuming the USB flash drive | ||
172 | takes device /dev/sdf, use dd to copy the live image to it. For | ||
173 | example: | ||
174 | |||
175 | # dd if=poky-image-sato-live-crownbay-20101207053738.hddimg of=/dev/sdf | ||
176 | # sync | ||
177 | # eject /dev/sdf | ||
178 | |||
179 | This should give you a bootable USB flash device. Insert the device | ||
180 | into a bootable USB socket on the target, and power on. This should | ||
181 | result in a system booted to the Sato graphical desktop. | ||
182 | |||
183 | If you want a terminal, use the arrows at the top of the UI to move to | ||
184 | different pages of available applications, one of which is named | ||
185 | 'Terminal'. Clicking that should give you a root terminal. | ||
186 | |||
187 | If you want to ssh into the system, you can use the root terminal to | ||
188 | ifconfig the IP address and use that to ssh in. The root password is | ||
189 | empty, so to log in type 'root' for the user name and hit 'Enter' at | ||
190 | the Password prompt: and you should be in. | ||
191 | |||
192 | ---- | ||
193 | |||
194 | If you find you're getting corrupt images on the USB (it doesn't show | ||
195 | the syslinux boot: prompt, or the boot: prompt contains strange | ||
196 | characters), try doing this first: | ||
197 | |||
198 | # dd if=/dev/zero of=/dev/sdf bs=1M count=512 | ||
diff --git a/meta-crownbay/binary/.gitignore b/meta-crownbay/binary/.gitignore new file mode 100644 index 00000000..e69de29b --- /dev/null +++ b/meta-crownbay/binary/.gitignore | |||
diff --git a/meta-crownbay/conf/layer.conf b/meta-crownbay/conf/layer.conf new file mode 100644 index 00000000..52581e1c --- /dev/null +++ b/meta-crownbay/conf/layer.conf | |||
@@ -0,0 +1,10 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH := "${BBPATH}:${LAYERDIR}" | ||
3 | |||
4 | # We have a recipes directory, add to BBFILES | ||
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes-*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "crownbay" | ||
9 | BBFILE_PATTERN_crownbay := "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_crownbay = "6" | ||
diff --git a/meta-crownbay/conf/machine/crownbay.conf b/meta-crownbay/conf/machine/crownbay.conf new file mode 100644 index 00000000..1fc27b78 --- /dev/null +++ b/meta-crownbay/conf/machine/crownbay.conf | |||
@@ -0,0 +1,46 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: crownbay | ||
3 | |||
4 | #@DESCRIPTION: Machine configuration for Crown Bay systems | ||
5 | # i.e. E660 + EG20T | ||
6 | |||
7 | TARGET_ARCH = "i586" | ||
8 | PACKAGE_EXTRA_ARCHS = "x86 atom" | ||
9 | |||
10 | include conf/machine/include/tune-atom.inc | ||
11 | |||
12 | BASE_PACKAGE_ARCH="atom" | ||
13 | |||
14 | MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \ | ||
15 | acpi serial usbgadget" | ||
16 | |||
17 | KERNEL_IMAGETYPE = "bzImage" | ||
18 | |||
19 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-wrs" | ||
20 | PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim" | ||
21 | PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri" | ||
22 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-emgd" | ||
23 | PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-emgd" | ||
24 | XSERVER ?= "xserver-xf86-emgd \ | ||
25 | xserver-xf86-emgd-bin \ | ||
26 | xf86-input-mouse \ | ||
27 | xf86-input-keyboard \ | ||
28 | xf86-input-evdev \ | ||
29 | xf86-input-synaptics \ | ||
30 | xf86-video-vesa" | ||
31 | |||
32 | PREFERRED_VERSION_xserver-xf86-emgd ?= "1.7.99.2" | ||
33 | PREFERRED_VERSION_xserver-xf86-emgd-bin ?= "1.7.99.2" | ||
34 | |||
35 | SERIAL_CONSOLE = "115200 ttyS0" | ||
36 | |||
37 | MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts" | ||
38 | |||
39 | GUI_MACHINE_CLASS = "bigscreen" | ||
40 | |||
41 | IMAGE_ROOTFS_SIZE_ext3 = "2000000" | ||
42 | |||
43 | IMAGE_FSTYPES ?= "ext3 cpio.gz" | ||
44 | |||
45 | GLIBC_ADDONS = "nptl" | ||
46 | GLIBC_EXTRA_OECONF = "--with-tls" | ||
diff --git a/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay/machconfig b/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay/machconfig new file mode 100644 index 00000000..ffce0122 --- /dev/null +++ b/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay/machconfig | |||
@@ -0,0 +1,3 @@ | |||
1 | # Assume a USB mouse and keyboard are connected | ||
2 | HAVE_TOUCHSCREEN=0 | ||
3 | HAVE_KEYBOARD=1 | ||
diff --git a/meta-crownbay/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-crownbay/recipes-bsp/formfactor/formfactor_0.0.bbappend new file mode 100644 index 00000000..4a41d487 --- /dev/null +++ b/meta-crownbay/recipes-bsp/formfactor/formfactor_0.0.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS := "${THISDIR}/${PN}" | ||
2 | |||
3 | PRINC = "1" | ||
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/xorg.conf b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/xorg.conf new file mode 100644 index 00000000..f78a538a --- /dev/null +++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/xorg.conf | |||
@@ -0,0 +1,47 @@ | |||
1 | ## | ||
2 | ## X Config options generated from CED | ||
3 | ## x11 conf skeleton | ||
4 | ## DriverVer= | ||
5 | ## | ||
6 | |||
7 | Section "Screen" | ||
8 | Identifier "Screen0" | ||
9 | Device "IntelEMGD-0" | ||
10 | Monitor "Monitor0" | ||
11 | SubSection "Display" | ||
12 | EndSubSection | ||
13 | EndSection | ||
14 | |||
15 | # Primary (First/only) display | ||
16 | Section "Device" | ||
17 | Identifier "IntelEMGD-0" | ||
18 | Driver "emgd" | ||
19 | VendorName "Intel(R) DEG" | ||
20 | BoardName "Embedded Graphics" | ||
21 | BusID "0:2:0" | ||
22 | Screen 0 | ||
23 | Option "PcfVersion" "1792" | ||
24 | Option "ConfigId" "1" | ||
25 | Option "ALL/1/name" "e6xx" | ||
26 | Option "ALL/1/General/PortOrder" "40000" | ||
27 | Option "ALL/1/General/DisplayConfig" "1" | ||
28 | Option "ALL/1/General/DisplayDetect" "1" | ||
29 | Option "ALL/1/Port/4/General/name" "lvds" | ||
30 | Option "ALL/1/Port/4/General/EdidAvail" "3" | ||
31 | Option "ALL/1/Port/4/General/EdidNotAvail" "1" | ||
32 | Option "ALL/1/Port/4/General/Rotation" "0" | ||
33 | Option "ALL/1/Port/4/General/Edid" "1" | ||
34 | EndSection | ||
35 | |||
36 | Section "ServerLayout" | ||
37 | Identifier "Default Layout" | ||
38 | Screen 0 "Screen0" 0 0 | ||
39 | # InputDevice "Mouse0" "CorePointer" | ||
40 | # InputDevice "Keyboard0" "CoreKeyboard" | ||
41 | # InputDevice "DevInputMice" "SendCoreEvents" | ||
42 | EndSection | ||
43 | |||
44 | Section "ServerFlags" | ||
45 | Option "DontZap" "0" | ||
46 | Option "AutoAddDevices" "False" | ||
47 | EndSection | ||
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend new file mode 100644 index 00000000..4b8d0e65 --- /dev/null +++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}" | ||
2 | FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:" | ||
3 | |||
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin/.gitignore b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin/.gitignore new file mode 100644 index 00000000..e69de29b --- /dev/null +++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin/.gitignore | |||
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb new file mode 100644 index 00000000..95068722 --- /dev/null +++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb | |||
@@ -0,0 +1,90 @@ | |||
1 | SUMMARY = "EMGD 1.5 xserver binaries" | ||
2 | DESCRIPTION = "EMGD 1.5 includes some userspace binaries that use non-free licensing. Intel Open Source Technology Center unfortunately has no power to change that, but tries to make their use as painless as possible. Please see the README.before.building in meta-crownbay/recipes/xorg-xerver for instructions on the (simple) manual steps necessary to make the necessary binaries available to this recipe. Please do that before building an image." | ||
3 | |||
4 | LICENSE = "Intel-binary-only" | ||
5 | LIC_FILES_CHKSUM = "file://${WORKDIR}/License.txt;md5=95c4d031b83ab803f3f2401b04ecfbcd" | ||
6 | PR = "r0" | ||
7 | |||
8 | FILESPATH = "${FILE_DIRNAME}/xserver-xf86-emgd-bin" | ||
9 | |||
10 | FILES_${PN} = "${libdir}/*.so.* ${libdir}/dri ${libdir}/xorg/modules/drivers" | ||
11 | |||
12 | SRC_URI = "file://emgd_dri.so \ | ||
13 | file://emgd_drv.so \ | ||
14 | file://emgd_drv_video.so \ | ||
15 | file://libEGL.so \ | ||
16 | file://libGLES_CM.so \ | ||
17 | file://libGLESv2.so \ | ||
18 | file://libIMGegl.so \ | ||
19 | file://libOpenVG.so \ | ||
20 | file://libOpenVGU.so \ | ||
21 | file://libPVROGL.so \ | ||
22 | file://libPVRScopeServices.so \ | ||
23 | file://libXegd_escape.so.2.0.0 \ | ||
24 | file://libglslcompiler.so \ | ||
25 | file://libpvr2d.so \ | ||
26 | file://libpvrPVR2D_DRIWSEGL.so \ | ||
27 | file://libsrv_init.so \ | ||
28 | file://libsrv_um.so \ | ||
29 | file://libva-x11.so.1.0.1 \ | ||
30 | file://libva.so.1.0.1 \ | ||
31 | file://License.txt" | ||
32 | |||
33 | S = "${WORKDIR}" | ||
34 | |||
35 | do_install () { | ||
36 | install -d -m 0755 ${D}/${libdir}/dri ${D}/${libdir}/xorg/modules/drivers | ||
37 | |||
38 | install -m 0755 ${S}/emgd_dri.so ${D}${libdir}/dri/emgd_dri.so.1.1.15.3082 | ||
39 | ln -sf emgd_dri.so.1.1.15.3082 ${D}${libdir}/dri/emgd_dri.so | ||
40 | |||
41 | install -m 0755 ${S}/emgd_drv.so ${D}${libdir}/xorg/modules/drivers/emgd_drv.so | ||
42 | install -m 0755 ${S}/emgd_drv_video.so ${D}${libdir}/xorg/modules/drivers/emgd_drv_video.so | ||
43 | |||
44 | install -m 0755 ${S}/libEGL.so ${D}${libdir}/libEGL.so.1.1.15.3082 | ||
45 | ln -sf libEGL.so.1.1.15.3082 ${D}${libdir}/libEGL.so | ||
46 | |||
47 | install -m 0755 ${S}/libGLES_CM.so ${D}${libdir}/libGLES_CM.so.1.1.15.3082 | ||
48 | ln -sf libGLES_CM.so.1.1.15.3082 ${D}${libdir}/libGLES_CM.so | ||
49 | |||
50 | install -m 0755 ${S}/libGLESv2.so ${D}${libdir}/libGLESv2.so.1.1.15.3082 | ||
51 | ln -sf libGLESv2.so.1.1.15.3082 ${D}${libdir}/libGLESv2.so | ||
52 | |||
53 | install -m 0755 ${S}/libIMGegl.so ${D}${libdir}/libIMGegl.so.1.1.15.3082 | ||
54 | ln -sf libIMGegl.so.1.1.15.3082 ${D}${libdir}/libIMGegl.so | ||
55 | |||
56 | install -m 0755 ${S}/libOpenVG.so ${D}${libdir}/libOpenVG.so.1.1.15.3082 | ||
57 | ln -sf libOpenVG.so.1.1.15.3082 ${D}${libdir}/libOpenVG.so | ||
58 | |||
59 | install -m 0755 ${S}/libOpenVGU.so ${D}${libdir}/libOpenVGU.so.1.1.15.3082 | ||
60 | ln -sf libOpenVG.so.1.1.15.3082 ${D}${libdir}/libOpenVGU.so | ||
61 | |||
62 | install -m 0755 ${S}/libPVROGL.so ${D}${libdir}/libPVROGL.so.1.1.15.3082 | ||
63 | ln -sf libPVROGL.so.1.1.15.3082 ${D}${libdir}/libPVROGL.so | ||
64 | |||
65 | install -m 0755 ${S}/libPVRScopeServices.so ${D}${libdir}/libPVRScopeServices.so.1.1.15.3082 | ||
66 | ln -sf libPVRScopeServices.so.1.1.15.3082 ${D}${libdir}/libPVRScopeServices.so | ||
67 | |||
68 | install -m 0755 ${S}/libXegd_escape.so.2.0.0 ${D}${libdir}/libXegd_escape.so.2.0.0 | ||
69 | |||
70 | install -m 0755 ${S}/libglslcompiler.so ${D}${libdir}/libglslcompiler.so.1.1.15.3082 | ||
71 | ln -sf libglslcompiler.so.1.1.15.3082 ${D}${libdir}/libglslcompiler.so | ||
72 | |||
73 | install -m 0755 ${S}/libpvr2d.so ${D}${libdir}/libpvr2d.so.1.1.15.3082 | ||
74 | ln -sf libpvr2d.so.1.1.15.3082 ${D}${libdir}/libpvr2d.so | ||
75 | |||
76 | install -m 0755 ${S}/libpvrPVR2D_DRIWSEGL.so ${D}${libdir}/libpvrPVR2D_DRIWSEGL.so.1.1.15.3082 | ||
77 | ln -sf libpvrPVR2D_DRIWSEGL.so.1.1.15.3082 ${D}${libdir}/libpvrPVR2D_DRIWSEGL.so | ||
78 | |||
79 | install -m 0755 ${S}/libsrv_init.so ${D}${libdir}/libsrv_init.so.1.1.15.3082 | ||
80 | ln -sf libsrv_init.so.1.1.15.3082 ${D}${libdir}/libsrv_init.so | ||
81 | |||
82 | install -m 0755 ${S}/libsrv_um.so ${D}${libdir}/libsrv_um.so.1.1.15.3082 | ||
83 | ln -sf libsrv_um.so.1.1.15.3082 ${D}${libdir}/libsrv_um.so | ||
84 | |||
85 | install -m 0755 ${S}/libva-x11.so.1.0.1 ${D}${libdir}/libva-x11.so.1.0.1 | ||
86 | |||
87 | install -m 0755 ${S}/libva.so.1.0.1 ${D}${libdir}/libva.so.1.0.1 | ||
88 | } | ||
89 | |||
90 | LEAD_SONAME = "libEGL.so" | ||
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/crosscompile.patch b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/crosscompile.patch new file mode 100644 index 00000000..2341e40b --- /dev/null +++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/crosscompile.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | Index: xorg-server-1.7.99.2/configure.ac | ||
2 | =================================================================== | ||
3 | --- xorg-server-1.7.99.2.orig/configure.ac 2010-01-29 16:38:49.000000000 +0000 | ||
4 | +++ xorg-server-1.7.99.2/configure.ac 2010-01-29 16:42:39.000000000 +0000 | ||
5 | @@ -503,14 +503,10 @@ | ||
6 | |||
7 | dnl Uses --default-font-path if set, otherwise checks for /etc/X11/fontpath.d, | ||
8 | dnl otherwise uses standard subdirectories of FONTROOTDIR | ||
9 | -AC_CHECK_FILE([${sysconfdir}/X11/fontpath.d], | ||
10 | - [DEFAULT_FONT_PATH='catalogue:${sysconfdir}/X11/fontpath.d'], | ||
11 | - [ | ||
12 | DEFAULT_FONT_PATH="${FONTMISCDIR}/,${FONTTTFDIR}/,${FONTOTFDIR}/,${FONTTYPE1DIR}/,${FONT100DPIDIR}/,${FONT75DPIDIR}/" | ||
13 | case $host_os in | ||
14 | darwin*) DEFAULT_FONT_PATH="${DEFAULT_FONT_PATH},/Library/Fonts,/System/Library/Fonts" ;; | ||
15 | esac | ||
16 | - ]) | ||
17 | AC_ARG_WITH(default-font-path, AS_HELP_STRING([--with-default-font-path=PATH], [Comma separated list of font dirs]), | ||
18 | [ FONTPATH="$withval" ], | ||
19 | [ FONTPATH="${DEFAULT_FONT_PATH}" ]) | ||
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/fix_open_max_preprocessor_error.patch b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/fix_open_max_preprocessor_error.patch new file mode 100644 index 00000000..565832ee --- /dev/null +++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/fix_open_max_preprocessor_error.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: git/os/osdep.h | ||
2 | =================================================================== | ||
3 | --- git.orig/os/osdep.h 2008-10-07 18:38:21.000000000 +0100 | ||
4 | +++ git/os/osdep.h 2008-10-07 18:39:36.000000000 +0100 | ||
5 | @@ -92,7 +92,7 @@ | ||
6 | * like sysconf(_SC_OPEN_MAX) is not supported. | ||
7 | */ | ||
8 | |||
9 | -#if OPEN_MAX <= 256 | ||
10 | +#if 0 | ||
11 | #define MAXSOCKS (OPEN_MAX - 1) | ||
12 | #else | ||
13 | #define MAXSOCKS 256 | ||
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/macro_tweak.patch b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/macro_tweak.patch new file mode 100644 index 00000000..6998adff --- /dev/null +++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/macro_tweak.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | Index: xorg-server-1.5.0/xorg-server.m4 | ||
2 | =================================================================== | ||
3 | --- xorg-server-1.5.0.orig/xorg-server.m4 2007-05-29 20:36:51.000000000 +0100 | ||
4 | +++ xorg-server-1.5.0/xorg-server.m4 2008-11-04 23:56:55.000000000 +0000 | ||
5 | @@ -28,9 +28,12 @@ | ||
6 | # Checks for the $1 define in xorg-server.h (from the sdk). If it | ||
7 | # is defined, then add $1 to $REQUIRED_MODULES. | ||
8 | |||
9 | +m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR) | ||
10 | + | ||
11 | AC_DEFUN([XORG_DRIVER_CHECK_EXT],[ | ||
12 | + PKG_PROG_PKG_CONFIG | ||
13 | SAVE_CFLAGS="$CFLAGS" | ||
14 | - CFLAGS="$CFLAGS -I`pkg-config --variable=sdkdir xorg-server`" | ||
15 | + CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`pkg-config --variable=sdkdir xorg-server`" | ||
16 | AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ | ||
17 | #include "xorg-server.h" | ||
18 | #if !defined $1 | ||
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/nodolt.patch b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/nodolt.patch new file mode 100644 index 00000000..6b34032a --- /dev/null +++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/nodolt.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | Index: git/configure.ac | ||
2 | =================================================================== | ||
3 | --- git.orig/configure.ac 2009-01-15 20:35:31.000000000 +0000 | ||
4 | +++ git/configure.ac 2009-01-15 20:35:38.000000000 +0000 | ||
5 | @@ -62,7 +62,6 @@ | ||
6 | AC_LIBTOOL_WIN32_DLL | ||
7 | AC_DISABLE_STATIC | ||
8 | AC_PROG_LIBTOOL | ||
9 | -DOLT | ||
10 | AC_PROG_MAKE_SET | ||
11 | PKG_PROG_PKG_CONFIG | ||
12 | AC_PROG_LEX | ||
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd_1.7.99.2.bb b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd_1.7.99.2.bb new file mode 100644 index 00000000..5f22213a --- /dev/null +++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd_1.7.99.2.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | require recipes-graphics/xorg-xserver/xserver-xf86-dri-lite.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=3dd2bbe3563837f80ed8926b06c1c353" | ||
4 | |||
5 | PROTO_DEPS += "xf86driproto dri2proto" | ||
6 | |||
7 | DEPENDS += "font-util" | ||
8 | |||
9 | PE = "1" | ||
10 | PR = "r0" | ||
11 | |||
12 | SRC_URI += "file://nodolt.patch \ | ||
13 | file://crosscompile.patch" | ||
14 | |||
15 | # Misc build failure for master HEAD | ||
16 | SRC_URI += "file://fix_open_max_preprocessor_error.patch" | ||
17 | |||
18 | SRC_URI[md5sum] = "5c8773499a6a8c1ddaedf33577ec9634" | ||
19 | SRC_URI[sha256sum] = "8b30800004c98fc7a8e6ff31a339f28451be5132e774443be22bf226e1791e34" | ||
20 | |||
21 | RDEPENDS_${PN} += "xserver-xf86-emgd-bin mesa-dri" | ||
22 | |||
23 | COMPATIBLE_MACHINE = "crownbay" | ||
24 | |||
25 | EXTRA_OECONF += "--enable-dga --enable-dri --enable-dri2" | ||
diff --git a/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend b/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend new file mode 100644 index 00000000..9709c365 --- /dev/null +++ b/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS := "${THISDIR}/${PN}" | ||
2 | COMPATIBLE_MACHINE_crownbay = "crownbay" | ||
3 | WRMACHINE_crownbay = "crownbay" | ||