summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch11
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb)4
2 files changed, 10 insertions, 5 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
index b0bfa6ee..417e0221 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch
@@ -1,4 +1,4 @@
1From 40be69a2c9460aea40beab8734684050988b9322 Mon Sep 17 00:00:00 2001 1From 2ce2619b544678541e0cc56494e2927086718613 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 26 Mar 2019 14:11:29 +0800 3Date: Tue, 26 Mar 2019 14:11:29 +0800
4Subject: [PATCH] point to correct llvm-tblgen 4Subject: [PATCH] point to correct llvm-tblgen
@@ -10,12 +10,14 @@ git through cmake.
10 10
11Upstream-Status: Inappropriate [OE specific] 11Upstream-Status: Inappropriate [OE specific]
12 12
13Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
14Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
13--- 15---
14 CMakeLists.txt | 4 ++-- 16 CMakeLists.txt | 4 ++--
15 1 file changed, 2 insertions(+), 2 deletions(-) 17 1 file changed, 2 insertions(+), 2 deletions(-)
16 18
17diff --git a/CMakeLists.txt b/CMakeLists.txt 19diff --git a/CMakeLists.txt b/CMakeLists.txt
18index 174133b..be409e5 100644 20index 1371a67..f83ffcc 100644
19--- a/CMakeLists.txt 21--- a/CMakeLists.txt
20+++ b/CMakeLists.txt 22+++ b/CMakeLists.txt
21@@ -53,7 +53,7 @@ endif(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR) 23@@ -53,7 +53,7 @@ endif(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
@@ -27,7 +29,7 @@ index 174133b..be409e5 100644
27 29
28 if (NOT WIN32) 30 if (NOT WIN32)
29 add_subdirectory( linux_linker ) 31 add_subdirectory( linux_linker )
30@@ -102,7 +102,7 @@ endif(NOT USE_PREBUILT_LLVM) 32@@ -138,7 +138,7 @@ endif(NOT USE_PREBUILT_LLVM)
31 set (COMPILE_OPTIONS_TD opencl_clang_options.td) 33 set (COMPILE_OPTIONS_TD opencl_clang_options.td)
32 set (COMPILE_OPTIONS_INC opencl_clang_options.inc) 34 set (COMPILE_OPTIONS_INC opencl_clang_options.inc)
33 35
@@ -36,3 +38,6 @@ index 174133b..be409e5 100644
36 set(LLVM_TARGET_DEFINITIONS ${COMPILE_OPTIONS_TD}) 38 set(LLVM_TARGET_DEFINITIONS ${COMPILE_OPTIONS_TD})
37 if(USE_PREBUILT_LLVM) 39 if(USE_PREBUILT_LLVM)
38 set(TABLEGEN_ADDITIONAL -I ${LLVM_INCLUDE_DIRS}) 40 set(TABLEGEN_ADDITIONAL -I ${LLVM_INCLUDE_DIRS})
41--
422.17.1
43
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb
index c45c36d8..e4209234 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb
@@ -5,11 +5,11 @@ DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
5LICENSE = "NCSA" 5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7 7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=https \ 8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-90;protocol=https \
9 file://point-to-correct-llvm-tblgen.patch \ 9 file://point-to-correct-llvm-tblgen.patch \
10 " 10 "
11 11
12SRCREV = "94af090661d7c953c516c97a25ed053c744a0737" 12SRCREV = "6f8c329bea44321aef1a1716dd206c1f7bed23cf"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15