summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb1
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch27
2 files changed, 28 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
index 207b206e..a7db09ae 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
@@ -13,6 +13,7 @@ SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
13 file://0003-Supply-firmware-at-build-time.patch;patchdir=../ \ 13 file://0003-Supply-firmware-at-build-time.patch;patchdir=../ \
14 file://0004-disable-werror.patch;patchdir=../ \ 14 file://0004-disable-werror.patch;patchdir=../ \
15 file://0005-point-to-correct-location-of-ngraph-headers.patch;patchdir=../ \ 15 file://0005-point-to-correct-location-of-ngraph-headers.patch;patchdir=../ \
16 file://0001-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch;patchdir=../ \
16 file://run-ptest \ 17 file://run-ptest \
17 " 18 "
18SRCREV = "ba6e22b1b5ee4cbefcc30e8d9493cddb0bb3dfdf" 19SRCREV = "ba6e22b1b5ee4cbefcc30e8d9493cddb0bb3dfdf"
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch
new file mode 100644
index 00000000..24feee25
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch
@@ -0,0 +1,27 @@
1From 1cc6ee3a1df0133e2ea7a4442bd05598a89958f6 Mon Sep 17 00:00:00 2001
2From: Chin Huat Ang <chin.huat.ang@intel.com>
3Date: Mon, 30 Sep 2019 13:50:45 +0800
4Subject: [PATCH] Install clDNN plugin to CMAKE_INSTALL_LIBDIR
5
6Upstream-Status: Pending
7Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com>
8---
9 inference-engine/src/cldnn_engine/CMakeLists.txt | 2 ++
10 1 file changed, 2 insertions(+)
11
12diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
13index 211f660..76c8086 100644
14--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
15+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
16@@ -23,6 +23,8 @@ target_include_directories(${TARGET_NAME} PRIVATE
17 ${IE_MAIN_SOURCE_DIR}/src/inference_engine
18 ${IE_MAIN_SOURCE_DIR}/thirdparty/pugixml/src)
19
20+install(TARGETS ${TARGET_NAME} EXPORT ${TARGET_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
21+
22 # copy default global xml file describing the custom kernels and the *.cl files
23
24 add_custom_command(TARGET ${TARGET_NAME} POST_BUILD
25--
262.7.4
27