diff options
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb | 6 | ||||
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb | 18 |
2 files changed, 12 insertions, 12 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb index 700f78c2..1461afe1 100644 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb +++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb | |||
@@ -21,7 +21,7 @@ OECMAKE_SOURCEPATH = "${S}/demos" | |||
21 | 21 | ||
22 | DEPENDS += "openvino-inference-engine opencv gflags" | 22 | DEPENDS += "openvino-inference-engine opencv gflags" |
23 | 23 | ||
24 | RDEPENDS_${PN} += " \ | 24 | RDEPENDS:${PN} += " \ |
25 | python3-decorator \ | 25 | python3-decorator \ |
26 | python3-defusedxml \ | 26 | python3-defusedxml \ |
27 | python3-networkx \ | 27 | python3-networkx \ |
@@ -46,7 +46,7 @@ EXTRA_OECMAKE += " \ | |||
46 | -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \ | 46 | -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \ |
47 | " | 47 | " |
48 | 48 | ||
49 | do_configure_prepend(){ | 49 | do_configure:prepend(){ |
50 | mkdir -p ${WORKDIR}/InferenceEngine/share | 50 | mkdir -p ${WORKDIR}/InferenceEngine/share |
51 | cp ${STAGING_LIBDIR}/cmake/InferenceEngine/* ${WORKDIR}/InferenceEngine/share/ | 51 | cp ${STAGING_LIBDIR}/cmake/InferenceEngine/* ${WORKDIR}/InferenceEngine/share/ |
52 | } | 52 | } |
@@ -63,4 +63,4 @@ do_install(){ | |||
63 | cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools | 63 | cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools |
64 | } | 64 | } |
65 | 65 | ||
66 | FILES_${PN} += "${datadir}/openvino" | 66 | FILES:${PN} += "${datadir}/openvino" |
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb index 19da3e1b..654cac13 100644 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb +++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb | |||
@@ -30,7 +30,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ | |||
30 | file://thirdparty/xbyak/COPYRIGHT;md5=03532861dad9003cc2c17f14fc7a4efa \ | 30 | file://thirdparty/xbyak/COPYRIGHT;md5=03532861dad9003cc2c17f14fc7a4efa \ |
31 | file://inference-engine/thirdparty/clDNN/common/include/OpenCL_CLHPP_License.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \ | 31 | file://inference-engine/thirdparty/clDNN/common/include/OpenCL_CLHPP_License.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \ |
32 | " | 32 | " |
33 | LICENSE_${PN}-vpu-firmware = "ISSL" | 33 | LICENSE:${PN}-vpu-firmware = "ISSL" |
34 | 34 | ||
35 | inherit cmake python3native | 35 | inherit cmake python3native |
36 | 36 | ||
@@ -64,7 +64,7 @@ DEPENDS += "libusb1 \ | |||
64 | " | 64 | " |
65 | 65 | ||
66 | COMPATIBLE_HOST = '(x86_64).*-linux' | 66 | COMPATIBLE_HOST = '(x86_64).*-linux' |
67 | COMPATIBLE_HOST_libc-musl = "null" | 67 | COMPATIBLE_HOST:libc-musl = "null" |
68 | 68 | ||
69 | #Disable opencl temporarily. intel-compute-runtime depends on | 69 | #Disable opencl temporarily. intel-compute-runtime depends on |
70 | #intel-graphics-compiler and vc-intrinsics and these two recipes fail to | 70 | #intel-graphics-compiler and vc-intrinsics and these two recipes fail to |
@@ -76,7 +76,7 @@ PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} | |||
76 | PACKAGECONFIG[vpu] = "-DENABLE_VPU=ON -DVPU_FIRMWARE_USB-MA2X8X_FILE=../mvnc/usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA2X8X_FILE=../mvnc/pcie-ma2x8x.mvcmd,-DENABLE_VPU=OFF,,${PN}-vpu-firmware" | 76 | PACKAGECONFIG[vpu] = "-DENABLE_VPU=ON -DVPU_FIRMWARE_USB-MA2X8X_FILE=../mvnc/usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA2X8X_FILE=../mvnc/pcie-ma2x8x.mvcmd,-DENABLE_VPU=OFF,,${PN}-vpu-firmware" |
77 | PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0" | 77 | PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0" |
78 | 78 | ||
79 | do_install_append() { | 79 | do_install:append() { |
80 | if ${@bb.utils.contains('PACKAGECONFIG', 'vpu', 'true', 'false', d)}; then | 80 | if ${@bb.utils.contains('PACKAGECONFIG', 'vpu', 'true', 'false', d)}; then |
81 | install -m0644 ${WORKDIR}/mvnc/usb-ma2x8x.mvcmd ${D}${libdir}/ | 81 | install -m0644 ${WORKDIR}/mvnc/usb-ma2x8x.mvcmd ${D}${libdir}/ |
82 | install -m0644 ${WORKDIR}/mvnc/pcie-ma2x8x.mvcmd ${D}${libdir}/ | 82 | install -m0644 ${WORKDIR}/mvnc/pcie-ma2x8x.mvcmd ${D}${libdir}/ |
@@ -102,13 +102,13 @@ do_install_append() { | |||
102 | 102 | ||
103 | # Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR | 103 | # Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR |
104 | # instead of RSS | 104 | # instead of RSS |
105 | SSTATE_SCAN_FILES_append = " *.cmake" | 105 | SSTATE_SCAN_FILES:append = " *.cmake" |
106 | 106 | ||
107 | FILES_${PN}-dev = "${includedir} \ | 107 | FILES:${PN}-dev = "${includedir} \ |
108 | ${libdir}/cmake \ | 108 | ${libdir}/cmake \ |
109 | " | 109 | " |
110 | 110 | ||
111 | FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \ | 111 | FILES:${PN} += "${libdir}/lib*${SOLIBSDEV} \ |
112 | ${datadir}/openvino \ | 112 | ${datadir}/openvino \ |
113 | ${libdir}/custom_kernels \ | 113 | ${libdir}/custom_kernels \ |
114 | ${libdir}/plugins.xml \ | 114 | ${libdir}/plugins.xml \ |
@@ -118,12 +118,12 @@ FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \ | |||
118 | # Move inference engine samples into a separate package | 118 | # Move inference engine samples into a separate package |
119 | PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware" | 119 | PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware" |
120 | 120 | ||
121 | FILES_${PN}-samples = "${datadir}/inference_engine \ | 121 | FILES:${PN}-samples = "${datadir}/inference_engine \ |
122 | ${bindir} \ | 122 | ${bindir} \ |
123 | " | 123 | " |
124 | FILES_${PN}-vpu-firmware += "${libdir}/*.mvcmd" | 124 | FILES:${PN}-vpu-firmware += "${libdir}/*.mvcmd" |
125 | 125 | ||
126 | # Package for inference engine python API | 126 | # Package for inference engine python API |
127 | PACKAGES =+ "${PN}-${PYTHON_PN}" | 127 | PACKAGES =+ "${PN}-${PYTHON_PN}" |
128 | 128 | ||
129 | FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino" | 129 | FILES:${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino" |