summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch130
1 files changed, 0 insertions, 130 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch
deleted file mode 100644
index 6f0eb517..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch
+++ /dev/null
@@ -1,130 +0,0 @@
1From d96a9413face4e8540400848d9a25a5458bad74a Mon Sep 17 00:00:00 2001
2From: "Brett T. Warden" <brett.t.warden@intel.com>
3Date: Mon, 28 Jan 2019 13:58:03 -0800
4Subject: [PATCH] Install sample apps and format_reader library
5
6Make sure that we install format_reader library as well.
7
8Upstream-Status: Submitted
9
10Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com>
11---
12 inference-engine/samples/classification_sample/CMakeLists.txt | 1 +
13 inference-engine/samples/classification_sample_async/CMakeLists.txt | 1 +
14 inference-engine/samples/common/format_reader/CMakeLists.txt | 1 +
15 inference-engine/samples/hello_autoresize_classification/CMakeLists.txt | 1 +
16 inference-engine/samples/hello_classification/CMakeLists.txt | 1 +
17 inference-engine/samples/hello_request_classification/CMakeLists.txt | 1 +
18 inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt | 1 +
19 inference-engine/samples/style_transfer_sample/CMakeLists.txt | 1 +
20 inference-engine/samples/validation_app/CMakeLists.txt | 1 +
21 9 files changed, 9 insertions(+)
22
23diff --git a/inference-engine/samples/classification_sample/CMakeLists.txt b/inference-engine/samples/classification_sample/CMakeLists.txt
24index 1dab0c9..b2c67ea 100644
25--- a/inference-engine/samples/classification_sample/CMakeLists.txt
26+++ b/inference-engine/samples/classification_sample/CMakeLists.txt
27@@ -16,6 +16,7 @@ link_directories(${LIB_FOLDER})
28
29 # Create library file from sources.
30 add_executable(${TARGET_NAME} ${SRC})
31+install(TARGETS ${TARGET_NAME} DESTINATION bin)
32
33 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
34 COMPILE_PDB_NAME ${TARGET_NAME})
35diff --git a/inference-engine/samples/classification_sample_async/CMakeLists.txt b/inference-engine/samples/classification_sample_async/CMakeLists.txt
36index 9e37440..3fc0082 100644
37--- a/inference-engine/samples/classification_sample_async/CMakeLists.txt
38+++ b/inference-engine/samples/classification_sample_async/CMakeLists.txt
39@@ -16,6 +16,7 @@ link_directories(${LIB_FOLDER})
40
41 # Create library file from sources.
42 add_executable(${TARGET_NAME} ${SRC})
43+install(TARGETS ${TARGET_NAME} DESTINATION bin)
44
45 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
46 COMPILE_PDB_NAME ${TARGET_NAME})
47diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt
48index e3ecd58..cc30fec 100644
49--- a/inference-engine/samples/common/format_reader/CMakeLists.txt
50+++ b/inference-engine/samples/common/format_reader/CMakeLists.txt
51@@ -35,6 +35,7 @@ source_group("include" FILES ${LIBRARY_HEADERS})
52
53 # Create library file from sources.
54 add_library(${TARGET_NAME} SHARED ${MAIN_SRC} ${LIBRARY_HEADERS})
55+install(TARGETS ${TARGET_NAME} DESTINATION lib)
56 target_link_libraries(${TARGET_NAME} ${OpenCV_LIBRARIES})
57
58 if(CMAKE_VERSION VERSION_LESS "2.8.11")
59diff --git a/inference-engine/samples/hello_autoresize_classification/CMakeLists.txt b/inference-engine/samples/hello_autoresize_classification/CMakeLists.txt
60index 01deda6..5ef2900 100644
61--- a/inference-engine/samples/hello_autoresize_classification/CMakeLists.txt
62+++ b/inference-engine/samples/hello_autoresize_classification/CMakeLists.txt
63@@ -21,6 +21,7 @@ link_directories(${LIB_FOLDER})
64
65 # Create library file from sources.
66 add_executable(${TARGET_NAME} ${SRC})
67+install(TARGETS ${TARGET_NAME} DESTINATION bin)
68
69 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
70 COMPILE_PDB_NAME ${TARGET_NAME})
71diff --git a/inference-engine/samples/hello_classification/CMakeLists.txt b/inference-engine/samples/hello_classification/CMakeLists.txt
72index 845f7e9..276be87 100644
73--- a/inference-engine/samples/hello_classification/CMakeLists.txt
74+++ b/inference-engine/samples/hello_classification/CMakeLists.txt
75@@ -23,6 +23,7 @@ link_directories(${LIB_FOLDER})
76
77 # Create library file from sources.
78 add_executable(${TARGET_NAME} ${SRC})
79+install(TARGETS ${TARGET_NAME} DESTINATION bin)
80
81 if(WIN32)
82 # This target supports UNICODE on Windows
83diff --git a/inference-engine/samples/hello_request_classification/CMakeLists.txt b/inference-engine/samples/hello_request_classification/CMakeLists.txt
84index c7dbb1e..3e5ab8f 100644
85--- a/inference-engine/samples/hello_request_classification/CMakeLists.txt
86+++ b/inference-engine/samples/hello_request_classification/CMakeLists.txt
87@@ -23,6 +23,7 @@ link_directories(${LIB_FOLDER})
88
89 # Create library file from sources.
90 add_executable(${TARGET_NAME} ${SRC})
91+install(TARGETS ${TARGET_NAME} DESTINATION bin)
92
93 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
94 COMPILE_PDB_NAME ${TARGET_NAME})
95diff --git a/inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt b/inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt
96index 436edc2..adba758 100644
97--- a/inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt
98+++ b/inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt
99@@ -21,6 +21,7 @@ link_directories(${LIB_FOLDER})
100
101 # Create library file from sources.
102 add_executable(${TARGET_NAME} ${MAIN_SRC} ${MAIN_HEADERS})
103+install(TARGETS ${TARGET_NAME} DESTINATION bin)
104
105 add_dependencies(${TARGET_NAME} gflags)
106
107diff --git a/inference-engine/samples/style_transfer_sample/CMakeLists.txt b/inference-engine/samples/style_transfer_sample/CMakeLists.txt
108index ac2a170..d8e624b 100644
109--- a/inference-engine/samples/style_transfer_sample/CMakeLists.txt
110+++ b/inference-engine/samples/style_transfer_sample/CMakeLists.txt
111@@ -22,6 +22,7 @@ link_directories(${LIB_FOLDER})
112
113 # Create library file from sources.
114 add_executable(${TARGET_NAME} ${MAIN_SRC} ${MAIN_HEADERS})
115+install(TARGETS ${TARGET_NAME} DESTINATION bin)
116
117 add_dependencies(${TARGET_NAME} gflags)
118
119diff --git a/inference-engine/samples/validation_app/CMakeLists.txt b/inference-engine/samples/validation_app/CMakeLists.txt
120index 87b337c..07f48b7 100644
121--- a/inference-engine/samples/validation_app/CMakeLists.txt
122+++ b/inference-engine/samples/validation_app/CMakeLists.txt
123@@ -36,6 +36,7 @@ link_directories(${LIB_FOLDER})
124
125 # Create library file from sources.
126 add_executable(${TARGET_NAME} ${MAIN_SRC} ${MAIN_HEADERS})
127+install(TARGETS ${TARGET_NAME} DESTINATION bin)
128
129 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
130 COMPILE_PDB_NAME ${TARGET_NAME})