summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch15
1 files changed, 9 insertions, 6 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
index d47d273c..ad4d8e8a 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
@@ -1,4 +1,4 @@
1From f201d67c965318ebe49f0d38ea36e530c35a4701 Mon Sep 17 00:00:00 2001 1From 74b6af221e7e2663687654e6eb2d68a5c7158af9 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:50:19 +0800 3Date: Wed, 10 Jun 2020 09:50:19 +0800
4Subject: [PATCH] cldnn: fix inclusion of headers 4Subject: [PATCH] cldnn: fix inclusion of headers
@@ -13,17 +13,20 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
13 3 files changed, 3 insertions(+), 2 deletions(-) 13 3 files changed, 3 insertions(+), 2 deletions(-)
14 14
15diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp 15diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
16index fce7d8f17..827e5764a 100644 16index 282dcd844..0d5d4084c 100644
17--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp 17--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
18+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp 18+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
19@@ -21,4 +21,4 @@ 19@@ -22,7 +22,7 @@
20 # pragma GCC system_header 20 # pragma GCC system_header
21 #endif 21 #endif
22 22
23-#include <CL/cl2.hpp> 23-#include <CL/cl2.hpp>
24+#include <cl2.hpp> 24+#include <cl2.hpp>
25
26 #if defined __GNUC__
27 # pragma GCC diagnostic pop
25diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt 28diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
26index eeb9b5c80..32a283ba4 100644 29index cdc0de406..70883465b 100644
27--- a/inference-engine/src/cldnn_engine/CMakeLists.txt 30--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
28+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt 31+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
29@@ -33,6 +33,7 @@ target_include_directories(${TARGET_NAME} PRIVATE 32@@ -33,6 +33,7 @@ target_include_directories(${TARGET_NAME} PRIVATE
@@ -35,7 +38,7 @@ index eeb9b5c80..32a283ba4 100644
35 38
36 # install 39 # install
37diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp 40diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
38index c67c81726..5ca48c597 100644 41index 97608c30a..3a04096c0 100644
39--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp 42--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
40+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp 43+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
41@@ -29,7 +29,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel; 44@@ -29,7 +29,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel;
@@ -48,5 +51,5 @@ index c67c81726..5ca48c597 100644
48 51
49 #include <memory> 52 #include <memory>
50-- 53--
512.25.4 542.26.2
52 55