summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch58
1 files changed, 36 insertions, 22 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
index ac34fa4f..9c91ac4d 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
@@ -1,4 +1,4 @@
1From d9adfdc9c802fdb880fb658085854384f90a88c2 Mon Sep 17 00:00:00 2001 1From 5bec3199ec6fd8f784cd688159f768a732c9ad69 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 11 Jun 2020 14:24:04 +0800 3Date: Thu, 11 Jun 2020 14:24:04 +0800
4Subject: [PATCH] cmake installation fixes 4Subject: [PATCH] cmake installation fixes
@@ -9,7 +9,7 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9--- 9---
10 CMakeLists.txt | 14 -------------- 10 CMakeLists.txt | 14 --------------
11 cmake/developer_package.cmake | 10 ++++++---- 11 cmake/developer_package.cmake | 10 ++++++----
12 .../ie_bridges/c/samples/common/CMakeLists.txt | 2 ++ 12 .../samples/common/opencv_c_wraper/CMakeLists.txt | 2 ++
13 inference-engine/samples/CMakeLists.txt | 9 +++------ 13 inference-engine/samples/CMakeLists.txt | 9 +++------
14 .../samples/common/format_reader/CMakeLists.txt | 2 ++ 14 .../samples/common/format_reader/CMakeLists.txt | 2 ++
15 .../src/inference_engine/CMakeLists.txt | 4 ++-- 15 .../src/inference_engine/CMakeLists.txt | 4 ++--
@@ -17,13 +17,14 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
17 inference-engine/tests/unit/cpu/CMakeLists.txt | 4 +++- 17 inference-engine/tests/unit/cpu/CMakeLists.txt | 4 +++-
18 .../tests/unit/inference_engine/CMakeLists.txt | 2 ++ 18 .../tests/unit/inference_engine/CMakeLists.txt | 2 ++
19 inference-engine/tests/unit/vpu/CMakeLists.txt | 4 +++- 19 inference-engine/tests/unit/vpu/CMakeLists.txt | 4 +++-
20 10 files changed, 24 insertions(+), 29 deletions(-) 20 inference-engine/tools/compile_tool/CMakeLists.txt | 2 +-
21 11 files changed, 25 insertions(+), 30 deletions(-)
21 22
22diff --git a/CMakeLists.txt b/CMakeLists.txt 23diff --git a/CMakeLists.txt b/CMakeLists.txt
23index 1f981ed25..2c014ca27 100644 24index 18ed02ee5..18f6094f3 100644
24--- a/CMakeLists.txt 25--- a/CMakeLists.txt
25+++ b/CMakeLists.txt 26+++ b/CMakeLists.txt
26@@ -121,12 +121,8 @@ add_subdirectory(docs) 27@@ -143,12 +143,8 @@ add_subdirectory(docs)
27 28
28 # install setupvars 29 # install setupvars
29 30
@@ -36,7 +37,7 @@ index 1f981ed25..2c014ca27 100644
36 elseif(WIN32) 37 elseif(WIN32)
37 install(PROGRAMS scripts/setupvars/setupvars.bat 38 install(PROGRAMS scripts/setupvars/setupvars.bat
38 DESTINATION bin 39 DESTINATION bin
39@@ -136,22 +132,12 @@ endif() 40@@ -158,22 +154,12 @@ endif()
40 # install install_dependencies 41 # install install_dependencies
41 42
42 if(UNIX) 43 if(UNIX)
@@ -60,7 +61,7 @@ index 1f981ed25..2c014ca27 100644
60 install(DIRECTORY scripts/demo/ 61 install(DIRECTORY scripts/demo/
61 DESTINATION deployment_tools/demo 62 DESTINATION deployment_tools/demo
62diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake 63diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake
63index 5e022244b..6e2cbf44e 100644 64index 86137c384..af011c361 100644
64--- a/cmake/developer_package.cmake 65--- a/cmake/developer_package.cmake
65+++ b/cmake/developer_package.cmake 66+++ b/cmake/developer_package.cmake
66@@ -10,7 +10,9 @@ list(APPEND CMAKE_MODULE_PATH 67@@ -10,7 +10,9 @@ list(APPEND CMAKE_MODULE_PATH
@@ -94,10 +95,10 @@ index 5e022244b..6e2cbf44e 100644
94 endif() 95 endif()
95 96
96 # Enable postfixes for Debug/Release builds 97 # Enable postfixes for Debug/Release builds
97diff --git a/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt b/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt 98diff --git a/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt b/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt
98index b8d5ddf62..d086478f6 100644 99index b8d5ddf62..d086478f6 100644
99--- a/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt 100--- a/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt
100+++ b/inference-engine/ie_bridges/c/samples/common/CMakeLists.txt 101+++ b/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt
101@@ -29,3 +29,5 @@ set_target_properties(${TARGET_NAME} PROPERTIES FOLDER c_samples) 102@@ -29,3 +29,5 @@ set_target_properties(${TARGET_NAME} PROPERTIES FOLDER c_samples)
102 if(COMMAND add_cpplint_target) 103 if(COMMAND add_cpplint_target)
103 add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME}) 104 add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
@@ -105,7 +106,7 @@ index b8d5ddf62..d086478f6 100644
105+ 106+
106+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}) 107+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
107diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt 108diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
108index 594e581b1..4e95a7808 100644 109index 4dda7eecd..04e1b9c3e 100644
109--- a/inference-engine/samples/CMakeLists.txt 110--- a/inference-engine/samples/CMakeLists.txt
110+++ b/inference-engine/samples/CMakeLists.txt 111+++ b/inference-engine/samples/CMakeLists.txt
111@@ -34,7 +34,7 @@ endif() 112@@ -34,7 +34,7 @@ endif()
@@ -117,7 +118,7 @@ index 594e581b1..4e95a7808 100644
117 # hint for find_package(InferenceEngine in the samples folder) 118 # hint for find_package(InferenceEngine in the samples folder)
118 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}") 119 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
119 # hint for find_package(ngraph in the samples folder) 120 # hint for find_package(ngraph in the samples folder)
120@@ -118,11 +118,6 @@ set (HAVE_INTTYPES_H 1) 121@@ -122,11 +122,6 @@ set (HAVE_INTTYPES_H 1)
121 set (INTTYPES_FORMAT C99) 122 set (INTTYPES_FORMAT C99)
122 set (BUILD_TESTING OFF) 123 set (BUILD_TESTING OFF)
123 124
@@ -129,7 +130,7 @@ index 594e581b1..4e95a7808 100644
129 if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU") 130 if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
130 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall") 131 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
131 endif() 132 endif()
132@@ -239,6 +234,8 @@ macro(ie_add_sample) 133@@ -250,6 +245,8 @@ macro(ie_add_sample)
133 add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME} 134 add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME}
134 CUSTOM_FILTERS ${custom_filters}) 135 CUSTOM_FILTERS ${custom_filters})
135 endif() 136 endif()
@@ -149,10 +150,10 @@ index 48dbed9f2..76532fd04 100644
149+ 150+
150+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}) 151+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
151diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt 152diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
152index 4ae0d5607..b9ee12498 100644 153index 105e666a3..5c2f70575 100644
153--- a/inference-engine/src/inference_engine/CMakeLists.txt 154--- a/inference-engine/src/inference_engine/CMakeLists.txt
154+++ b/inference-engine/src/inference_engine/CMakeLists.txt 155+++ b/inference-engine/src/inference_engine/CMakeLists.txt
155@@ -265,8 +265,8 @@ install(TARGETS ${TARGET_NAME} 156@@ -244,8 +244,8 @@ install(TARGETS ${TARGET_NAME}
156 install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake" 157 install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake"
157 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake" 158 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake"
158 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake" 159 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake"
@@ -164,7 +165,7 @@ index 4ae0d5607..b9ee12498 100644
164+ DESTINATION ${CMAKE_INSTALL_LIBDIR} 165+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
165 COMPONENT core) 166 COMPONENT core)
166diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt 167diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
167index bf30d127c..6ed8c4081 100644 168index aeebe4e04..310eb6231 100644
168--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt 169--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
169+++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt 170+++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
170@@ -48,5 +48,5 @@ target_link_libraries(${TARGET_NAME} 171@@ -48,5 +48,5 @@ target_link_libraries(${TARGET_NAME}
@@ -175,10 +176,10 @@ index bf30d127c..6ed8c4081 100644
175+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d 176+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
176 COMPONENT myriad) 177 COMPONENT myriad)
177diff --git a/inference-engine/tests/unit/cpu/CMakeLists.txt b/inference-engine/tests/unit/cpu/CMakeLists.txt 178diff --git a/inference-engine/tests/unit/cpu/CMakeLists.txt b/inference-engine/tests/unit/cpu/CMakeLists.txt
178index 9ec5ad025..45c62571a 100644 179index d7acf8908..be4ae4a76 100644
179--- a/inference-engine/tests/unit/cpu/CMakeLists.txt 180--- a/inference-engine/tests/unit/cpu/CMakeLists.txt
180+++ b/inference-engine/tests/unit/cpu/CMakeLists.txt 181+++ b/inference-engine/tests/unit/cpu/CMakeLists.txt
181@@ -22,4 +22,6 @@ addIeTargetTest( 182@@ -24,4 +24,6 @@ addIeTargetTest(
182 ADD_CPPLINT 183 ADD_CPPLINT
183 LABELS 184 LABELS
184 CPU 185 CPU
@@ -188,20 +189,20 @@ index 9ec5ad025..45c62571a 100644
188+ 189+
189+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR}) 190+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
190diff --git a/inference-engine/tests/unit/inference_engine/CMakeLists.txt b/inference-engine/tests/unit/inference_engine/CMakeLists.txt 191diff --git a/inference-engine/tests/unit/inference_engine/CMakeLists.txt b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
191index 3eb21a434..09ba9225a 100644 192index e4613f032..5fe9e7089 100644
192--- a/inference-engine/tests/unit/inference_engine/CMakeLists.txt 193--- a/inference-engine/tests/unit/inference_engine/CMakeLists.txt
193+++ b/inference-engine/tests/unit/inference_engine/CMakeLists.txt 194+++ b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
194@@ -15,3 +15,5 @@ addIeTargetTest( 195@@ -26,3 +26,5 @@ addIeTargetTest(
195 LABELS 196 LABELS
196 IE 197 IE
197 ) 198 )
198+ 199+
199+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR}) 200+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
200diff --git a/inference-engine/tests/unit/vpu/CMakeLists.txt b/inference-engine/tests/unit/vpu/CMakeLists.txt 201diff --git a/inference-engine/tests/unit/vpu/CMakeLists.txt b/inference-engine/tests/unit/vpu/CMakeLists.txt
201index 072103292..117cc9ee1 100644 202index a4106753d..091339e17 100644
202--- a/inference-engine/tests/unit/vpu/CMakeLists.txt 203--- a/inference-engine/tests/unit/vpu/CMakeLists.txt
203+++ b/inference-engine/tests/unit/vpu/CMakeLists.txt 204+++ b/inference-engine/tests/unit/vpu/CMakeLists.txt
204@@ -26,4 +26,6 @@ addIeTargetTest( 205@@ -27,4 +27,6 @@ addIeTargetTest(
205 LABELS 206 LABELS
206 VPU 207 VPU
207 MYRIAD 208 MYRIAD
@@ -210,6 +211,19 @@ index 072103292..117cc9ee1 100644
210+) 211+)
211+ 212+
212+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR}) 213+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
214diff --git a/inference-engine/tools/compile_tool/CMakeLists.txt b/inference-engine/tools/compile_tool/CMakeLists.txt
215index 58614d3ce..9dfa068e4 100644
216--- a/inference-engine/tools/compile_tool/CMakeLists.txt
217+++ b/inference-engine/tools/compile_tool/CMakeLists.txt
218@@ -49,7 +49,7 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
219 # install
220
221 install(TARGETS compile_tool
222- RUNTIME DESTINATION deployment_tools/tools/compile_tool
223+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
224 COMPONENT core)
225
226 install(FILES README.md
213-- 227--
2142.26.2 2282.26.2
215 229