summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch
new file mode 100644
index 00000000..8af9527e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch
@@ -0,0 +1,32 @@
1From 6e225e85d5763e883128ee7b8a97ac247c46b465 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 20 Aug 2019 12:40:09 +0800
4Subject: [PATCH] use ade and pugixml from system
5
6Don't build a local copy and use the one from sysroot.
7
8Upstream-Status: Submitted
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 inference-engine/thirdparty/CMakeLists.txt | 5 ++---
13 1 file changed, 2 insertions(+), 3 deletions(-)
14
15diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt
16index f65f38c..7f23e8f 100644
17--- a/inference-engine/thirdparty/CMakeLists.txt
18+++ b/inference-engine/thirdparty/CMakeLists.txt
19@@ -7,11 +7,10 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
20 set(CMAKE_CC_FLAGS "${CMAKE_CC_FLAGS} -Wno-unknown-warning-option -Wno-inconsistent-missing-override -Wno-pass-failed")
21 endif()
22
23-add_subdirectory(pugixml)
24-export(TARGETS pugixml NAMESPACE IE:: APPEND FILE "${CMAKE_BINARY_DIR}/targets.cmake")
25+# add_subdirectory(pugixml)
26+# export(TARGETS pugixml NAMESPACE IE:: APPEND FILE "${CMAKE_BINARY_DIR}/targets.cmake")
27
28 add_subdirectory(stb_lib)
29-add_subdirectory(ade)
30
31 if (ENABLE_CLDNN)
32 set(CLDNN__OUTPUT_BIN_DIR ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})