summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb
index d13752b0..fc160716 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2020r1.bb
@@ -43,7 +43,7 @@ EXTRA_OECMAKE += " \
43 -DBUILD_GTEST=0 \ 43 -DBUILD_GTEST=0 \
44 -DINSTALL_GMOCK=0 \ 44 -DINSTALL_GMOCK=0 \
45 -DINSTALL_GTEST=0 \ 45 -DINSTALL_GTEST=0 \
46 -DENABLE_SAMPLES=0 \ 46 -DENABLE_SAMPLES=1 \
47 -DENABLE_NGRAPH=ON \ 47 -DENABLE_NGRAPH=ON \
48 -DENABLE_MKL_DNN=ON \ 48 -DENABLE_MKL_DNN=ON \
49 -DIE_CPACK_IE_DIR=${prefix} \ 49 -DIE_CPACK_IE_DIR=${prefix} \
@@ -77,6 +77,19 @@ do_install_append() {
77 if ${@bb.utils.contains('PACKAGECONFIG', 'opencl', 'true', 'false', d)}; then 77 if ${@bb.utils.contains('PACKAGECONFIG', 'opencl', 'true', 'false', d)}; then
78 cp -r ${S}/inference-engine/src/cldnn_engine/cldnn_global_custom_kernels ${D}${libdir}/ 78 cp -r ${S}/inference-engine/src/cldnn_engine/cldnn_global_custom_kernels ${D}${libdir}/
79 fi 79 fi
80
81 if ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'true', 'false', d)}; then
82 install -d ${D}${datadir}/inference_engine
83 mv ${D}/usr/samples/python ${D}${datadir}/inference_engine/
84
85 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
86 mv ${D}${prefix}/python/${PYTHON_DIR}/openvino ${D}${PYTHON_SITEPACKAGES_DIR}/
87
88 rm -rf ${D}${prefix}/python
89 fi
90
91 # Remove the samples source directory. We install the built samples.
92 rm -rf ${D}/usr/samples
80} 93}
81 94
82do_install_ptest_base_prepend() { 95do_install_ptest_base_prepend() {
@@ -107,7 +120,9 @@ FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
107# Move inference engine samples into a separate package 120# Move inference engine samples into a separate package
108PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware" 121PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware"
109 122
110FILES_${PN}-samples = "${datadir}/inference_engine" 123FILES_${PN}-samples = "${datadir}/inference_engine \
124 ${bindir} \
125 "
111FILES_${PN}-vpu-firmware += "${libdir}/*.mvcmd" 126FILES_${PN}-vpu-firmware += "${libdir}/*.mvcmd"
112 127
113# Package for inference engine python API 128# Package for inference engine python API