summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r1.1.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r1.1.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r1.1.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r1.1.bb
new file mode 100644
index 00000000..7010811e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r1.1.bb
@@ -0,0 +1,75 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Deep Learning Deployment Toolkit"
2HOMEPAGE = "https://github.com/opencv/dldt"
3DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic."
6
7SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
8 https://download.01.org/opencv/2019/openvinotoolkit/R1/inference_engine/firmware_ma2450_491.zip;name=ma2450 \
9 https://download.01.org/opencv/2019/openvinotoolkit/R1/inference_engine/firmware_ma2480_mdk_R7_9.zip;name=ma2480 \
10 file://0001-Supply-firmware-at-build-time.patch;patchdir=../ \
11 file://0001-use-provided-paths.patch;patchdir=../ \
12 file://0001-disable-tests.patch;patchdir=../ \
13 file://0001-disable-werror.patch;patchdir=../ \
14 file://0001-fix-openmp-checking.patch;patchdir=../ \
15 file://0002-use-ade-and-pugixml-from-system.patch;patchdir=../ \
16 file://0007-Install-sample-apps-and-format_reader-library.patch;patchdir=../ \
17 "
18SRCREV = "0ef92871b6dd9a9ceed16d184c4595d2618d526f"
19
20SRC_URI[ma2450.md5sum] = "2886778e21ff3713b3ac69e3f43a1da8"
21SRC_URI[ma2450.sha256sum] = "070c57192fa1d4c17c5b2ebf98ebc35323c5617d1d6ccc454308b33a7476c45b"
22
23SRC_URI[ma2480.md5sum] = "a65e0ceab3a33bfe6eff58f2291cecec"
24SRC_URI[ma2480.sha256sum] = "a8231f4f68a1f8eab99d003a43756a23079699be379b64dacf66ad4912a607b3"
25
26LICENSE = "Apache-2.0"
27LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
28
29inherit cmake
30
31S = "${WORKDIR}/git/inference-engine"
32
33EXTRA_OECMAKE += " \
34 -DVPU_FIRMWARE_MA2450_FILE=../mvnc/MvNCAPI-ma2450.mvcmd \
35 -DVPU_FIRMWARE_MA2480_FILE=../mvnc/MvNCAPI-ma2480.mvcmd \
36 -DENABLE_INTEL_OMP=0 \
37 -DENABLE_OPENCV=1 \
38 -DENABLE_SAMPLES_CORE=1 \
39 -DENABLE_PLUGIN_RPATH=0 \
40 -DENABLE_GNA=0 \
41 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2 \
42 -DTHREADING=OMP \
43 -DCMAKE_INSTALL_LOCAL_ONLY=OFF \
44 -DCMAKE_BUILD_TYPE=DebugWithRelInfo \
45 "
46
47DEPENDS += "libusb1 ade mkl-dnn opencv pugixml"
48
49PACKAGECONFIG ?= ""
50PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime"
51
52do_install_append () {
53 # Workaround cmake build issue where the libraries are not properly
54 # installed, eventually these should be fixed in inference engine's
55 # cmake build.
56
57 install ${B}/src/extension/libcpu_extension.so ${D}${libdir}
58 install ${B}/src/vpu/myriad_plugin/libmyriadPlugin.so ${D}${libdir}
59 install ${B}/src/inference_engine/libinference_engine.so ${D}${libdir}
60 install ${B}/src/hetero_plugin/libHeteroPlugin.so ${D}${libdir}
61 install ${B}/src/mkldnn_plugin/libMKLDNNPlugin.so ${D}${libdir}
62
63 # libclDNNPlugin.so only exists when PACKAGECONFIG intel-compute-runtime
64 # is set (-DENABLE_CLDNN=1)
65 if ${@bb.utils.contains('PACKAGECONFIG', 'opencl', 'true', 'false', d)}; then
66 install ${B}/src/cldnn_engine/libclDNNPlugin.so ${D}${libdir}
67 fi
68}
69
70# Move inference engine samples into a separate package
71PACKAGES =+ "${PN}-samples"
72
73FILES_${PN}-dev = "${includedir}"
74FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}"
75FILES_${PN}-samples = "${bindir}"