summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb
deleted file mode 100644
index 63bc7b6a..00000000
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1SUMMARY = "Intel(R) Local Managability Service"
2DESCRIPTION = "Intel Local Manageability Service allows applications \
3to access the Intel Active Management Technology (AMT) firmware via \
4the Intel Management Engine Interface (MEI)."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10
11COMPATIBLE_HOST_libc-musl = "null"
12
13inherit cmake systemd features_check
14
15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native"
16
17EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
18
19# Enable either connman or networkmanager or none but not both.
20PACKAGECONFIG ??= "connman"
21PACKAGECONFIG[connman] = "-DNETWORK_CN=ON, -DNETWORK_CN=OFF, connman"
22PACKAGECONFIG[networkmanager] = "-DNETWORK_NM=ON, -DNETWORK_NM=OFF, networkmanager"
23
24REQUIRED_DISTRO_FEATURES= "systemd"
25
26FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
27
28S = "${WORKDIR}/git"
29
30SYSTEMD_SERVICE_${PN} = "lms.service"
31
32SRC_URI = "git://github.com/intel/lms.git \
33 file://0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch \
34 "
35SRCREV = "597783800b000091e05855f1e7431555216e77da"
36
37SRC_URI_append = " file://lms_drop_rpath_${PV}.diff"
38
39do_install_append() {
40 install -d ${D}${systemd_system_unitdir}
41 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
42}
43
44RDEPENDS_${PN} += "ace"