summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb
new file mode 100644
index 00000000..8ed74486
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Intel(R) Local Managability Service"
2DESCRIPTION = "Intel Local Manageability Service allows applications \
3to access the Intel Active Management Technology (AMT) firmware via \
4the Intel Management Engine Interface (MEI)."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10
11inherit cmake systemd
12
13DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native connman"
14
15EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
16
17REQUIRED_DISTRO_FEATURES= "systemd"
18
19FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
20
21FILES_${PN} += "${libdir}/libLms*.so"
22FILES_SOLIBSDEV = ""
23INSANE_SKIP_${PN} += "dev-so"
24
25S = "${WORKDIR}/git"
26
27SYSTEMD_SERVICE_${PN} = "lms.service"
28
29SRC_URI = "git://github.com/intel/lms.git"
30SRCREV = "f7c374745ae7efb3ed7860fdc3f8abbb52dc9f8f"
31
32SRC_URI_append = " file://lms_drop_rpath_${PV}.diff"
33
34do_install_append() {
35 install -d ${D}${systemd_system_unitdir}
36 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
37}
38
39RDEPENDS_${PN} += "ace"