diff options
Diffstat (limited to 'dynamic-layers/clang-layer')
4 files changed, 27 insertions, 78 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch deleted file mode 100644 index 417e0221..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/point-to-correct-llvm-tblgen.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From 2ce2619b544678541e0cc56494e2927086718613 Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anuj.mittal@intel.com> | ||
3 | Date: Tue, 26 Mar 2019 14:11:29 +0800 | ||
4 | Subject: [PATCH] point to correct llvm-tblgen | ||
5 | |||
6 | Let llvm-tblgen path be passed from recipe itself. | ||
7 | |||
8 | Also since we're going to do the patching ourselves, no need to look for | ||
9 | git through cmake. | ||
10 | |||
11 | Upstream-Status: Inappropriate [OE specific] | ||
12 | |||
13 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
14 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
15 | --- | ||
16 | CMakeLists.txt | 4 ++-- | ||
17 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
18 | |||
19 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
20 | index 1371a67..f83ffcc 100644 | ||
21 | --- a/CMakeLists.txt | ||
22 | +++ b/CMakeLists.txt | ||
23 | @@ -53,7 +53,7 @@ endif(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR) | ||
24 | include(AddLLVM) | ||
25 | include(TableGen) | ||
26 | |||
27 | -find_package(Git REQUIRED) | ||
28 | +#find_package(Git REQUIRED) | ||
29 | |||
30 | if (NOT WIN32) | ||
31 | add_subdirectory( linux_linker ) | ||
32 | @@ -138,7 +138,7 @@ endif(NOT USE_PREBUILT_LLVM) | ||
33 | set (COMPILE_OPTIONS_TD opencl_clang_options.td) | ||
34 | set (COMPILE_OPTIONS_INC opencl_clang_options.inc) | ||
35 | |||
36 | -set(LLVM_TABLEGEN_EXE "llvm-tblgen") | ||
37 | +#set(LLVM_TABLEGEN_EXE "llvm-tblgen") | ||
38 | set(LLVM_TARGET_DEFINITIONS ${COMPILE_OPTIONS_TD}) | ||
39 | if(USE_PREBUILT_LLVM) | ||
40 | set(TABLEGEN_ADDITIONAL -I ${LLVM_INCLUDE_DIRS}) | ||
41 | -- | ||
42 | 2.17.1 | ||
43 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc deleted file mode 100644 index c099a509..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | SUMMARY = "Common clang is a thin wrapper library around clang" | ||
2 | DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \ | ||
3 | to compile OpenCL C kernels to SPIR-V modules." | ||
4 | |||
5 | LICENSE = "NCSA" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c" | ||
7 | |||
8 | S = "${WORKDIR}/git" | ||
9 | |||
10 | inherit cmake | ||
11 | DEPENDS += "clang" | ||
12 | DEPENDS_append_class-target = " opencl-clang-native" | ||
13 | |||
14 | COMPATIBLE_HOST = '(x86_64).*-linux' | ||
15 | COMPATIBLE_HOST_libc-musl = "null" | ||
16 | |||
17 | EXTRA_OECMAKE += "\ | ||
18 | -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ | ||
19 | -DCMAKE_SKIP_RPATH=TRUE \ | ||
20 | " | ||
21 | |||
22 | do_install_append_class-native() { | ||
23 | install -d ${D}${bindir} | ||
24 | install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/ | ||
25 | } | ||
26 | |||
27 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb index c2b7d74a..c5ba96c1 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb | |||
@@ -1,4 +1,9 @@ | |||
1 | require opencl-clang.inc | 1 | SUMMARY = "Common clang is a thin wrapper library around clang" |
2 | DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \ | ||
3 | to compile OpenCL C kernels to SPIR-V modules." | ||
4 | |||
5 | LICENSE = "NCSA" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c" | ||
2 | 7 | ||
3 | SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-100;protocol=https \ | 8 | SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-100;protocol=https \ |
4 | file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \ | 9 | file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \ |
@@ -7,3 +12,24 @@ SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-100;protocol= | |||
7 | SRC_URI_append_class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" | 12 | SRC_URI_append_class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" |
8 | 13 | ||
9 | SRCREV = "92f3f7f1a06f25fb13708f87c26b0fbf50924c96" | 14 | SRCREV = "92f3f7f1a06f25fb13708f87c26b0fbf50924c96" |
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | inherit cmake | ||
19 | DEPENDS += "clang" | ||
20 | DEPENDS_append_class-target = " opencl-clang-native" | ||
21 | |||
22 | COMPATIBLE_HOST = '(x86_64).*-linux' | ||
23 | COMPATIBLE_HOST_libc-musl = "null" | ||
24 | |||
25 | EXTRA_OECMAKE += "\ | ||
26 | -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ | ||
27 | -DCMAKE_SKIP_RPATH=TRUE \ | ||
28 | " | ||
29 | |||
30 | do_install_append_class-native() { | ||
31 | install -d ${D}${bindir} | ||
32 | install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/ | ||
33 | } | ||
34 | |||
35 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb deleted file mode 100644 index f262a5eb..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | require opencl-clang.inc | ||
2 | |||
3 | SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-90;protocol=https \ | ||
4 | file://point-to-correct-llvm-tblgen.patch \ | ||
5 | " | ||
6 | |||
7 | SRCREV = "6f8c329bea44321aef1a1716dd206c1f7bed23cf" | ||