diff options
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl')
4 files changed, 2 insertions, 35 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-Fix-standalone-build-415.patch b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-Fix-standalone-build-415.patch deleted file mode 100644 index 3767d537..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-Fix-standalone-build-415.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From c2481fb3c7890302db5ee326ad9807155a2a2188 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Franti=C5=A1ek=20Zatloukal?= <Zatloukal.Frantisek@gmail.com> | ||
3 | Date: Fri, 21 Apr 2023 04:07:21 +0200 | ||
4 | Subject: [PATCH 1/2] Fix standalone build (#415) | ||
5 | |||
6 | Fixes https://github.com/intel/opencl-clang/issues/406 | ||
7 | Fixes https://github.com/intel/opencl-clang/issues/374 | ||
8 | |||
9 | Upstream-Status: Backport [https://github.com/intel/opencl-clang/commit/529a9188114bcbd8ed753d2276942384fa50d7a1] | ||
10 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
11 | --- | ||
12 | cl_headers/CMakeLists.txt | 6 +++++- | ||
13 | 1 file changed, 5 insertions(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/cl_headers/CMakeLists.txt b/cl_headers/CMakeLists.txt | ||
16 | index 69cf11e..18296c2 100644 | ||
17 | --- a/cl_headers/CMakeLists.txt | ||
18 | +++ b/cl_headers/CMakeLists.txt | ||
19 | @@ -1,5 +1,9 @@ | ||
20 | set(CL_HEADERS_LIB cl_headers) | ||
21 | -set(CLANG_COMMAND $<TARGET_FILE:clang> ) | ||
22 | +if(USE_PREBUILT_LLVM) | ||
23 | + find_program(CLANG_COMMAND clang PATHS ${LLVM_TOOLS_BINARY_DIR} NO_DEFAULT_PATH) | ||
24 | +else() | ||
25 | + set(CLANG_COMMAND $<TARGET_FILE:clang>) | ||
26 | +endif() | ||
27 | if(LLVM_USE_HOST_TOOLS AND NOT OPENCL_CLANG_BUILD_EXTERNAL) | ||
28 | build_native_tool(clang CLANG_COMMAND) | ||
29 | endif() | ||
30 | -- | ||
31 | 2.37.3 | ||
32 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc index 7c8c2513..31a3fb21 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc +++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc | |||
@@ -6,7 +6,6 @@ LICENSE = "NCSA" | |||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c" |
7 | 7 | ||
8 | SRC_URI = "git://github.com/intel/opencl-clang.git;branch=${BRANCH};protocol=https \ | 8 | SRC_URI = "git://github.com/intel/opencl-clang.git;branch=${BRANCH};protocol=https \ |
9 | file://0001-Fix-standalone-build-415.patch \ | ||
10 | file://0002-Request-native-clang-only-when-cross-compiling-464.patch \ | 9 | file://0002-Request-native-clang-only-when-cross-compiling-464.patch \ |
11 | file://0001-cl_headers-CMakeLists.txt-use-clang-from-native-sysr.patch \ | 10 | file://0001-cl_headers-CMakeLists.txt-use-clang-from-native-sysr.patch \ |
12 | " | 11 | " |
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb index 2a7af0c9..7e56af75 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | require opencl-clang.inc | 1 | require opencl-clang.inc |
2 | 2 | ||
3 | SRCREV = "cf95b338d14685e4f3402ab1828bef31d48f1fd6" | 3 | SRCREV = "980f1691c5babcf824ee10375a04a0d0c5d7d44a" |
4 | 4 | ||
5 | BRANCH = "ocl-open-140" | 5 | BRANCH = "ocl-open-140" |
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_15.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_15.0.0.bb index 0865a2af..e946c31c 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_15.0.0.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_15.0.0.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | require opencl-clang.inc | 1 | require opencl-clang.inc |
2 | 2 | ||
3 | SRCREV = "bc1d13ecc1c6f7aa5da3acf33165037d3fc5ed06" | 3 | SRCREV = "60fd799cc58755c16d951f9ebfde6d0f9b8554dd" |
4 | 4 | ||
5 | BRANCH = "ocl-open-150" | 5 | BRANCH = "ocl-open-150" |