summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-includes.patch157
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch25
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb2
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch29
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb1
5 files changed, 214 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-includes.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-includes.patch
new file mode 100644
index 00000000..a008d69e
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-includes.patch
@@ -0,0 +1,157 @@
1From 1517c8689cdaab9aaa1fa25e8db3b84f93e1f1ca Mon Sep 17 00:00:00 2001
2From: Mateusz Jablonski <mateusz.jablonski@intel.com>
3Date: Tue, 22 Aug 2023 12:37:37 +0200
4Subject: [PATCH] fix: add missing includes
5
6Upstream-Status: Pending
7Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
8---
9 level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h | 1 +
10 opencl/test/unit_test/built_ins/built_ins_file_names.h | 3 ++-
11 shared/source/compiler_interface/external_functions.h | 1 +
12 shared/source/os_interface/linux/drm_debug.h | 1 +
13 shared/source/os_interface/linux/pci_path.h | 3 ++-
14 shared/source/os_interface/linux/pmt_util.h | 1 +
15 shared/source/os_interface/print.h | 1 +
16 shared/source/tbx/tbx_sockets.h | 1 +
17 shared/source/tbx/tbx_sockets_imp.h | 1 +
18 third_party/aot_config_headers/platforms.h | 1 +
19 10 files changed, 12 insertions(+), 2 deletions(-)
20
21diff --git a/level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h b/level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h
22index 2bcfa0e6aa..2a30b0c6be 100644
23--- a/level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h
24+++ b/level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h
25@@ -7,6 +7,7 @@
26
27 #pragma once
28
29+#include <cstdint>
30 #include <map>
31 #include <string>
32
33diff --git a/opencl/test/unit_test/built_ins/built_ins_file_names.h b/opencl/test/unit_test/built_ins/built_ins_file_names.h
34index 08dc38d406..ca43ba0f26 100644
35--- a/opencl/test/unit_test/built_ins/built_ins_file_names.h
36+++ b/opencl/test/unit_test/built_ins/built_ins_file_names.h
37@@ -1,5 +1,5 @@
38 /*
39- * Copyright (C) 2020-2022 Intel Corporation
40+ * Copyright (C) 2020-2023 Intel Corporation
41 *
42 * SPDX-License-Identifier: MIT
43 *
44@@ -7,6 +7,7 @@
45
46 #pragma once
47
48+#include <cstdint>
49 #include <string>
50 #include <vector>
51
52diff --git a/shared/source/compiler_interface/external_functions.h b/shared/source/compiler_interface/external_functions.h
53index f4cd790489..d377bf3937 100644
54--- a/shared/source/compiler_interface/external_functions.h
55+++ b/shared/source/compiler_interface/external_functions.h
56@@ -9,6 +9,7 @@
57
58 #include "shared/source/utilities/arrayref.h"
59
60+#include <cstdint>
61 #include <string>
62 #include <unordered_map>
63 #include <vector>
64diff --git a/shared/source/os_interface/linux/drm_debug.h b/shared/source/os_interface/linux/drm_debug.h
65index a1a46fcd8e..bc56e407d9 100644
66--- a/shared/source/os_interface/linux/drm_debug.h
67+++ b/shared/source/os_interface/linux/drm_debug.h
68@@ -7,6 +7,7 @@
69
70 #pragma once
71
72+#include <cstdint>
73 #include <array>
74 #include <string>
75 #include <utility>
76diff --git a/shared/source/os_interface/linux/pci_path.h b/shared/source/os_interface/linux/pci_path.h
77index c72c1d65d0..4f95e5ba61 100644
78--- a/shared/source/os_interface/linux/pci_path.h
79+++ b/shared/source/os_interface/linux/pci_path.h
80@@ -7,6 +7,7 @@
81
82 #pragma once
83
84+#include <cstdint>
85 #include <optional>
86 #include <string>
87
88@@ -16,4 +17,4 @@ std::optional<std::string> getPciPath(int deviceFd);
89 std::optional<std::string> getPciLinkPath(int deviceFd);
90 std::optional<std::string> getPciRootPath(int deviceFd);
91
92-} // namespace NEO
93\ No newline at end of file
94+} // namespace NEO
95diff --git a/shared/source/os_interface/linux/pmt_util.h b/shared/source/os_interface/linux/pmt_util.h
96index 28ecad3f05..d85bf298ae 100644
97--- a/shared/source/os_interface/linux/pmt_util.h
98+++ b/shared/source/os_interface/linux/pmt_util.h
99@@ -7,6 +7,7 @@
100
101 #pragma once
102
103+#include <cstdint>
104 #include <map>
105 #include <poll.h>
106 #include <string>
107diff --git a/shared/source/os_interface/print.h b/shared/source/os_interface/print.h
108index 7cc214e6ec..ac967be44b 100644
109--- a/shared/source/os_interface/print.h
110+++ b/shared/source/os_interface/print.h
111@@ -7,6 +7,7 @@
112
113 #pragma once
114
115+#include <cstdint>
116 #include <cstddef>
117
118 void printToSTDOUT(const char *str);
119diff --git a/shared/source/tbx/tbx_sockets.h b/shared/source/tbx/tbx_sockets.h
120index 9b7f7863f0..2d4cf2ffbe 100644
121--- a/shared/source/tbx/tbx_sockets.h
122+++ b/shared/source/tbx/tbx_sockets.h
123@@ -6,6 +6,7 @@
124 */
125
126 #pragma once
127+#include <cstdint>
128 #include <string>
129
130 namespace NEO {
131diff --git a/shared/source/tbx/tbx_sockets_imp.h b/shared/source/tbx/tbx_sockets_imp.h
132index 738f26175b..4a567a8f64 100644
133--- a/shared/source/tbx/tbx_sockets_imp.h
134+++ b/shared/source/tbx/tbx_sockets_imp.h
135@@ -10,6 +10,7 @@
136
137 #include "os_socket.h"
138
139+#include <cstdint>
140 #include <iostream>
141
142 namespace NEO {
143diff --git a/third_party/aot_config_headers/platforms.h b/third_party/aot_config_headers/platforms.h
144index 05f75a40b3..35fb490a55 100644
145--- a/third_party/aot_config_headers/platforms.h
146+++ b/third_party/aot_config_headers/platforms.h
147@@ -7,6 +7,7 @@
148
149 #include <map>
150 #include <string>
151+#include <cstdint>
152
153 #pragma once
154
155--
1562.43.0
157
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch
new file mode 100644
index 00000000..4aed37b8
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch
@@ -0,0 +1,25 @@
1From 894bab05efb447d249c9f0afdbf0ca62c82395c6 Mon Sep 17 00:00:00 2001
2From: Mateusz Jablonski <mateusz.jablonski@intel.com>
3Date: Tue, 22 Aug 2023 10:55:50 +0000
4Subject: [PATCH] fix: add missing zero-initialization in StackVec class
5
6Upstream-Status: Backport [https://github.com/intel/compute-runtime/commit/894bab05efb447d249c9f0afdbf0ca62c82395c6]
7
8Signed-off-by: Mateusz Jablonski <mateusz.jablonski@intel.com>
9---
10 shared/source/utilities/stackvec.h | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13Index: git/shared/source/utilities/stackvec.h
14===================================================================
15--- git.orig/shared/source/utilities/stackvec.h
16+++ git/shared/source/utilities/stackvec.h
17@@ -431,7 +431,7 @@ class StackVec { // NOLINT(clang-analyze
18 DataType *onStackMem;
19 };
20
21- alignas(alignof(DataType)) char onStackMemRawBytes[sizeof(DataType[onStackCaps])];
22+ alignas(alignof(DataType)) char onStackMemRawBytes[sizeof(DataType[onStackCaps])]{};
23 SizeT onStackSize = 0U;
24 };
25
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb
index ebf69af2..bb471f00 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb
@@ -9,6 +9,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9280143b568466d8fbe385f838078b93 \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" 9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10 10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=master \ 11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=master \
12 file://0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch \
13 file://0001-fix-add-missing-includes.patch \
12 " 14 "
13 15
14SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \ 16SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch
new file mode 100644
index 00000000..4b1078e1
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch
@@ -0,0 +1,29 @@
1From 5ea17d8bcf3daa03ef95d0fed796f68cec7dc32d Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Franti=C5=A1ek=20Zatloukal?= <fzatlouk@redhat.com>
3Date: Wed, 18 Jan 2023 22:22:23 +0000
4Subject: [PATCH] SPIRVutil: Include cstdint to fix GCC 13 build
5
6SPIRVutil: Include cstdint to fix GCC 13 build
7
8Upstream-Status: Backport [https://github.com/intel-innersource/drivers.gpu.compiler.staging/commit/5ea17d8bcf3daa03ef95d0fed796f68cec7dc32d]
9
10Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
11---
12 IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h b/IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h
16index 1076d5d42..9685e477f 100644
17--- a/IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h
18+++ b/IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h
19@@ -49,6 +49,7 @@ THE SOFTWARE.
20 #define SPIRVUTIL_H_
21
22 #include <algorithm>
23+#include <cstdint>
24 #include <functional>
25 #include <limits>
26 #include <map>
27--
282.34.1
29
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb
index 7a994ebe..354732d5 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;nam
14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=SPIRV-Headers;name=spirv-headers;branch=master \ 14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=SPIRV-Headers;name=spirv-headers;branch=master \
15 file://0003-Improve-Reproducibility-for-src-package.patch \ 15 file://0003-Improve-Reproducibility-for-src-package.patch \
16 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \ 16 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \
17 file://0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch \
17 " 18 "
18 19
19SRC_URI:append:class-native = " file://0001-fix-tblgen.patch" 20SRC_URI:append:class-native = " file://0001-fix-tblgen.patch"