diff options
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl')
2 files changed, 1 insertions, 61 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics/0001-Use-standard-installation-directory-variables.patch b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics/0001-Use-standard-installation-directory-variables.patch deleted file mode 100644 index 35469a1c..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics/0001-Use-standard-installation-directory-variables.patch +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | From 33f60fe2c64272cf1472aa541bcb491a62f81ca5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Mon, 26 Oct 2020 16:24:09 +0800 | ||
4 | Subject: [PATCH] Use standard installation directory variables | ||
5 | |||
6 | Upstream-Status: Submitted [https://github.com/intel/vc-intrinsics/pull/35] | ||
7 | |||
8 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
9 | --- | ||
10 | GenXIntrinsics/CMakeLists.txt | 14 +++++++------- | ||
11 | 1 file changed, 7 insertions(+), 7 deletions(-) | ||
12 | |||
13 | diff --git a/GenXIntrinsics/CMakeLists.txt b/GenXIntrinsics/CMakeLists.txt | ||
14 | index c59c589..5bcf0d1 100644 | ||
15 | --- a/GenXIntrinsics/CMakeLists.txt | ||
16 | +++ b/GenXIntrinsics/CMakeLists.txt | ||
17 | @@ -33,7 +33,7 @@ endif() | ||
18 | # this option is to switch on install when we are building not inside IGC | ||
19 | if(INSTALL_REQUIRED) | ||
20 | install(DIRECTORY include/llvm | ||
21 | - DESTINATION include | ||
22 | + DESTINATION ${CMAKE_INSTALL_INCLUDEDIR} | ||
23 | COMPONENT genx-intrinsics-headers | ||
24 | FILES_MATCHING | ||
25 | PATTERN "*.h" | ||
26 | @@ -43,7 +43,7 @@ if(INSTALL_REQUIRED) | ||
27 | # and then "install(DIRECTORY" installs them even if they are empty | ||
28 | # so generated file has to be installed separetely | ||
29 | install(FILES ${CMAKE_CURRENT_BINARY_DIR}/include/llvm/GenXIntrinsics/${GENX_INTRINSICS_DESCRIPTION} | ||
30 | - DESTINATION include/llvm/GenXIntrinsics | ||
31 | + DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/llvm/GenXIntrinsics | ||
32 | COMPONENT genx-intrinsics-headers | ||
33 | ) | ||
34 | |||
35 | @@ -52,15 +52,15 @@ if(INSTALL_REQUIRED) | ||
36 | # we need to limit it to external build | ||
37 | if(BUILD_EXTERNAL) | ||
38 | install(TARGETS LLVMGenXIntrinsics EXPORT LLVMGenXIntrinsicsTargets | ||
39 | - LIBRARY DESTINATION lib | ||
40 | - ARCHIVE DESTINATION lib | ||
41 | - RUNTIME DESTINATION bin | ||
42 | - INCLUDES DESTINATION include | ||
43 | + LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} | ||
44 | + ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} | ||
45 | + RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} | ||
46 | + INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR} | ||
47 | ) | ||
48 | |||
49 | install(EXPORT LLVMGenXIntrinsicsTargets | ||
50 | FILE LLVMGenXIntrinsicsConfig.cmake | ||
51 | - DESTINATION lib/cmake/LLVMGenXIntrinsics | ||
52 | + DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/LLVMGenXIntrinsics | ||
53 | ) | ||
54 | endif() # BUILD_EXTERNAL | ||
55 | endif() # INSTALL_REQUIRED | ||
56 | -- | ||
57 | 2.17.1 | ||
58 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb index 39bf5803..eca1cb4d 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb | |||
@@ -7,10 +7,8 @@ LICENSE = "MIT" | |||
7 | LIC_FILES_CHKSUM = "file://License.md;md5=c18ea6bb4786a26bf4eee88a7424a408" | 7 | LIC_FILES_CHKSUM = "file://License.md;md5=c18ea6bb4786a26bf4eee88a7424a408" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/intel/vc-intrinsics.git;protocol=https; \ | 9 | SRC_URI = "git://github.com/intel/vc-intrinsics.git;protocol=https; \ |
10 | file://0001-Use-standard-installation-directory-variables.patch \ | ||
11 | " | 10 | " |
12 | 11 | SRCREV = "77974f5a32e19475125531483bede9ee23935257" | |
13 | SRCREV = "c8c52b5fb14b33e32de9df573b7de186a0c97c94" | ||
14 | 12 | ||
15 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
16 | 14 | ||