summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb8
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb8
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb6
3 files changed, 11 insertions, 11 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
index 4928eb22..c870b90b 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-100;protocol=
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \ 9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 file://0001-Building-in-tree-with-LLVM-10.0-with-the-LLVM_LINK_L.patch \ 10 file://0001-Building-in-tree-with-LLVM-10.0-with-the-LLVM_LINK_L.patch \
11 " 11 "
12SRC_URI_append_class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" 12SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch"
13 13
14SRCREV = "c8cd72e32b6abc18ce6da71c357ea45ba78b52f0" 14SRCREV = "c8cd72e32b6abc18ce6da71c357ea45ba78b52f0"
15 15
@@ -17,17 +17,17 @@ S = "${WORKDIR}/git"
17 17
18inherit cmake 18inherit cmake
19DEPENDS += "clang" 19DEPENDS += "clang"
20DEPENDS_append_class-target = " opencl-clang-native" 20DEPENDS:append:class-target = " opencl-clang-native"
21 21
22COMPATIBLE_HOST = '(x86_64).*-linux' 22COMPATIBLE_HOST = '(x86_64).*-linux'
23COMPATIBLE_HOST_libc-musl = "null" 23COMPATIBLE_HOST:libc-musl = "null"
24 24
25EXTRA_OECMAKE += "\ 25EXTRA_OECMAKE += "\
26 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ 26 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
27 -DCMAKE_SKIP_RPATH=TRUE \ 27 -DCMAKE_SKIP_RPATH=TRUE \
28 " 28 "
29 29
30do_install_append_class-native() { 30do_install:append:class-native() {
31 install -d ${D}${bindir} 31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/ 32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33} 33}
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
index 0c5d0508..e0b12d1f 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-110;protocol=https \ 8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-110;protocol=https \
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \ 9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 " 10 "
11SRC_URI_append_class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" 11SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch"
12 12
13SRCREV = "c67648d41df00ea8ee9d701d17299b86f86f0321" 13SRCREV = "c67648d41df00ea8ee9d701d17299b86f86f0321"
14 14
@@ -16,10 +16,10 @@ S = "${WORKDIR}/git"
16 16
17inherit cmake 17inherit cmake
18DEPENDS += "clang" 18DEPENDS += "clang"
19DEPENDS_append_class-target = " opencl-clang-native" 19DEPENDS:append:class-target = " opencl-clang-native"
20 20
21COMPATIBLE_HOST = '(x86_64).*-linux' 21COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST_libc-musl = "null" 22COMPATIBLE_HOST:libc-musl = "null"
23 23
24EXTRA_OECMAKE += "\ 24EXTRA_OECMAKE += "\
25 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ 25 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
@@ -27,7 +27,7 @@ EXTRA_OECMAKE += "\
27 -DPREFERRED_LLVM_VERSION="11.1.0" \ 27 -DPREFERRED_LLVM_VERSION="11.1.0" \
28 " 28 "
29 29
30do_install_append_class-native() { 30do_install:append:class-native() {
31 install -d ${D}${bindir} 31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/ 32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33} 33}
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
index 06dc44da..544f7e33 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
@@ -13,17 +13,17 @@ S = "${WORKDIR}/git"
13 13
14inherit cmake 14inherit cmake
15DEPENDS += " clang spirv-llvm-translator" 15DEPENDS += " clang spirv-llvm-translator"
16DEPENDS_append_class-target = " opencl-clang-native" 16DEPENDS:append:class-target = " opencl-clang-native"
17 17
18COMPATIBLE_HOST = '(x86_64).*-linux' 18COMPATIBLE_HOST = '(x86_64).*-linux'
19COMPATIBLE_HOST_libc-musl = "null" 19COMPATIBLE_HOST:libc-musl = "null"
20 20
21EXTRA_OECMAKE += "\ 21EXTRA_OECMAKE += "\
22 -DCMAKE_SKIP_RPATH=TRUE \ 22 -DCMAKE_SKIP_RPATH=TRUE \
23 -DPREFERRED_LLVM_VERSION=${LLVMVERSION} \ 23 -DPREFERRED_LLVM_VERSION=${LLVMVERSION} \
24 " 24 "
25 25
26do_install_append_class-native() { 26do_install:append:class-native() {
27 install -d ${D}${bindir} 27 install -d ${D}${bindir}
28 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/ 28 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
29} 29}