summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb25
1 files changed, 3 insertions, 22 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
index 92befaf0..d0b2acfb 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
@@ -1,31 +1,12 @@
1SUMMARY = "Common clang is a thin wrapper library around clang" 1require opencl-clang.inc
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4 2
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-120;protocol=https \
9 "
10SRCREV = "8fc6b059248dc6c9c40c7cbe5fedcc6ebb951983" 3SRCREV = "8fc6b059248dc6c9c40c7cbe5fedcc6ebb951983"
11 4
12S = "${WORKDIR}/git" 5DEPENDS += " spirv-llvm-translator"
13
14inherit cmake
15DEPENDS += " clang spirv-llvm-translator"
16DEPENDS:append:class-target = " opencl-clang-native"
17 6
18COMPATIBLE_HOST = '(x86_64).*-linux' 7BRANCH = "ocl-open-120"
19COMPATIBLE_HOST:libc-musl = "null"
20 8
21EXTRA_OECMAKE += "\ 9EXTRA_OECMAKE += "\
22 -DCMAKE_SKIP_RPATH=TRUE \ 10 -DCMAKE_SKIP_RPATH=TRUE \
23 -DPREFERRED_LLVM_VERSION="12.0.0" \ 11 -DPREFERRED_LLVM_VERSION="12.0.0" \
24 " 12 "
25
26do_install:append:class-native() {
27 install -d ${D}${bindir}
28 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
29}
30
31BBCLASSEXTEND = "native nativesdk"