summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
new file mode 100644
index 00000000..6df10912
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Common clang is a thin wrapper library around clang"
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-120;protocol=https \
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 "
11
12SRCREV = "cea544b04460a47848e585bfe75cd774c0324b45"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17DEPENDS += " clang spirv-llvm-translator"
18DEPENDS_append_class-target = " opencl-clang-native"
19
20COMPATIBLE_HOST = '(x86_64).*-linux'
21COMPATIBLE_HOST_libc-musl = "null"
22
23EXTRA_OECMAKE += "\
24 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
25 -DCMAKE_SKIP_RPATH=TRUE \
26 -DPREFERRED_LLVM_VERSION="12.0.0" \
27 "
28
29do_install_append_class-native() {
30 install -d ${D}${bindir}
31 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
32}
33
34BBCLASSEXTEND = "native nativesdk"