summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb26
1 files changed, 3 insertions, 23 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
index e0b12d1f..60d5f0cc 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
@@ -1,35 +1,15 @@
1SUMMARY = "Common clang is a thin wrapper library around clang" 1require opencl-clang.inc
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4 2
5LICENSE = "NCSA" 3SRC_URI:append = " file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-110;protocol=https \
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 " 4 "
11SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" 5SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch"
12 6
13SRCREV = "c67648d41df00ea8ee9d701d17299b86f86f0321" 7SRCREV = "c67648d41df00ea8ee9d701d17299b86f86f0321"
14 8
15S = "${WORKDIR}/git" 9BRANCH = "ocl-open-110"
16
17inherit cmake
18DEPENDS += "clang"
19DEPENDS:append:class-target = " opencl-clang-native"
20
21COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST:libc-musl = "null"
23 10
24EXTRA_OECMAKE += "\ 11EXTRA_OECMAKE += "\
25 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ 12 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
26 -DCMAKE_SKIP_RPATH=TRUE \ 13 -DCMAKE_SKIP_RPATH=TRUE \
27 -DPREFERRED_LLVM_VERSION="11.1.0" \ 14 -DPREFERRED_LLVM_VERSION="11.1.0" \
28 " 15 "
29
30do_install:append:class-native() {
31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33}
34
35BBCLASSEXTEND = "native nativesdk"