summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch
deleted file mode 100644
index bd6c9676..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/link-with-all-libs.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From cc0769fb72561f82976e40c5b7ea8bf07069c87a Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 19 Mar 2020 16:30:07 +0800
4Subject: [PATCH] link to all libs
5
6LINK_COMPONENTS=all isn't working for static libs for out of tree builds. Use
7LLVM_AVAILABLE_LIBS instead. Reported:
8
9https://github.com/intel/opencl-clang/issues/114
10
11Upstream-Status: Pending
12
13Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
14---
15 CMakeLists.txt | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/CMakeLists.txt b/CMakeLists.txt
19index 4590a11..2ff9901 100644
20--- a/CMakeLists.txt
21+++ b/CMakeLists.txt
22@@ -261,6 +261,7 @@ add_llvm_library(${TARGET_NAME} SHARED
23 clangLex
24 clangBasic
25 ${ADDITIONAL_LIBS}
26+ ${LLVM_AVAILABLE_LIBS}
27 )
28
29 # Configure resource file on Windows
30--
312.25.1
32