summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb
new file mode 100644
index 00000000..1469bc14
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8744.bb
@@ -0,0 +1,57 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=23;md5=4a985f2545dd5a846e205b1e60a51cd9 \
9 file://NOTICES.txt;md5=db621145dfb627436bc90ad600386801"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc \
12 git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc \
13 file://0001-llvm_deps.cmake-don-t-copy-header-file-when-building.patch \
14 file://0003-Improve-Reproducibility-for-src-package.patch \
15 file://0004-find-external-llvm-tblgen.patch \
16 "
17
18SRCREV_igc = "3ba8dde8c414a0e47df58b1bba12a64f8ba2089e"
19SRCREV_vc = "e5ad7e02aa4aa21a3cd7b3e5d1f3ec9b95f58872"
20
21# Used to replace with relative path in reproducibility patch
22export B
23
24S = "${WORKDIR}/git"
25
26inherit cmake
27
28CXXFLAGS:append = " -Wno-error=nonnull"
29
30COMPATIBLE_HOST = '(x86_64).*-linux'
31COMPATIBLE_HOST:libc-musl = "null"
32
33DEPENDS += " flex-native bison-native clang opencl-clang"
34DEPENDS:append:class-target = " clang-cross-x86_64 intel-graphics-compiler-native"
35
36RDEPENDS:${PN} += "opencl-clang"
37
38EXTRA_OECMAKE = " \
39 -DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} \
40 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
41 -DVC_INTRINSICS_SRC="${S}/vc-intrinsics" \
42 -DIGC_OPTION__LLVM_MODE=Prebuilds \
43 -DIGC_BUILD__VC_ENABLED=OFF \
44 "
45
46do_install:append:class-native () {
47 install -d ${D}${bindir}
48 install ${B}/IGC/Release/elf_packager ${D}${bindir}/
49}
50
51BBCLASSEXTEND = "native nativesdk"
52
53UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"
54
55FILES:${PN} += " \
56 ${libdir}/igc/NOTICES.txt \
57 "