summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8708.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8708.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8708.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8708.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8708.bb
new file mode 100644
index 00000000..1e87047d
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.8708.bb
@@ -0,0 +1,45 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=23;md5=4a985f2545dd5a846e205b1e60a51cd9 \
9 file://NOTICES.txt;md5=db621145dfb627436bc90ad600386801"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \
12 file://0001-skip-execution-of-ElfPackager.patch \
13 file://0002-IGC-VectorCompiler-CMakeLists.txt-link-to-external-L.patch \
14 file://0003-Improve-Reproducibility-for-src-package.patch \
15 file://0004-find-external-llvm-tblgen.patch \
16 "
17
18SRCREV = "9ff8ff3d235cfac683ef91809c64247d6a43b887"
19
20# Used to replace with relative path in reproducibility patch
21export B
22
23S = "${WORKDIR}/git"
24
25inherit cmake
26
27CXXFLAGS:append = " -Wno-error=deprecated-declarations"
28
29COMPATIBLE_HOST = '(x86_64).*-linux'
30COMPATIBLE_HOST:libc-musl = "null"
31
32DEPENDS += " flex-native bison-native clang opencl-clang vc-intrinsics"
33DEPENDS:append:class-target = " clang-cross-x86_64"
34
35RDEPENDS:${PN} += "opencl-clang"
36
37EXTRA_OECMAKE = "-DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DIGC_BUILD__VC_ENABLED=OFF"
38
39BBCLASSEXTEND = "native nativesdk"
40
41UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"
42
43FILES:${PN} += " \
44 ${libdir}/igc/NOTICES.txt \
45 "